Google Pay does not work | All devices



Rep: (2305)
Google Pay does not work

Google pay » | Magisk - The Universal Systemless Interface » | SafetyNet Helper Sample »
The topic fully applies to all
Forum Rulesandmessage template


This topic discusses how to launch Google Pay on devices with an unlocked bootloader, with superuser privileges, and with custom firmware installed.
>>FAQ<<

DProblem solving
Dear users!
Due to the frequent cases of random Google Pay crashes, never manually update Google Play services until the Magisk update appears, which bypasses the updated SafetyNet network.
The problem is not in Magisk, the cause here is primarily the Google developers themselves, who seem to be trying to improve the protection of the Google Pay service.
At the moment there is no 100% solution to this problem, all possible solutions are in the topic header and FAQ
Auseful links
For quick solutions to problems with the GP, please indicate the model of your device, GP version and describe the problem in detail.

Messages that are not related to the topic of discussion (offtopic) are deleted without warning.


The curator of the topic isRayan. On filling in caps obraschatsyaQMS.


Post has been editedRayan - 07.10.20, 06:53
Reason for editing: Manual Certification



Rep: (5)
* ... PA ... ,
I understood you
I explain
As I was checking out the work of NFC
There is a card of the Moscow metro. When I present, the reading error occurs. But as with all phones with NFC
There is a second phone with the same NFC. I present to each other. Appears interface android beam
Consequently the working unit
Apologies for the excessive stupidity

Post has been editedPRO100GREEK - 03.12.18, 19:07



Rep: (299)
* PRO100GREEK , And here Bim android? Here are discussing payment, rather than the transfer of funds nfc data. So do not check payment.



Rep: (4132)
PRO100GREEK @ 02.12.2018, 17:01*
Xperia Z5 on lineageOS 14.1
version of the Linux kernel with the what?



Rep: (5)
* W.Master ,
3.10.84



Rep: (2)
Hello!
I can not run on mi 6 guglpey, writes that perhaps installed Ruth on the phone, the bootloader is unlocked, but many try ways different and does not work, the various applications they write that the phone is not root, for guglpey writes have Ruth, tell what on the moment there is a way to Root your phone and rutovsky not what I would have for probyval and this and that ...

Post has been editedevgeniymc777 - 05.12.18, 12:26



Rep: (72)
* evgeniymc777 , MI6 was unlocked bootloader. I blocked with data loss. Now it works, but what about the release have not tried, maybe hemorrhagic



Rep: (10)
Good afternoon! Guys, tell me please how it is possible to bypass the bootloader unlocked without installing Magisk, and it slows the whole system ?! I Masik 1.5 for gemini (miui 10). With Magisk everything works, but damn system so slow (



Rep: (91)
I leave immediately for themselves and for history.

ApparatusNubia z17 mini s, LineageOS 7.1.2. Stoke have not tried it, because all life on CM / LAOS and change to something I'm not.
1. JustMagisk17.1: card added, payments are made. In both points magisk green,SafetyNet Testpasses.
2. Submittingsystemless xposed89.3: It is red, the card is not added, the payments do not pass. If xposed off at magisk, then everything becomes as in claim 1. When switched on again, the map remains, but the payments do not pass.
3. With the included add xposedNo Device Checkdirectly from the turnip xposed. In magisk greens ctsProfile, basicIntegrity remains red, SafetyNet Test fails. Maps are added. If you turn off Xposed, the cards are added, payments are made. After switching xposed to add maps, the map remains the passes 1-3 and the payment goes on to say that the device can no longer be used for contactless payments.
4. With the included xposed tried all three No Device Check outthis post. In magisk both items turn green (which is reassuring) but SafetyNet Test still fails and the card are not added. If you turn off Xposed, the cards are added, payments are made. After switching xposed to add maps, the map remains the passes 1-3 and the payment goes on to say that the device can no longer be used for contactless payments.
5. yet tried (without success, the two points in magisk red): DeviceSpoofingTool4Magisk-v1.0.1.1AL (v17000) (3MF) .zip, magisk-gemini-safetynet-props-v3.zip, MagiskHidePropsConf-v2.6.5.zip , Petnoire's_SafetyNet_Spoofer.zip, universal-safetynet-fix-v1.10.1.zip, universal-safetynet-fix-v2-beta-5.zip, Universal-safetynet-fix-v3.zip. Links do not bring - to look lazy again.

Conclusion: magisk work out fine, but you can hide Xposed only xposed, magisk neprichem here. Xposed brings me much more good than pay phone at the checkout, so choose it.

By the way, the moduleDeviceSpoofingTool4Magisk-v1.0.1.1AL (v17000) (3MF) .ziphelped to green both counts in magisk on the Samsung Galaxy A5 2017 on LineageOS 14.1 from the official site. What's up with xposed payments and, unfortunately, did not have time to check. I think that the situation is the same as described above.

Continue testing, unfortunately, I can not, the unit passed back to the store. In my family devices (profile) can not NFC. At the time of their purchase contactless payments did not plan to use it, so the presence of NFC did not matter.

Post has been editedraven428 - 09.12.18, 10:12



Rep: (164)
Device 10 Honor, freshly bought.
ROOT is missing.
The phone has 3 uchetki Google, a Google Pay only sees 2 uchetki - third simply do not have.
Uchetki working, it is added to the map.
How to treat?



Rep: (18)
All privet.podskazhite where to dig: is not added to the map GP.pishet
Attached Image

Phone: xiaomi
Attached Image

P.S.:na 7 bucket, miui 10, global stability, all rabotalo.ruta not locked bootloader.

Post has been editedandrejj225 - 09.12.18, 17:02



Rep: (0)
On mi 5s plus 8. Android bootloader unlocked. Google Pay does not work. How can I fix it? Thanks in advance.

A photo
Attached Image


Post has been editedBOYAZID - 09.12.18, 19:35
Reason for editing: Spoiler



Rep: (72)
* BOYAZID , Well, how much time to talk. The cap has everything, or lochim loader with the loss of all data, or rutovat, hang magistik and take a tambourine



Rep: (46)
raven428 @ 8.12.18, 8:55*
By the way, DeviceSpoofingTool4Magisk-v1.0.1.1AL module (v17000) (3MF) .zip helped to green both counts in magisk on the Samsung Galaxy A5 2017


At some point I stopped working payment. Not tested. The specified module magisk decided this problem without dancing.

Leeco le pro body 3 x720, sw official 026s



Rep: (1)
PavCo @ 09.12.18, 20:20*
... or lochim loader with the loss of all data, or rutovat, hang magistik and take a tambourine

Those. These actions lead to a full-fledged work of Google Pay ?! Today was Mitino market for a similar problem (MI 8 installed globalkoy 10.0.3.0., To start working after this "face"but not a full-fledged operation of Google Pay), And so, I was told that online banks do not like rutovannye phones, do not know if this is true, but somehow I do not feel like finding a full Google Pay, losing online banks. And the advice was simple - wait for the next firmware, which will eliminate this bug, both in the present with a face.



Rep: (101)
Today at the store as usual launched nfs and payment, payment failed. I run the application - issued:
Attached Image

Delete, clear the cache / data reinstalled, rebooted - bestolku.



Rep: (1)
Mi5s plus unlocked after the last official update the firmware, guglopey earned before was not working.

Post has been editedmorlock777 - 11.12.18, 06:23



Rep: (709)
With the end of November, I stopped working on Samsung nerutovannom a8. FAQ Technical support:
Hello, Basil!
Unfortunately, the use of Google Pay at the Samsung, which is set MyKnox application can not be phones. Samsung engineers are working to solve this problem.
To pay for the purchase in the shop through Google Pay, use a different device.
If you have any other questions about Google Pay, please contact us and we will try to help.
Respectfully,

Eliza
Google Support

Google пїјSpravochny Center
В© Google Inc., 1600 Amphitheatre Parkway, Mountain View, CA, 94043, SSHAпїјпїј

Rights Zadornov was late!
 




Rep: (1)
All greetings !!! I bought a machine of MI5, anything with it did not do - no sewing, no rutoval, but Google does not work drink. Supersu really why it is installed but not working. What to do?
Attached Image
Attached Image



Rep: (1)
It is interesting to listen to the owners of vehicles rostestovskih ...;)



Rep: (367)
Oneplus 5T

Solving the problem with idle Google Pay (Correction SafetyNet on uncertified firmware (ctsProfile: false))

Instructions for those who have a Root:

Method 1:
1) Go to the MagiskManager ->Repository
2) We seek and set SaferyPatch
3) Making restarts


Method 2:
1) Go to the MagiskManager ->Repository
2) We are looking for and install two modules: MagiskHide Props Config and Busybox for Android NDK ->Reboot the phone
3) Set the terminal, for example this one:Terminal
4) Run and enter: "props", give permission Root rights.
5) Select the point "1" - Edit device fingerprint. (To select: write "1" and press "the Enter" (the arrow on the keyboard)
6) Now select the point "f '- Pick a certified fingerprint.
7) Then "12" - OnePlus
8) "6" - OnePlus 5T (8.1.0)
9) confirms the action, write "y" and do a reboot, too, "y".
* List of all prints of the original firmware OnePlus 5t (China / Europe / beta / stabilka) for use with MagiskHide Props Config:It does not work Google Pay (Post SMACL # 81792503) We say thanks: SMACL


For those who do not have ROOT

Now try this option:


The phone will reboot and everything will work!

Post has been edited~ Skyline ~ - 29.01.19, 15:03
Reason for editing: Updating instructions


Full version    

Help     rules

Time is now: 19/10/20, 20:56