DD-WRT - Alternative Firmware | [firmware] General theme. FAQ, software discussion, tips, problem solving

Rep: (48)
OpenWrt / LEDE (General theme) | Build OpenWrt / LEDE from source | Collect bin (dump) for the programmer | Upgraded UBOOT loaders


DD-WRT - free alternative firmware for wireless routers

Attached Image

Latest version:See the official FTP
In this topic, you must place images under the spoilerPicture

Difference DD-WRT firmware from factory
First, it is worth noting that DD-WRT firmware is an operating system based on the Linux kernel. Even with the default settings it has a very wide functionality, much wider than in the factory firmware. Built-in components such as FTP server, Samba, WOL and more. Through the Web interface, detailed statistics and load on the channels of the local, wireless network and the Internet are available, as well as the load on the processor and the memory of the router.

If you configure the router to install additional packages, you can turn your router into a home media server. A connected hard drive with a torrent client installed, broadcasting ITPV via HTTP, for viewing via wi-fi. If you have a TV with DLNA standard support, you can connect the TV to the router and watch IPTV, as well as watch movies from your hard drive.
13 languages ​​(including Russian)
802.1x (EAP (Extensible Authentication Protocol) encapsulation over LANs)
Access Restrictions
Adhoc mode
Client Isolation Mode
Client Mode (supports multiple connected clients)
Client Mode WPA
DHCP Forwarder (udhcp)
DHCP Server (udhcp or Dnsmasq)
DNS forwarder (Dnsmasq)
Dynamic DNS (DynDNS, easyDNS, FreeDNS, No-IP, TZO, ZoneEdit, custom, and others)
Hotspot Portal (Sputnik Agent, Chillispot)
IPv6 Support
MMC / SD Card Support (hardware modification required)
NTP client in a client-server basis
Ntop remote statistic
OpenVPN Client & Server (only in -vpn build of the firmware)
Port triggering
Port Forwarding (max. 30 entries)
PPTP VPN Server & Client
QoS Bandwidth Management (Optimize for Gaming and Services / Netmask / MAC / Ethernet Port Priority)
QoS L7 Packet Classifier (l7-filter)
RFlow / MACupd
Routing: Static entries and Gateway, BGP, OSPF & RIP2 via (BIRD)
Samba FS Automount
Syslog to remote server
Rx / Tx Antenna (Select or Auto)
Uptime / Processor Utilization
Site survey
SSH server & client (dropbear)
Startup, Firewall, and Shutdown scripts (startup script)
Static DHCP Assignment
Style (Changeable GUI; v.23)
Supports New Devices (WRT54G V3, V3.1, V4, V5 and WRT54GS V2.1, V3, V4)
Telnet server & client
Transmit Power Adjustment (0-251mW, default is 28mW, 100mW is safe)
Wake On Lan client (WOL)
WDS Connection Watchdog
WDS Repeater Mode
Wireless MAC Addresses Cloning
Wireless MAC filter
WMM (Wi-Fi Multimedia QoS) or Wireless Multimedia Extensions (WME)
WPA over WDS
Xbox Kaid (Kai Engine)
Web Interface Screenshots
List of supported devices
How to flash (install) DD-WRT

factory-to-ddwrt.bin - file for installing DD-WRT from under the router's native firmware.

webflash.bin - file for updating from already installed DD-WRT.

For some models, only one file is available for all operations.

Forthe originalDD-WRT installations:

In the address bar of the browser we typehttp://,depends on the router, enter the data for authorization and update the filefactory-to-ddwrt.bin through the standard update menu in your router.
After some time, the router will reboot, after which you will see the updated interface (DD-WRT's address is by default). On the main page when you first start you need to specify the username and password for administration.
Firmware dd-wrt installed, you can proceed to configure. (It is also recommended to do a reset to the factory settings after the firmware and before the setting)

Esli you are having problems it is impossible to go to the admin panel DD-WRT firmware after, go to the network connections on your computer and make sure that the ip addresses are given correctly: ip: 192.168.1.xxx (last digit may vary) Mask: gateway: If the addresses are different, then the easiest option to restart the network card (.. On and off again when the network asks for dhcp addresses), if this does not work, enter manually, for example ip, mask: Gateway: 192.168. 1.1 and try again to enter the browser to the address
Going to the web interface of the router, the tab "Settings" - "Basic Settings" - find this item:
Attached Image
Must be "DHCP server", if not, put.
The fact is that if there is a "redirection" your router will redirect the provider's IP address to your computer, that is, it will work as a switch.

ForupdatesDD-WRT already installed:

In the DD-WRT menu, select “Administration” - in the submenu, select the “Firmware upgrade” item. Click on the button “select file” and specify the firmwarewebflash.bin which was downloaded earlier. Click on the “Upgrade” button, the software update process will begin.

Options for rolling back to stock (native) firmware
Important!If you do not know how to return the stock on your router or do it for the first time, before performing any operations with the router, it is better to ask in this topic or topic visited by your router.Not all methods are universal., each router needs its own approach.

AT: How to properly flash the router?
  • Do not flash the router via WiFi; connect it to your computer with a network cable;
  • Before and after the firmware, make a hardware reset of the router (for example, "30/30/30");
  • Disable firewalls, antiviruses and ad blockers on your computer;
AT: What is "Reset 30/30/30"?
ABOUT: Press the reset button and hold it. After 30 seconds, turn off the power without releasing the Reset button. After another 30 seconds, release the Reset, turn on the power, wait until any other light on the router lights up except for the power supply, or the PC does not see the router, again we hold the Reset. Wait another 30 seconds and release the reset.

AT: How to view the system log?
ABOUT: You must first enable the syslogd service in the Services tab. (The field with the server name can be left blank.) And follow the link, The page can be accessed only through the address bar.
If you don’t open the System Log page, then you have an old firmware version, and the log messages are written to the file / var / log / messages, which can be viewed with the commands cat, tail, more, less, etc.

AT: How to connect telnet to the router with DD-WRT?
ABOUT: Open a session in telnet client with the address of the router (by default and the standard port (23). When prompted for a username (login), enter the standard root name - even if you changed the username to log in to the web interface. And when prompted for a password, enter the password you set for the web interface.

AT: How to load into the router not one script, but two?
ABOUT: Put the & sign at the end of the first script and load the second one. If you later need to load the third one, put the & sign at the end of the second script, etc.

AT: The Russian language does not work. Why?
ABOUT: Most likely the problem is in the firmware, the Russian works again in all releases of 2016. Also in the old stable versions.

Q: "retracker.local" stopped working, what to do?
ABOUT: It is necessary to turn off "No DNS Rebind" in the section "Services" - "Services" - "DNSMasq".

Q: Can I enable HTTPS?
ABOUT: You can, but to use it you need a special browser. Also, if you uncheck HTTP and leave only HTTPS, then you will most likely have to do a reset, since you will not access the Web GUI through a regular browser. (If you uncheck both checkboxes, you won’t go to the web interface at all)

Q: Does Universal Plug and Play (UPnP) work?
ABOUT: Yes, but you need to enable it manually, in the section "NAT / QoS" - "UPnP"

Q: I climbed in the settings and now I have a low rate of return or reception, why?
ABOUT: Most likely you have enabled "QoS", check if it is, then disable it.

Q: I set the TX Power to 20, but shows 16 dBm, why? I know for sure that the router can work on this power!
ABOUT: Perhaps the power is limited, because of the region you selected in the WiFi settings.Change to another, for example "US".

Q: TX Power has set 20 (or 21), the region is needed, but the router shows 19 dBm, why?
ABOUT: Maximum power can be obtained only on channel 6.

Q: How to set up a router in repeater mode?
ABOUT: Instruction

Q: How to reassign a burned out WAN port to a LAN?
ABOUT: We read here .

Q: How to get the maximum WiFi speed on routers with N mode
ABOUT: We read here .

Q: It is written on the official website that I lose the warranty when installing DD-WRT. This is true?
ABOUT: Theoretically, yes, but you can flash the stock, and most routers will be out of the box.

Q: I need a built-in OpenVpn, is it in this firmware?
ABOUT: Yes, but only in firmware for routers with more than 4 mb. of memory. (You can find out how much flash memory in your router model, for example, in WikiDevi )

Q: I need the router to automatically turn on and off WIFI on a schedule, DD-WRT can it?
ABOUT: Yes that's instruction

Q: DD-WRT does not allow the provider’s local resources (personal account, etc.), what to do?
ABOUT: You just need to remove one tick. instruction

Q: How to change the TTL value on the router?
ABOUT: Here is instruction

Q: How to enable multicast on DD-WRT?
ABOUT: Instruction

Q: How to make the router work as a switch, but with wifi?
ABOUT: Instruction

Q: How to make the router automatically restart at the right time?
ABOUT: Instruction

Q: If you don’t see the neighboring computers on the router’s local network (for example, on Samba)
ABOUT: Instruction

Q: I switched the language to Russian and in some places (for example, on the tab of the MAC filter of a wireless network) there are cracks.
ABOUT: Yes, this is a bug; it is very easy to overcome - by forcibly switching the page encoding in the browser to UTF-8
(for example for chrome there is an encoding menu plugin)instructionAlso, this bug is missing in the version of r27086 and earlier.

Q: How to activate the firmware on Ubiquiti routers.
ABOUT: No Only buy a license for dd-wrt on the official site. There are no working key generators.

Q: My provider has local sites in the .local zone, having trouble accessing them. How to be ?.
ABOUT: Here is instruction

Q: I need to block a site on my home network, for example, youtube. How to do it?
ABOUT: Here is instruction

Q: I heard that using dd-wrt, you can somehow access Pandora, HBO Now, Spotify, Amazon Video and Netflix outside the US without using vpn. How?
ABOUT: Here is instruction

Q: I need to get internet via wifi and distribute it as usual, that is, connect the router with a "client". Can this be done?
ABOUT: Yes that's instruction

Q: In my router has a usb port, may I connect a USB flash drive or HDD?
ABOUT: Yes that's instruction

useful links
Download DD-WRT

Important! Firmware for routers Ubiquiti paid Key generators does not exist
Important! In the most recent versions can not work full-time update method through the Web interface. Accordingly, to return the factory firmware file webrevert also will not work.

Topic Curator: Topic with no curator

Post has been editedM | A | G - 02.07.20, 11:16
Reason for editing: The solution to the inability to update firmware problems

Rep: (574)
* uc3a,
https://wikidevi.com/wiki/TP-LINK_Archer_C60_v2.0That percent is the same
What is the difference for which market TL-WDR7400 rev.2?

And such that look for ready-made firmware for noname Chinese router or look for ready-made firmware for European (exactly the same, but called differently). What do you think for which one is faster? :)

Rep: (0)
stp101 @ 04.01.17, 14:24*

Yes, the QCA9561-AL3A processor is such, but in the TL-WDR7400 rev.2 the 5GHz chip is not QCA9882 but QCA9880, not the fact that it will work with this firmware.

And is it possible to assemble the DD-WRT firmware for the TL-WDR7400 rev.2?

Rep: (574)
And is it possible to assemble the DD-WRT firmware for the TL-WDR7400 rev.2?

Distinct manuals are not particularly on the topic of assembly, so I can not say anything about this.

Rep: (574)
A small instruction on how to make the DD-WRT router automatically restart at the right time.

So, first we need to make the router get the current time from the time server, for this we go to "Settings" - "Basic Settings" at the bottom there will be the "Time Settings" item there we enable "Time Service Client (NTP)", then we need to set the NTP server in the item: "IP / Server Name", for example pool.ntp.org and select your time zone, then click apply.
Next, go to the tab "Administration" - "Connection Support" and turn on the item "Planned Reboot"
We adjust as it is necessary for us, we click to apply and we reboot a router. Is done. The time that the ntp server specified can be viewed from the top right.
Attached Image
Attached Image

Rep: (237)
* uc3a,
Sometimes versions for China are different in hardware, which can create problems.
* stp101,
probably then it is already better to indicate regional than general, for example europe.pool.ntp.org. Or even: ru.pool.ntp.org. Instead of ru, ua, by, etc. can be specified. I will not give a complete list. Before them, there are still fewer transitions, in general, with regional over time, they will not be sent to a server anywhere in Asia or in America (unless of course you choose the appropriate region)

Post has been editedyhnyhn11 - 06.01.17, 02:13

Rep: (574)
yhnyhn11 @ 06.01.17, 02:04*
Or even: ru.pool.ntp.org

And if I read and set it up in the states? : D I gave thatfor example pool.ntp.org, and everyone can configure whatever server they want.
Well, a complete list of servers, you can look athttp://www.pool.ntp.org/ru/

Post has been editedstp101 - 06.01.17, 02:19

Rep: (237)
* stp101,
well, I wroteeg ;), in the states, you can specify north-america or south-america, but still I think the general populationsavagemessiahzine.comlives in the vast areas of Ru, Ua, and other Russian-speaking neighbors (who understand Russian)

Rep: (323)
Photo WDR7400
The secondhttps: //wiki.openwrt.o...h/tp-link/tl-wa901nd? s[] = vlan roar 4 maybe some kind of Qualcomm QCA956x SOC, also for uboot is setting forBooting qca956x series
Booting qca956x
CPU revision is: 00019750 (MIPS 74Kc) ath_sys_frequency: cpu 750 ddr 400 ahb 250

For dd-wrt there is
DIR-869 (AC1900) A1 Qualcomm QCA9563 @ 750 and Qualcomm QCA9880 (b / g / n 3x3: 3 an / ac 3x3: 3) rel.26947
XD3200 (AC1200) Qualcomm QCA9563 @ 750 and Qualcomm QCA9882 (b / g / n 2x2: 2 an / ac 2x2: 2) rel.29816
in both flash 16M

It is necessary to see the difference between the chips QCA9561 and QCA9563, it is also desirable to have the port ready at the ready.
Attached Image
Attached Image
Attached Image
Attached Image

Post has been editedstp101 - 08.01.17, 22:02
Reason for editing: SPOILER!

Rep: (574)
Balian007 @ 08.01.17, 11:53*
Need to see the difference between the chips QCA9561 and QCA9563

Attached Image


Rep: (323)
need something from
... QCA9563 and QCA9561 are two series of Qualcomm SoC Dragonfly. The only different is QCA9563 w / o internal switch. It has one GMAC with SGMII interface. But they
have the same device ID (0x1150) ....

Rep: (0)
good day!
we have Belkin Play Max Model: F7D4301 v1
during the firmware accidentally pulled the power supply! now it does not respond to the LAN in any port !!! how to lift? what to do?

Rep: (574)
woldemarusan @ 11.01.17, 12:57*
during the firmware accidentally pulled the power supply!

epic fail
woldemarusan @ 11.01.17, 12:57*
what to do?

For example google.
Since we do not have a Belkin router topic on the forum, let's google for you:
Google said that Belkin routers have a recovery mode, the same as in d-links, the last link describes everything in detail how to call it, the item Enable Recovery Mode on Router. Try it.
P.S. Well, further discussion of recovery will be considered oftop for this topic, there are links, there is Google too, the initial info. for reflection too, if anything, we usehttps://translate.google.com/Good luck with the recovery.

Rep: (9)
Hello, friends.
Such a problem. I decided to flash my ubiquiti airrouter on openWrt
After the firmware, the router died. He is trying to boot the LEDs blink somewhere for a second and then turn off and on again. Flashing the same way lan on the computer the connection then appears then disappears. (I think this is a failure, a checksum error)
Point pinged downloaded DDWRT under your router. through the program Tftp2 successfully flashed. The router came to life in the web interface you can go. After that I flashed another webflash-firmware on top.
The settings of the router are not saved, probably due to the fact that the firmware is a trial? I would buy the firmware if I was sure it was a trial freak.
I tried to roll back to the stock firmware. the router does not want to work on the stock
I tried the same old firmware, please tell me what can I do about it?
Rummaged a bunch of information in this does not help.
Please do not delete the message. If you can write in the LAN

Post has been editednokiaman1997 - 13.01.17, 23:55

Rep: (574)
nokiaman1997 @ 13.01.17, 23:53*
The settings of the router are not saved, probably due to the fact that the firmware is a trial?

Not sure, but something tells me that it's not about trial, but about the fact that it is crookedly established.

Rep: (11)
Good day !! I have a body WR841N v9, installed on it 05-27-2015-r27086, how stable I ask!
Everything is set up everything suits, but now I can not go to the receiver via cable, to throw the settings for sharing.
Aipi and the Internet on rese is, tell me what to do to access via ftp on res?
Dcc296 then it does not start up on the res! On the stock firmware, there were no such problems, but the speed on the wifi on the drain is just sadness !!

Rep: (574)
* staf77,
What kind of receiver? He generally glows in admika as connected, pings pass?
On r27086, there seemed to be no such problems, but still try. After you need to restart the router.
http: //savagemessiahzine.com/forum/index.php?s=&showtopic=734671&view=findpost&p=55778829

Post has been editedstp101 - 14.01.17, 07:15

Rep: (11)
Res Amiko SHD-8900 Alien, Thanks for the help! Disabling SPI firewall: thank_you:

Rep: (574)
Staf77 @ 14.01.17, 08:15*
helped to disable SPI Firewall

So you were not trying to connect from the internal network of the router, but from the Internet?

Rep: (11)
So you were not trying to connect from the internal network of the router, but from the Internet?

Sorry for the inaccuracy just got on the security tab and turned off the Firewall, But before that you did as you advised
swconfig dev eth0 set enable_vlan 1
swconfig dev eth0 set apply
After rebooting the router, access to the res appeared able to access it! (By LAN)
The second day I set DD_WRT, I will begin to understand the giblets.

Post has been editedstaf77 - 14.01.17, 08:33

Rep: (574)
just went to the security tab and turned off the firewall, but before that did as you advised

And if you now turn on the firewall again and restart the router, will there be access? It just became interesting to me, there is still a cant in r27086 or not, on my slips on this revision everything worked without commands.

Full version    

Help     rules

Time is now: 25/10/20, 8:52