LINUX on UEFI 32bit | [linuxos] tablets and TV box INTEL Bay \ Cherry Trail



Rep: (126)
LINUX on UEFI 32/64 bit


The topic discusses installing any kind of LINUX on tablets and TV boxes on INTEL Bay [Cherry] Trail with UEFI 32 / 64bit

Specifications
Specifications:
INTEL Bay [Cherry] Trail.
The screen size, touchscreen, Ram, Rom, it's all not important, they are almost identical, in tablets on Intel.
additional information
If you were able to launch Linux on your machine, write its name, what does not work and what works and how you launched it.
P.SThe topic is forbidden to discuss dualboot Android / Windows only linux / windows
Linux builds
Instructions
Drivers and sources
Kernel

Neighboring topics



There is no curator in the subject. For questions about filling the caps, please contact me atQMSif you found an interesting article or information.


Post has been editedM | A | G - 20.04.20, 18:06
Reason for editing: + autorotation guide



Rep: (1)
* laert00 Decided to introduce Kubuntu file bootia32, I wrote nomodeset and a miracle! Graphical user interface has appeared!
Honestly, I would navryatli guessed. Thanks!



Rep: (1)
Decided to put of Ubuntu, something like a nomodeset graphical interface appears, the installation was successful.
But the system does not zagruzhaesya, black screen. Nomodeset I tried.



Rep: (11)
* StepaBon ,
Try to place the image of a linuxium:
https: //sites.google.c.../wwwlinuxiumcomau/isos



Rep: (1)
* blue_2h,
there is even a nomodesetom (where ubuntu safe graphics, it seems there is already registered) will not ship, a black screen.



Rep: (20)
Lord, zdarova. Asus t100ta, efi x32. I put on him all the time through the system ubiquity -b without bootloader. But then people from the forum threw me files for efi / boot directory to stick. The system arose from a standard installer without hornbeam errors. If someone is willing to test on other Planchet, the link to the file I can throw on the forum



Rep: (1)
So. IMac is available in 2006 on the basis of processor Intel core 2 duo and Uefi x32.
I tried to put Ubuntu, Kubuntu. It seems to get up (on), but after hornbeam black screen (with nomodesetom). Now, hornbeam not put (when trying again ustanoivit).

If someone can throw off instructions (step by step) as to establish ubuntu (nk from the launch of the stick). I'll be very thankful. Thanks!



Rep: (1)
Help solve the problem with rotated counterclockwise image ... all methods of instruction in the header tried, tried different scripts, etc., but after every turn on all of the old left, helps only after each start command xrandr -o right
Snow leopard netbook NB29, aboard linuxmint-20-cinnamon-64bit, everything works Tipo wifi, sound, blyupup ... trouble with the screen only

By the way everything is put virtually no problems ... put up with the bugs and grab2 without leaving later in the terminal:
sudo chroot / target
mount devpts / dev / pts -t devpts
apt-get update
apt-get install grub-efi-ia32
grub-install / dev / sdX
update-grub
exit

Post has been editedGriha60 - 07.11.20, 16:00



Rep: (1)
Please help, here is my 2006 iMac with intel core 2 duo, uefi 32.
Now I should Kubuntu 64bit, hornbeam deliver.
If someone fumbles, tell the kernel boot parameters to the picture was, in fact with no nomodesetom pictures.
Tried: ro quiet splash (and there is still something long, starts at $), ro nomodeset and then that starts at $, just tried to nomodeset ro.
When you try to specify the parameters nomodeset quiet splash $ ... PC restarts



Rep: (11)
* Griha60 ,
xrandr in autostart, what's the problem?



Rep: (1)
* blue_2h,
Does not work



Rep: (11)
* Griha60 ,
Try it in ~ / .xinitrc to register
And then I suppose you run the command to start the X's, not after



Rep: (1)
* blue_2h,
No such file



Rep: (11)
* Griha60 ,
So create))

https: //wiki.archlinux...1%82%D0%B5%D0%BC%D1%83

Post has been editedblue_2h - 08.11.20, 14:46



Rep: (3)
Tried to Atombuke Irbis NB45 (Z3735) by Shell (32) and Grub (bootia32.efi and different from Arch) run some sort of version of Live CD Puppy,
but so far unsuccessful attempt - probably what it is, misunderstandings opportunities existing versions of Grub EFI
(For some, it is necessary to explicitly specify the location of the file where it grub.cfg placed and possibly root directory
Example
set prefix = (hd0, gpt1) / Boot / Grub
set root = (hd0, gpt1)
normal

for other teams do not have enough staff, if you do not find / i386-efi yes and what the commands are not recognized (perhaps more "new / old" and there is in the assembled bootia32.efi)
I saw an interesting solution in one startup.nsh file when he himself, by trying to find the name of the file directory where it is located and set its working (in the draft from the EFI BIOS update application Github)
About this content
@echo -off

if exist fs0: \ EFI \ BOOT \ fparts.txt then
set base "fs0:"
endif
if exist fs1: \ EFI \ BOOT \ fparts.txt then
set base "fs1:"
endif
if exist fs2: \ EFI \ BOOT \ fparts.txt then
set base "fs2:"
endif
if exist fs3: \ EFI \ BOOT \ fparts.txt then
set base "fs3:"
endif
if exist fs4: \ EFI \ BOOT \ fparts.txt then
set base "fs4:"
endif
if exist fs5: \ EFI \ BOOT \ fparts.txt then
set base "fs5:"
endif
if exist fs6: \ EFI \ BOOT \ fparts.txt then
set base "fs6:"
endif
if exist fs7: \ EFI \ BOOT \ fparts.txt then
set base "fs7:"
endif
if exist fs8: \ EFI \ BOOT \ fparts.txt then
set base "fs8:"
endif
if exist fs9: \ EFI \ BOOT \ fparts.txt then
set base "fs9:"
endif
if exist fsa: \ EFI \ BOOT \ fparts.txt then
set base "fsa:"
endif
if exist fsb: \ EFI \ BOOT \ fparts.txt then
set base "fsb:"
endif

% Base%
CD EFI \ BOOT
bootia32.efi


Even tried bootia32.efi of assembly LiveCD Windows PE (Strelec assembly) after the start of which it can be redirected to another run Grub Efi
What, I wonder, that with this disc on the beech and run EFI graphical application to test memory with operating arm (its speed just a little) This very WinPEs LiveCD does not boot on this beech, although start his, but gave screen of death.

ESP is a hidden partition on the beech "small" (100m) and there are a lot that are not located - svbodno about 36Mb (if not to touch anything in the UEFI / Microsoft and UEFI / Recovery)
(To him that a copy is loaded from an external LiveCD Puppy c EFI)

P.S. When, this, regular download any Live CD Uefi image (by selecting the download source in BIOSe) 32/64 occurs normally.
Of the unemployed - have yet to sound issues. (It is not even visible in the system)

Post has been editedKPGA - 09.11.20, 20:46



Rep: (3)
And, is there where the resource with which the applications made to run on UEFI?
At the same Github they are underrepresented, but what is there.

P.S. application Passmark memtest x86 (32) in the efi formatAttached fileMemtest_efД±.7z(444.95 KB)


Post has been editedKPGA - 09.11.20, 23:25


Full version    

Help     rules

Time is now: 16/11/20, 4:50