LINUX on UEFI 32bit | [linuxos] tablets and TV box INTEL Bay \ Cherry Trail



Rep: (126)
LINUX on UEFI 32/64 bit


The topic discusses installing any kind of LINUX on tablets and TV boxes on INTEL Bay [Cherry] Trail with UEFI 32 / 64bit

Specifications
Specifications:
INTEL Bay [Cherry] Trail.
The screen size, touchscreen, Ram, Rom, it's all not important, they are almost identical, in tablets on Intel.
additional information
If you were able to launch Linux on your machine, write its name, what does not work and what works and how you launched it.
P.SThe topic is forbidden to discuss dualboot Android / Windows only linux / windows
Linux builds
Instructions
Drivers and sources
Kernel

Neighboring topics



There is no curator in the subject. For questions about filling the caps, please contact me atQMSif you found an interesting article or information.


Post has been editedM | A | G - 20.04.20, 18:06
Reason for editing: + autorotation guide



Rep: (8)
screen autorotation and touchscreen matrix in almost any operating environment ubuntu.
In my case, I tested on LXQT

Link to githab -https://github.com/scadl/autorotate-linux

From the author of the script - Alexandr scadl
Very sumple script for automaticaly rotating your screen with gyroscope

This is a small tweak script, without which the possibilities of a transformer laptop are actually useless when working on most Debian Linux. Relying on various documentation and examples, managed to write a simple script that tracks the position of the laptop gyroscope via the monitor-sensor (from the IIO-SENSOR-Proxy package), and finding the change of its status through the InotifyWait (from the package of the Inotify-Tools), applies a series of commands to The Xorg (XRANDR) graphic server and the touchscreen matrix (XInput). As a result, it turns out correctly reacting to the change in the position of a laptop or a tablet running Linux.

This script is tested and used on the Dell Inspiron 13 (5378), under the control of Linux kUbuntu 18.04. It is with this device is taken the name of touchscreen, the first parameter passed to the team xinput in the body of the script.

If you do not have touch screen, use a shortened version AutoRotate_noTouch.SH script.
If there is - use basic AutoRotate.SH, but change the name of the touchscreen in quotes after xinput team.
If you do not know what it is, not izmenyate coordinates of the matrix! (This tsiferki at the end of each rotation of the team)


0. If not done before, we do transformation matrix correction . How do you know you need to do it or not. Run Ubuntu c flash no installation, and the system itself. Or on your tablet you have Ubuntu Desktop environment or Gnome Sell, the pereklyuichitsya him. If everything is correct rotates when you turn the tablet into a different position, then make correction, the transformation matrix is ​​not necessary.

1. For the success of the process, you must first configure the touchscreen work in this guide - Setting TouchScreen-on on the tablet Irbis_TW78


2. In the best tradition of making the terminal one by one the following commands:
sudo apt-get update


sudo apt-get upgrade


Then install the following packages, if you are not installed:
This package should already be installed if you performed 1 point, well navsyaky case leave the team immediately.
sudo apt-get install iio-sensor-proxy


sudo apt-get install inotify-tools


3. Download the script on githabe (link at the beginning of the post) or here Attached fileAutoRotate.zip (844 bytes)


And otkyvaem script from a text editor. We find an inscriptionELAN Touchscreen and replaces it with the name of the sensor (select / copy / find / replace all the values), which can be found by typing in the terminal

xinput


In my case -Silead GSLx680 Touchscreen Attached fileAutoRotate - Silead GSLx680 Touchscreen.zip (820 bytes)


#! / bin / sh
# Auto rotate screen based on device orientation

# Receives input from monitor-sensor (part of iio-sensor-proxy package)
# Screen orientation and launcher location is set based upon accelerometer position
# Launcher will be on the left in a landscape orientation and on the bottom in a portrait orientation
# This script should be added to startup applications for the user

# Clear sensor.log so it does not get too long over time
>sensor.log

# Launch monitor-sensor and store the output in a variable that can be parsed by the rest of the script
monitor-sensor>>sensor.log 2>&1 &

# Parse output or monitor sensor to get the new orientation whenever the log file is updated
# Possibles are: normal, bottom-up, right-up, left-up
# Light data will be ignored
while inotifywait -e modify sensor.log; do
# Read the last line that was added to the file and get the orientation
ORIENTATION = $ (tail -n 1 sensor.log | grep 'orientation' | grep -oE '[^] + $')

# Set the actions to be taken for each possible orientation
case "$ ORIENTATION" in
normal)
xrandr -o normal && xinput set-prop "Silead GSLx680 Touchscreen" --type = float "Coordinate Transformation Matrix" 0 0 0 0 0 0 0 0 0 ;;
bottom-up)
xrandr -o inverted && xinput set-prop "Silead GSLx680 Touchscreen" --type = float "Coordinate Transformation Matrix" -1 0 1 0 -1 1 0 0 1 ;;
right-up)
xrandr -o right && xinput set-prop "Silead GSLx680 Touchscreen" --type = float "Coordinate Transformation Matrix" 0 1 0 -1 0 1 0 0 1 ;;
left-up)
xrandr -o left && xinput set-prop "Silead GSLx680 Touchscreen" --type = float "Coordinate Transformation Matrix" 0 -1 1 1 0 0 0 0 1 ;;
esac
done



4. Run the script.
In some working environments it can be done by double-clicking on the script file. The author of the script file extension called zaklavnymi letters "SH", in this state, the script itself will not start. It is necessary to translate the extension to lowercase to looked - Navanie_skripta.sh. We click the right mouse button on the script, and open the "Properties" / "authorization". Tick ​​the "Make executable".Important!!! If you transferred the file rasshienie to lowercase, then in the console Komad below, the need to write an extension to lowercase.In that way it can be done - it is necessary to do the following - go to the folder where the script is, in my case:
cd Downloads


Making the script executable:
chmod + x AutoRotate.SH


Run it:
./AutoRotate.SH


5. I should think:
5.1. how to add the script to autostart, so it starts with the start of the desktop manager of choice (water and password to login to the desktop).
5.2. It would be nice to come up with how to slow down the script to be able to fix the shield in position. In ubuntu-desktop and gnome-shell, you can disable autorotation, I would like to do the same.
In ubuntu-desktop and gnome-shell is not true, because there are standard things on the screen and turn the matrix, need only podkorektirovat correct position of the matrix. I wrote about this here -tyk.

5.3. I would like to make gestures to work in other environments besides heavy ubuntu-desktop and gnome-shell, such as LXQT. It is possible to configure the touchpad gestures through touchegg, but I have not yet figured out how to do it - if we can do, make sure you accomplish your goal.

P.S. If anyone can help with the implementation of paragraph 5 - I will be glad and always complemented this statement.

Post has been editedNarovchatus - 20.04.20, 12:40



Rep: (0)
Save the image to a USB flash drive (which was successfully staged twice). At one point, I began to back up. with power outage interrupted the process and partition efi also appeared packed to 0 ... but not the essence. I decided to reinstall. Starting with a bang stick passes (Figure 1). At this point we would like to relax, but get errors (Figure 2) (Image 3)

I am a novice in Linux. I do not understand the reasons for, and have no idea how to fix it. Google did not help. It is advisable to get help with rescheniem. Intellectually I understand that this may be a bug with sections / memory stick / Hardy etc. But still need to be repaired.

Access is available to pre-installed on this netbook Linux operating system, so if you suddenly can help any manipulation through there the console, I will try and

В¤ The image of Linux Mint 19.3 Cinnamon
В¤ Record to USB through Rufus
В¤ Secure Boot is OFF
В¤ Start with a stick - normal flight
В¤ System 32 bit
В¤ The device - Prestigio Multipad Visconte 4U (better not to look, it is the Chinese HS, and the worst thing about it is the monster mutant BIOS UEFI which has no analogues in nature)
В¤ I repeat - twice reinstalled image, and everything worked. Work stopped after a failure in the backup. After this event, no longer runs Linux Mint from a USB drive.

Attached images
Attached Image
Attached Image
Attached Image



Rep: (88)
key85lvl @ 20.04.20, 14:32*
Starting with a stick - normal flight

"Hd0, msdos1 not found" - you mess with the partition table. Boot into the installed system, and you look the partition table on a flash drive (via gparted, for example) - is on her first partition to fat format?
key85lvl @ 20.04.20, 14:32*
Recorded on USB over Rufus

So you installed the system on a flash drive (installation, select the partitions, time zone, user password, etc.), or written down on her Rufus iso The samples you better define, plz.



Rep: (424)
Please do not scold severely, as a last resort to put in a corner: blush:
Deadline time Fedor 21yu put on nedobuk at 2014m.
3 years ago, after updating the company, prepared a partition on the system drive by Fedor - so only the hands are now reached ...
Fedor 31ya established successfully, except that instead of GRUB dialogue, given the choice of how and where to ship AXIS had a "happiness" to observe loading Win10. o.O



Rep: (424)
Launched Fedor ... touch OS boot selection keys ... from the BIOS ...
Sand me sweep do not ... I'll ...: hysterics:: wallbash:
p.s. What happened to the Linux bootloader ...



Rep: (131)
Dynamite @ 28.04.20, 10:21*
What happened to the Linux bootloader ...
Now Leon ↓ parteya and decided that the linux bootloader should be systemd-boot (former gummiboot). So it may in Fedora has already performed the task five-year plan?
Attached Image


Post has been editedCut in - 28.04.20, 06:42
Reason for editing: Added graphic



Rep: (424)
* Cut in
I try to understand.
Yesterday just had to urgently put Fedora, since It took the data from the old hard, which is not read Wendy, ahem ... a little burnt ...: blush:



Rep: (94)
* Dynamite For Windows also have ext2fs driver, who works with eht4



Rep: (424)
* laert00,
Hardy NTFS, apparently injured his 8 years of aging in the closet.
Backup data will have to reformat.



Rep: (9)
installed Kubuntu on Prestige 3gk's even a video filmed by Suteev current firewood for touch install



Rep: (0)
Prestigio MultiPad VISCONTE V
Installed Ubuntu 20.04 x64
With a loader X32.
All would be good, i.e. It fell almost everything smoothly. Several but
1. Switching sound when connected headphones does not occur
those. In manual mode, turn on the sound in the Headphone and turn off in the speakers through alsamixer.
Looks like a script that responds to connecting and disconnecting headphones
2. The screen orientation is correct only in the landscape position, during the coup into the portrait screen turns over to 180. And additionally, when you try to change (reduce resolution), the size is knocked on the part of the screen in the center and in no way unfolds XRANDR does not help, i.e. Now mode
Screen 0: Minimum 320 x 200, Current 1280 x 800, Maximum 16384 x 16384
DSI-1 Connected Primary 1280x800 + 0 + 0 Right (Normal Left Inverted Right X Axis Y Axis) 0mm x 0mm
800x1280 60.00 * +


When selecting another mode, it is created as it should be ~ / .monitors.xml
But the screen in the 4th part in the middle, i.e. The output area is constant in size and position A inside this small area already changes the position -o Left or -o Normal and permission.
I tried the CVT to create modes but assigning them to DSI-1 failed, says there is no such mode

Post has been editedr.andal - 04.05.20, 13:54



Rep: (37)
* laert00 ,

Grub Rescue sees sections, but Command Linux is not found

Grub from a flash drive - does not see FS sections on MMC

What to do?



Rep: (94)
* thehelixpg because it is Grub Rescue and not Grub Command Line
What sections on the FS?
GRUB is able to do load firewood for FS, if available in the section from which Grub launched

Post has been editedlaert00 - 05.05.20, 11:27



Rep: (37)
* laert00 Tell us more. Loading Grub with Live USB Ubuntu 20.04

Posted on 05/05/2020, 11:30:

* laert00 , Section EXT4



Rep: (94)
* thehelixpg You want using the flash drive bootloader to boot from the disk, right?
Then you load from the flash drive, click on the English, we fall into the command mode of the Grab.
We write Ls. What do you see?



Rep: (37)
* laert00 , (HD0, GPT1), (HD1, GPT1), (HD1, GPT2), (HD1, GPT3)
01- flash drive
11- EFI on MMC
12- SWAP.
13- Ext4.



Rep: (1)
3D Virus @ 02/16/18, 03:03*
I managed to perfectly adjust the size of the tacha to the job of downloading and unloading the necessary modules thanks for the idea of ​​* udarec,


More? How to do it?



Rep: (0)
Hello everyone, I came to you from Windows. I want to start to get acquainted with the penguin. Help choose the first assembly on my chuwi laptop 15.6 so that without lags and not very old

Post has been editedRavenoker - 07.05.20, 08:12



Rep: (37)
* Ravenoker , ubuntu lts 20.04



Rep: (2)
People, good health!
Installed Lubuntu 19.10 on IRBIS TW98. Herethere already wrote about it.
Installed from the flash drive, the AMD64 system itself, but slipped bootia32.efi to the desired folder.
Everything was established without any problems, with the turn of the screen on the G-Sensor-y did not bother, made simply through the XRANDR -O RIGHT.
Earned immediately:
1. WiFi
2. Graphics (Intel HD Graphics)
3. Sound and Volume Controller
4. Bluetooth (picked up the system, but nothing to check)
Touchscreen started after some bubbocks ... already many times described before me. Just executed instructions. Multitouch works through Touchegg.

Everything works well except cameras. There are two cameras in the tablet and both the system does not see anyone. Cameras (as it seems to me) are connected as something directly to the processor bus ... not via PCI / ISA / USB. Front camera there GC0310, rear - GC2355. I already read the network, but I did not find a solution, how to make them work ... And I really want ... Maybe someone will advise?


Full version    

Help     rules

Now: 30.11.20, 07:22