LINUX on UEFI 32bit | [linuxos] tablets and TV box INTEL Bay \ Cherry Trail



Rep: (126)
LINUX on UEFI 32/64 bit


The topic discusses installing any kind of LINUX on tablets and TV boxes on INTEL Bay [Cherry] Trail with UEFI 32 / 64bit

Specifications
Specifications:
INTEL Bay [Cherry] Trail.
The screen size, touchscreen, Ram, Rom, it's all not important, they are almost identical, in tablets on Intel.
additional information
If you were able to launch Linux on your machine, write its name, what does not work and what works and how you launched it.
P.SThe topic is forbidden to discuss dualboot Android / Windows only linux / windows
Linux builds
Instructions
Drivers and sources
Kernel

Neighboring topics



There is no curator in the subject. For questions about filling the caps, please contact me atQMSif you found an interesting article or information.


Post has been editedM | A | G - 20.04.20, 18:06
Reason for editing: + autorotation guide



Rep: (5)
DRAW @ 12/15/19, 10:10*
Therefore, it is necessary to see in the / sys / firmware / EFI / EFIVARS directory and not guess.

Before installing climbed there. There is a bunch of files. Need to find something specific?

Posted on 15/12/2019, 12:21:

Here is the size of the folder

Attached images
Attached Image



Rep: (5)
DRAW @ 12/15/19, 8:20*
By installing GRUB.


Attached images
Attached Image



Rep: (131)
* brokera
To delete directories, use the -RF key
Sudo RM -RF / SYS / Firmware / EFI / VARS / DUMP *

If there is no experience with the command line, you can try to run a file manager under the root, and delete from there.

Post has been editedCut in - 16.12.19, 08:31



Rep: (7)
Damn, like a lot of nuances. What firmware is best suitable for the IRBIS TW48 tablet? Can someone put on it?



Rep: (5)
DRAW @ 16.12.19, 08:30*
To delete directories, use the -RF key

OK. Thanks for the prompt
All the same files are not deleted. Though through the terminal, at least through the conductor (

Post has been editedbrokera - 16.12.19, 16:31



Rep: (8)
Brokera @ 12.12.19, 16:55*
And share your experience where and what to throw, what would the axle see WiFi?

In the header themes flashed across the shelves how to fastenWIFI

Post has been editedpetefree - 19.12.19, 10:22



Rep: (5)
Managed to install Linux on this instructionLINUX at UEFI 32bit (Post iillyyaa2033 # 74034680)
Bypassing the installation of GRUB when installing. But on the same instructions, install Grub fails. Frequently, you managed to install GRUB manually share experiences)



Rep: (5)
Everyone darned to try to install Linux on the tablet. Good luck to all



Rep: (94)
* brokera
You quickly surrendered)
GRUB UEFI32 installation option on UBUNTU


the essence of this (I did it with the bubuntie) - we put the system with Liv Yusb via ubiquity -b
She puts, everything is fine, everything without mistakes.
On the rebutting computer and ... again as a boot disk choose a flash drive
When the flash drive shows GRUB, press with and get into the GRUB console. This is unpleasant for many place, but still.
write
ls

We see a list of sections and disks.
We find in them that disk and section where our system through (for example)
Ls (HD0, MSDOS1) /


Farther manually write download commands:

SET ROOT = (HD0, MSDOS1)
Linux / Boot / VMLinuz * root = / dev / sdax **
initrd /boot/initrd.img-*
boot

ATTENTION! WARNING
In the commands above: where it costs "*" you need to press Tab for auto-section, because I do not know which kernel you will have. "**" instead of x should be the partition number on which the system is worth. If you put the system on the principle "Next, further, then, ready," to assume that it will be / dev / sda2. Another moment - I have a HP hard drive or EMMC, for example, it looks like / dev / mmcblk0p2. It is best to make sure in the upper disk name immediately after installation downloading again in Live and entering the command
lsblk -l


Sobstly, the most difficult behind.
It remains to put rust in the system and everything, you are great.

Sudo Apt Update; Sudo Apt Install Grub-EFI-IA32
sudo grub-install --target = i386-efi --removable
sudo grub-mkconfig -o /boot/grub/grub.cfg


Rebut and rejoice

Post has been editedlaert00 - 20.05.20, 23:40



Rep: (0)
Installed Fedora 31, jacket Bootia32.efi. Everything works except cameras and microphone



Rep: (5)
Laert00 @ 12/20/19, 22:41*
GRUB UEFI32 installation option on UBUNTU

THANK YOU SO MUCH!
If it were not for this instruction for DUM-Duma))) I would never have been able to install on the tablet!
Please add it to the header! I am sure that she will no longer help those who can not install at all)

People advise the on-screen clave for the tablet under Ubuntu.

Post has been editedbrokera - 23.12.19, 12:53



Rep: (94)
Thank you) already in the header.
Then the feeling when it all did everything so many times that he wrote everything in memory))) I was glad to help

And keyboard - Onboard

Post has been editedlaert00 - 23.12.19, 13:11



Rep: (5)
Laert00 @ 12/23/19, 13:11*
And keyboard - Onboard

When it starts the system when you need to enter a password inactive. You have to connect a USB clave. I tried Florence, but it is buggy even at the installation stage
Of course, I want a lot of much from Linux - Ubuntu installed on the tablet, but I want to have a fully working device with the installed Linux and at the same time everything worked) and the touch and the screen key and sound and WiFi and the camera.

Post has been editedbrokera - 23.12.19, 14:09



Rep: (94)
* brokera Onboard works on LightDM, if you put it instead of GDM (although in it and its own claus-screen is there, which is enough for the entrance). Sound, touch, sleep, wifi and bluetooth for most work. But with cameras ... everything is bad with cameras



Rep: (5)
Laert00 @ 12/23/19, 14:52*
Onboard works on LightDM

I still installed Lubuntu-18.04.3-Desktop-AMD64, there is LXDE. But for some reason, the screen keyway does not turn on. Although the touch works. It is necessary to somehow register something in GRUB?
With sound, it was not particularly understood.

Post has been editedbrokera - 23.12.19, 17:10



Rep: (94)
* brokera
Inboard settings included startup? and in special opportunities? In Lightdm, you most likely need to enter the pen in the config

sudo nano /etc/lightdm/lightdm-gtk-greeter.conf.

Keyboard = Onboard.


And she should then appear in the special features menu.



Rep: (5)
Laert00 @ 12/24/19, 01:45*
Inboard settings included startup? and in special opportunities? In Lightdm, you most likely need to enter the pen in the config

It seems to be included in the settings. It really appeared when the system is started, but after starting it is terribly buggy. Just hangs everything except the cursor-mouse (something I'm not at all delighted with Lubuntu on the tablet (



Rep: (1)
Kalpec @ 24.10.19, 12:44*
Conversion


You can write more about what to do? I put Andrew 9th 64bits on Krez TM1101S32 3G - the touch does not work almost. The devices also indicate Siled GSLX680 ...



Rep: (1)
Silent Forest @ 07.11.19, 17:34*
In the same place in the console, download utilities for the firmware from Windows drivers
git clonehttps://github.com/onitake/gsl-firmware


The terminal does not understand this team.
It is worth android 9, busybox.
How to start?

Inet works, root is.



Rep: (398)
Seeerp @ 03.01.20, 13:32*
The terminal does not understand this team.
In Android, there is no guita by default. And it's not a fact that this program will work on android.
But in general, maybe it's easier, in some Linux to do it? And the resulting file is already in the android raise.

Post has been editedKitsune2222 - 03.01.20, 15:33


Full version    

Help     rules

Now: 30.11.20, 08:26