LINUX on UEFI 32bit | [linuxos] tablets and TV box INTEL Bay \ Cherry Trail



Rep: (126)
LINUX on UEFI 32/64 bit


The topic discusses installing any kind of LINUX on tablets and TV boxes on INTEL Bay [Cherry] Trail with UEFI 32 / 64bit

Specifications
Specifications:
INTEL Bay [Cherry] Trail.
The screen size, touchscreen, Ram, Rom, it's all not important, they are almost identical, in tablets on Intel.
additional information
If you were able to launch Linux on your machine, write its name, what does not work and what works and how you launched it.
P.SThe topic is forbidden to discuss dualboot Android / Windows only linux / windows
Linux builds
Instructions
Drivers and sources
Kernel

Neighboring topics



There is no curator in the subject. For questions about filling the caps, please contact me atQMSif you found an interesting article or information.


Post has been editedM | A | G - 20.04.20, 18:06
Reason for editing: + autorotation guide



Rep: (131)
Midgard @ 06/09/19 21:48*
In the same Windows, both cards work without problems, and even if you connect a card reader via USB, it works on any OS
The card reader is so called that there is a separate controller in it.
Try the core of the new, as of today 5.1.8.



Rep: (14)
Guys tell me whether it will fully start on onda v80 se. controller gsl5680. percent Z3735F. 18.10 I put ubuntu an official there is a sound in works except for a tach. maybe something has changed)



Rep: (24)
* moobbi , Here try , however, I will not tell you by calibration, I have not figured it out with mine



Rep: (14)
Midgard @ 06/27/19 11:33*
Here, try, though I will not tell you about the calibration, I have not figured it out with my own

Yes, last time I kind of tried it too. assemble and install is not a problem but how you said calibration



Rep: (2)
Hello,
Faced with the problem that after several months of use, the device stopped normally from waking up. Simply put, after leaving the sleep mode, the device hangs, and then it terribly slows down and buggy.
Dist Manjaro KDE
core 4.19.49



Rep: (131)
* oleg740740
First try to update the kernel. In the LTS branch, 4.19.56 has already been released, and 5.1.15 is.



Rep: (2)
* Cut in
I tried to install 5.1.8, nothing has changed and I went back to the LTS, except for the test and rt branches in the Manjaro repositories there is nothing newer. And I don’t want to assemble the core myself, especially since I have no experience in this matter.

Post has been editedoleg740740 - 29.06.19, 16:04



Rep: (-2)
Hello, help when I run linux mint in live usb on an irbis tw91 tablet, the mouse is invented, and the cursor is turned



Rep: (0)
Here is bootia32.efi from various distros:
https://yadi.sk/d/sQt2OJVFD2TXwQ

As for me, the most usable of android-x86.



Rep: (56)
Do not tell me how to make a sound? The sound card is determined but there is no sound. Ubuntu 18.04. Kernel 5.1 from the cap.
ES8316 sound card
Attached Image


Post has been editednikita200s - 03.07.19, 20:35



Rep: (69)
* Nikita200s, check back at 19.04.

* andreykod I ran into a non-working turn of the touchscreen in the Wayland session on the Lenovo Miix 320-10ICR, at 19.04 I decided to install updates from the proposed (last tab of the source settings).



Rep: (0)
RussianNeuroMancer @ 05/30/19 12:55*
Appeal to IRBIS laptop owners with ES8316 sound card. Your help is needed in finding out whether it will suit them all the same set of parameters for a sound card. To test, install Ubuntu 19.04, set these two packets (Linux 5.1.5) Test sound playback on the left and right speakers using the Sound Settings section in the system parameters. Testing connected and with headphones disconnected. If during testing any problems arose, then you additionally test two kernels from the IRBIS ES8316 directory, and write down, with which of them you have, and whether everything works. When publishing the results here, also lay out the output "DMesg | Grep 8316".


Finally checked the laptop irbis nb105. I installed xubuntu 19.04, with the help of ukuu I upgraded the kernel to 5.1.5, rebooted, installed these two packages and voila - the sound finally appeared! And in the headphones and speakers.
Later I will try to do the same trick with elementary os.

A slight disappointment is that when you start playing sounds / music and a few seconds after the termination, you hear a crack or click. And so everything works great! The laptop finally became fully functional in ubunt.

Post has been editedasm_4 - 05.07.19, 14:51



Rep: (56)
* asm_4, But is there a simultaneous sound in the speakers and headphones?



Rep: (0)
* asm_4, But is there a simultaneous sound in the speakers and headphones?


When you connect headphones, the sound goes to the headphones, and disappears from the speakers - everything is as it should be. I don’t know how to make both speakers and headphones work at the same time, and I don’t need it.



Rep: (56)
* asm_4 , Wao, and on the contrary, at the same time, and I do not know how to do it normally.



Rep: (24)
* nikita200s , Tried all versions of a package? There they were 4 if I remember correctly. I'm on Digma e200 with Mintom great plow. The truth is of little help, speaker volume disgusting



Rep: (56)
* Midgard
If you are about the kernel from the header, then 4 packages are one core. And so all versions of the core tried. There are 2 there seems to be there.

Post has been editednikita200s - 08.07.19, 09:58



Rep: (39)
Hello. The tabletLenovo IdeaPad MIIX 300-10IBY80NR, Intel Atom Z3735F Bay Trail processor, UEFI32, Secure Boot is turned off.
After a series of torment with different Linux, I decided to try to install Arch.

How to record a USB flash drive and UEFI-32? To begin with format throughRufusUSB flash drive in FAT32, MBR for BIOS or UEFI, title Arch_yyyymm, yyyy change for the year of release release, and MM for the month of release (currently it will be Arch_201907). In the download method, select the "Unloading Image". Then through a 7-zip or another archiver to unpack all the contents.Image with Arch Linuxdirectly to a USB flash drive.

Now we have to use a virtual machine with Arch. Just load in it from our ISO image, connect the USB flash drive. We enter LSBLK, we must get a list of disk devices, among which our flash drive will be, for example, we indicate it as an SDB.

Insert the section with the ARCH Installer Files / MNT / USB /:
# Mkdir / mnt / usb
# Mount / dev / sdb1 / mnt / usb

Next, install GRUB for EFI32, prescribing these commands:
# Echo 'configfile $ {cmdpath} /grub.cfg'>/tmp/grub.cfg
# Grub-mkstandalone -d / usr / lib / grub / i386-efi -O i386-efi --modules = "part_gpt part_msdos" --locales = "en @ quot" --themes = "" -o "/ mnt / usb / EFI / boot / bootia32.efi "" boot / grub / grub.cfg = / tmp / grub.cfg "-v

Now we need to create a GRUB.CFG file in the / MNT / USB / EFI / BOOT directory withsocontent. Where Arch_YYYYYMM, there Yyyy change the release of release for the year, and MM for the month of release (at the moment it will be Arch_201907).

Everything! The loading flash drive is made, plug in the keyboard and flash drive through the hub, load. We try to connect to a wireless network via WiFi-Menu - everything works out of the box, it means to install.
Install byto thisExample, but still Arch is a system where everyone installs as he wants. Everyone is already individually here.

During network setup Do not forget to download Wi-Faya packages:
# PACMAN -S IW WPA_SUPPLICANT Dialog


It came up to the loader. We install it already on our tablet (/ boot / esp Replace to your directory in which your EFI section is mounted):
# PACMAN -S GRUB Intel-Ucode EFIBOOTMGR
# GRUB-INSTALL --Target = i386-EFI --EFI-Directory = / Boot / ESP --Bootloader-id = grub
# Grub-mkconfig -o /boot/grub/grub.cfg


Reboot and get a tablet with just installed Arch Linux. Yes, while it's just a naked terminal, then it is already necessary to install the X.org server, drivers for different sensors and your favorite DE, but, as I said, it is pure individually. Used materials from your experience, as well as with these articles from Arch:


In addition, you can look at the photo installation and the already installed system:
Photo (Achtung Traffic)
Attached Image

Attached Image

Attached Image


Post has been editedw32u - 09.07.19, 19:23
Reason for editing: Added a link to the topic of the tablet



Rep: (95)
* w32u,
good instruction.
We have similar devices -Lenovo Miix 2 10 - Discussion



Rep: (39)
* laert00, By the way, I would like to ask, do you have a screen rotation normally in the line? I was the IIO-Sensor-Proxy-Git and ScreenRotator-Git and the ScreenRotator-Git, but they turn not at all. For example, turned into a landscape - and he is in portrait. And the touchscreen with the mouse is still inverted. Do not know how to repair? I have an xfce4 shell.

Post has been editedw32u - 09.07.19, 19:22


Full version    

Help     rules

Now: 05.12.20, 14:13