LINUX on UEFI 32bit | [linuxos] tablets and TV box INTEL Bay \ Cherry Trail

Rep: (126)
LINUX on UEFI 32/64 bit

The topic discusses installing any kind of LINUX on tablets and TV boxes on INTEL Bay [Cherry] Trail with UEFI 32 / 64bit

INTEL Bay [Cherry] Trail.
The screen size, touchscreen, Ram, Rom, it's all not important, they are almost identical, in tablets on Intel.
additional information
If you were able to launch Linux on your machine, write its name, what does not work and what works and how you launched it.
P.SThe topic is forbidden to discuss dualboot Android / Windows only linux / windows
Linux builds
Drivers and sources

Neighboring topics

There is no curator in the subject. For questions about filling the caps, please contact me atQMSif you found an interesting article or information.

Post has been editedM | A | G - 20.04.20, 18:06
Reason for editing: + autorotation guide

Rep: (0)
Something cleared up about the work stitch. Stable only works in portrait mode, in landscape where nothing. True to me unusual in portrait orientation. Maybe somebody has thought about it. Somewhere in the forums mention of the fact that this problem stems from the fact that the BIOS displays the tablet in portrait orienatsii and loading Linux comes in the same orientation.

Post has been editedmato4kin - 20.05.16, 00:35

Rep: (22)
then I came


"In addition to the usual images collected with UEFI x64 and i586 without UEFI is now available for download and a special assembly -
i586 systems with 32-bit UEFI (for tablets) "

No case did not try to build a tablet to put?

Rep: (131)
andruxa80 @ 20.05.2016, 09:51*
then I came

It can be run in Live mode and see.
I have installed:DEXP Ursus Apollo Z110 / Z110i (cut in post # 48954920)
Sound works with the patched kernel.

Rep: (0)
andruxa80, it is necessary to disable what fast boot?

Rep: (22)
* mato4kin,
Is the question to the user* Cut in
- He tried.

Post has been editedandruxa80 - 20.05.16, 18:32

Rep: (131)
mato4kin @ 20.05.2016, 19:51*
Why disable fast boot is necessary?
Included Fast Boot can skip the initialization of a number of devices, such as USB Mass Storage, that is, stick, with which the load is carried out.

In general, met the recommendation to disable this feature, and to install Linux on a normal iron, as well as the Quiet Boot (, nothing changes on the screen with this option may be a problem with the display).

Rep: (33)
Who have already installed the dew? When preparing for installation dracut falls with the error:
dracut Warning: Could not boot.
dracut Warning: /dev/disk/by-label/ROSA.FRESH.GNOME.R7.i586 does not exist
dropping to debug shell.
dracut: / #

I realized that I need to somehow get it loaded not label the disk and by UUID or something like, but how?

P.S decided to replace in grub.cfg label-but on his own. Collective, but che do. Still does not help - on any stage load falls again in the shell, swears by the inability to mount / dev / disk / live-rw

Post has been editedsladder123 - 22.05.16, 10:24

Rep: (131)
sladder123 @ 22.05.2016, 16:51*
dracut Warning: /dev/disk/by-label/ROSA.FRESH.GNOME.R7.i586 does not exist

I recall a similar, but the details are rusty, or when the fast boot, either at a 64 bit image (you can run it by adapting the code mentioned below).

It should be the image of a i586.uefi in name, ROSA.FRESH.GNOME.R7.i586.uefi.iso
then popular utilities for creating boot images are not needed, just filled the stick command dd (or utility from the site).

Ezhel run the recorded image as a file, it is such a kernel command line:
insmod search_label
set iso = / ROSA.FRESH.GNOME.R7.i586.uefi.iso
loopback loop $ {iso}
linux (loop) / isolinux / vmlinuz0 isoboot = $ {iso} boot = isolinux iso-scan / filename = $ {iso} root = live: LABEL = ROSA.FRESH.GNOME.R7.i586 rd.luks = 0 = 0 = 0 rhgb logo.nologo

Post has been editedCut in - 23.05.16, 07:40

Rep: (33)
* Cut in so I just took the i586 and 32 bit. On the way is an interesting idea, thank you, but I have a feeling that swears terminal is just a label, whether it is cut off, or that. Maybe just because of the type of Rufus program, the DD should work out well, I did not know what hornbeam able to boot from an image

Rep: (131)
sladder123 @ 23.05.2016, 14:55*
Maybe just because of the type of Rufus program, the DD should work out well, I did not know what hornbeam able to boot from an image

Perhaps, for example,herewrites that "Rufus" "spoil the load."

Instead, you can use the ddhttp: // there is an option in Windows.

GRUB functionality depends on the version and distribution, to download ISO images should be loopback module.
In addition, in the example above, I forgot to copy the root installation: set root = 'hd0, msdos1' (disk and partition names need to set their own, depending on the breakdown of the stick).
Possible without the additional variable root, here are download option Mint image:
menuentry "Mint 17 linuxmint-17.3-cinnamon-64bit." {
set isofile = "/ linuxmint-17.3-cinnamon-64bit.iso"
loopback loop (hd0, msdos2) $ isofile
linux (loop) / casper / vmlinuz boot = casper iso-scan / filename = $ isofile noprompt noeject toram
initrd (loop) /casper/initrd.lz
kernel parameters as seen differ.
As a general rule, for each distribution can be found on his website.

On his plate was through previously installed GRUB, I tried to run a variety of Linux, if their images were not recognized by UEFI.

Rep: (33)
* Cut in thank you very much, I will keep in mind, my problem was really in the wrong way, he took the image for uefi and earned all of the box. ROSA is one of the two images (the second-lmde 2), who worked out of the box without video nomodeset, and the only way of correctly-established in the memory of the tablet, so that in addition to installing the drivers did not have anything even need to take.
And your method of downloading is really very convenient, especially if you suddenly need to have on a tablet a few distributions (like mine, and a number of Linux in the form akronis), though the hornbeam is a little off topic, would be worth it to add a hat.
By the way, does anyone know if someone could make in rEFInd \ rEFIt normal control buttons or tachem?

Rep: (7)
phil-fowler2 @ 17.02.2016, 08:07*
How can such trouble to win?

In his ownTrekstor SurfTab 10.1 twin Winning team
xrandr --addmode VGA1 "1280x800_60.00"

It is not strange it VGA1, yes. You may have a different, check the team

Of course still have to manage to run in iksah terminal, lol. pressSuper (She Win), print ter and hit Enter. It should work
Start the failed Ubuntu 14.04 and 13.04 Wi-Fi, Touchscreen, sound does not work.

We will continue to look

What is interesting - to find a hidden partition with rekaveri daddy called Android 5.1, but there is really nothing there, some configs.
Just found out - Ubuntu 14.04.3 LTS starts immediately with the normal graphics

Post has been editedjokfur - 27.05.16, 20:07

Rep: (19)
Guys need your help! I installed the dew on the IRBIS TW81 tablet, the rules worked several times rebooting all the rules, connected to the Internet came updates (very much) somewhat installed and asked to restart I ignorly continued the installation then the installation got up on the same percentage of 15-20 minutes stood I decided that hung and rebooted the tablet, now it gives me a GNU GRUP when starting GNU, but I can't go to Bius ((for some reason Klava and the mouse do not work, before I went to BIOS before

Rep: (131)
dalmat_777 @ 29.05.2016, 01:29*
produces at gnu grup start but nothing is pressed and CICS can not go ((

GRUB automatically have to run the operating system, it happens?

With broken keyboard encountered when the BIOS has disabled XHCI mode for USB, hardware buttons (volume) on my device is not allowed to return the settings, because it was necessary to alterDexp ursus 10W2 3G (Post foradey1983 # 39202195). How to IRBIS do not know, I read that can protect the port work, decided something likeDEXP Ursus Apollo Z110 / Z110i (Post rif1983 # 42501283)

Rep: (19)
* Cut in not does not go himself, Claudia has not blocked himself all worked fine in CICS has not yet put Linux ((

Rep: (131)
* dalmat_777 With a pause when updating (when it hung) It is clear: this is a rebeling of DKMS drivers when updating the kernel. As far as I understand, the GRUB configuration should vary at the end of this process, that is, the reboot should not have harvested (in the worst case, if the kernel is set with an error, GRUB starts to upload it, or writes about the inability, and you need to select the previous kernel). But how and that could make Linux with the keyboard, I don't know, I did not come across; If this happens, we are talking about bug, and it would be necessary to report it to developers, must correct.

But there is still a chance to CICS using the volume keys on my plate to keep - ( "softer") when turned on. grub, as I understand it. these keys do not respond?

Rep: (19)
* Cut in the volume keys do not work on my tablet (does not go into the BIOS) development of writing but they are silent, for the second week of the plate brick and the computer does not have what the trouble ((

Rep: (3)
If still someone has a black screen when you install linux, that after selecting the distribution Boot menu: check (via edit 'e') boot parameters of the distribution. It is in its bootia32.efi where indicated (if this bootia32.efi was established under the special distro, like me). For example, I was ARCH_201604 a menu, although the distro ARCH_20160 5 . He replaced - start.

Rep: (131)
dalmat_777 @ 01.06.2016, 16:38*
the volume keys do not work well on my tablet

Options may be different: +, or both.
But I looked at the characteristics of the tablet. The keyboard is connected via microUSB? Check connector, and their quality leaves much to be desired. On my charge through it knocks ...

Rep: (0)
Wanted to could not assess the chances to run Chromium OS but find information on the Internet before buying.
It is necessary to nobody? or there are some difficulties that doing this does not make sense.

Full version    

Help     rules

Now: 05.12.20, 14:47