> Attention!

We strongly recommend to readRules section "Android - firmware"

New threads need to be created only inroot partition! In the future, they will be processed by moderators.



Lenovo S650 - Firmware MIUI v5, LeWa OS5, and others (OS 4.2.2 - 4.4.2)
What firmware is installed in your Lenovo S650?
Choosing the most popular firmware
VibeUI 2.0 CN [ 270 ] ** [17,14%]
VibeUI 1.5 CN [ 14 ] ** [0,89%]
VibeUI 1.5 ROW [ 122 ] ** [7,75%]
VibeUI 1.0 CN [ 1 ] ** [0,06%]
VibeUI 1.0 ROW [ 21 ] ** [1,33%]
AOSP CN 4.4.2 [ 30 ] ** [1,9%]
AOSP ROW 4.4.2 [ 108 ] ** [6,86%]
AOSP CN 4.2.2 [ 11 ] ** [0,7%]
AOSP ROW 4.2.2 [ 38 ] ** [2,41%]
MIUI V5 CN [ 69 ] ** [4,38%]
MIUI v5 ROW [ 305 ] ** [19,37%]
EMUI 3.0 [ 58 ] ** [3,68%]
Other [ 528 ] ** [33,52%]
Total votes: 1575
 



Rep: (891)
Lenovo S650 - Firmware MIUI, LeWa OS, and others (OS 4.2.2 - 4.4.2)
PictureLenovo S650, Vibe X Mini
Description | FAQ | Discussion » | Purchase » | Official firmware » | MIUI, LeWa OS, and other firmware »

Drivers and Utilities
ADB driver - enhanced smartphone operation from PC
Attached fileLenovoUsbDriver_1.1.16.7z(9.36 MB)
Attached fileLenovo_ADB_driver.rar(2.9 KB)

Smartphone firmware mode driver from PC
Attached fileDriverInstall_v5.14.53_WinXP_Win7.7z(9.3 MB)
Attached fileDriverInstall_v5.14.53_Win8.7z(9.29 MB)



Firmware

Instructions
Install TWRP Recovery
ThroughFlash toolonCNmarkup:
  • Turn off the phone (in some cases, you can pull out the battery and flash without it)
  • DownloadFlashtooland unpack
  • DownloadTWRP v2.6.3.0and unpack
  • LaunchFlashtooland choosescatter filefrom the folder withTWRP v2.6.3.0. Be sure to tickDA DL All With Check Sum
  • InFlashtoolpress a button"Download"and connect the phone

Using the appMobileUncleToolsif root was obtained earlier through the programVroot:
  • DownloadTWRP v2.6.3.0and unpack, copyrecovery.imgto memory card
  • LaunchMobileUncleToolsand pressRecovery Update
  • Select a recovery image and confirm the installation


Installing firmware via TWRP Recovery



miscellanea

Screenshots




There is no curator in the subject. If there is a user in the subject who wants to become a Curator and the correspondingRequirements for candidates, he can apply in the topicI want to be curator(after having studied the topic header and all materials for curators).
Prior to the appointment of the curator, on filling the caps, contact the section moderators via the "Complaint" button under the messages to which you want to add links.


Post has been editedsnekt - 28.03.19, 20:22
Reason for editing: Temasek cm13 MM Android 6.0.1 row



Rep: (2)
gulyuk @ 08.05.2014, 19:46*
Slawucho, you can drain the build number and a reference to those that rocked?

the build number of the drain 119, and tried to put miui_sofina_cn_s650_4.4.25-2 aosp_sofina_cn_s650_R-V0.11.2.

and even wipes are made Cache, Dalvilk Cache, System, can here what is wrong


Post has been editedSlawucho - 08.05.14, 19:08



Rep: (891)
Slawucho and wipe data ?

Post has been editedgulyuk - 08.05.14, 20:00



Rep: (891)
RIO Genesis v.1 S650 ROW


Features:
- pure AOSP 4.2.2 ported to MyPhone Agua Rio (thank you for findingpalermo6 ), Originally coming under CN
- a minimum of trash
- the possibility to change the color scheme in messages (white / black)
- Added "Smart gestures" (unfortunately control points chips dialers do not work)
- engineering settings displayed in the setting item
- transparent bar status

What is done:
- adaptation to the ROW
- I added the ability to mount to the inside of the card layout ROW
- translating "Smart gestures"
- forced to work the camera
- stock levels Auto Brightness
- Superuser, Viper4Android

Screenshots
Attached Image
Attached Image
Attached Image
Attached Image
Attached Image
Attached Image


What does not work:
- green LED


Download:
sofina_rio_s650_row-39.zip

Post has been editedgulyuk - 08.05.14, 21:38



Rep: (1156)
S_As,
M



Rep: (891)
Event notification by flashing buttons


I decided to appoint a flashing alert buttons in this app help
Attached filecom.martinborjesson.o2xtouchlednotifications-1.apk(161.61 KB)


So lucky that this program has the support of the ITC buttons, and temporarily it can be used as an alternative to a green LED notifications

Tips on settings:
- to givethe rights super and admin
- optionalNotifications - General notification settings:
Mode - pulse repetition
and reduceduration per unit

I checked SMS notification and added to the list of events Viber works fine, but the nuance in the program code, notification service keeps track of them and flashing buttons to turn on the screen.
So I disabled it in the sms and vaybere.

Post has been editedgulyuk - 09.05.14, 07:42



Rep: (2)
gulyuk @ 08.05.2014, 20:07*
Slawucho, and wipe data?

yes, I missed data. All eventually fell perfectly poyuzat miui and stopped at aosp t.k.poradoval level wi fi. Thanks for the help)

Post has been editedSlawucho - 09.05.14, 12:07



Rep: (4)
there was a question - put lewa, and after connecting to vayfay he told me to upgrade ... is it worth? or better not? :)



Rep: (66)
avelanche @ 9.5.2014, 21:53*
there was a question - put lewa, and after connecting to vayfay he told me to upgrade ... is it worth? or better not? :)
It is not necessary, as the left - the port with another device, get a brick at Refresh.



Rep: (3)
Confused AOSP OS 4.2.2 R-V0.11.2 ROW - old, it is a postscript "old". There is no difference or better in row on cn go and then put under the Chinese?



Rep: (891)
Koshon Well if critical mount the internal memory card to your PC, it is best to row in the cn go and put the firmware under cn. If you do not want to be sewn on the cn, it is better to put the firmware RIO Genesis v1, the same AOSP, just a little bit later
avelanche, download the update, but it should not be established because the has firmware changes the original assembly



Rep: (3)
gulyuk, Excuse me, but where to get RIO Genesis v1? And at once: if there are any problems (at least seen)?

Post has been editedKoshon - 11.05.14, 21:01



Rep: (3)
Sorry, I found. Clever ideas come late. Clean please.



Rep: (11)
gulyuk, great job !! A problem with falling asleep during conversations there? And what a modem ??



Rep: (9)
Prompt please, give S65 device. I flashed under 113, not the network operates. I'm in the Crimea. Shoveled the Internet, it is possible to flash the modem on it. Something like with grief in half get Ruth rights. And now I can not update rekaveri, not one of the versions, it goes back and all. And in the factory did not set as you know. Who can faced with a similar situation?



Rep: (57)
Hello.
I came with telefonchikfirmware : S650_S123_131105 Modem : S650.V11,2013 \ 09 \ 06 17:49 Android : 4.2.2
Please explain what it means and whether it is necessary to do something. For reference, I will say that as many as 190 programs installed (all).



Rep: (891)
247760, this means that the markings on a device with the appropriate CN bp under it, and what can to do this:
1. Upgrade to a newer version VibeUI 1.5 (which means the new version 4.4.2 androjda) with English and Chinese
2. reflash on ROW layout and install of.proshivku Europe 113 ROW based androjda 4.2.2 - Multilingual
3. Try an informal firmware on the basis of 4.2, but there is a matter of taste, and only basic functionality is working in them, etc. etc.

PS. Such questions are asked orDiscussions or theme Official firmware



Rep: (10)
Tried to flash in rekaveri for further firmware via Flash Tool on CN markup (119) 127. Did all the instructionsfrom here.
My actions --
- I downloaded fleshtul and tvrp, launched
- chose scatter,
- said yes to,
- Press Daunload,
- Connect your phone without a battery.

And nothing. Rather, it was a message by pressing the button daunload - Not all images have been properly loaded. proceed? - press Yes, and then nothing. Preloader red highlighted line.

What to do?



Rep: (891)
gem84, so if there is a ROW marking the Lenovo UI 127 port (it was implied) just for her, sewn on the CN is not necessary



Rep: (10)
I realized the mistake. But then where to find the firmware instruction to 127?

Clarify - I have the firmware 119, ie CN.

I found a clue - Go with CN on ROW and back is done only with the help of firmware via Flash Tool using the Firmware Upgrade button. Not enough information. What fleshtul download necessary - CN, or PAB, and where instructions?

Post has been editedgem84 - 13.05.14, 19:51



Rep: (891)
gem84, and then it's simple:
1. Put TWRP Recovery, unless stated
2. Download and throws 127 on the memory card
3. Wipe rekaveri do and then Install, Reboot

Everything..

PS ... then yes, you have to through Flash Tool sewn do is download the file 113 Row of threads of.proshivok, unpack it on your PC and there dolzhent already be in Flash Tool for this marking, remains to flash through the Firmware Upgrade button (possible after flash TWRP separately once a Row)

Post has been editedgulyuk - 13.05.14, 19:50


Full version    

Help     rules

Time is now: 07/09/20, 05:13