[GUIDE] Installing and configuring Linux (Ubuntu / Debian) on the Acer A500 / A501 without VNC | Native Linux on Iconia
New hat
It became
Worse [ 11 ] ** [5,82%]
It is better [ 47 ] ** [24,87%]
Anyway, just the result is interesting. [ 131 ] ** [69,31%]
Total votes: 189
 



Rep: (50)
Installing Ubuntu Linux on Acer A500 / A501

Description | Discussion " | FAQ on the A500 " | Acer ICONIA TAB A500 / 501 - Purchase | Acer Iconia Tab A500 / A501 - Accessories
3.x firmware | 4.0.x firmware | Firmware 4.1.x - 4.3 В»

At the moment, the most efficient port ubuntu from thor2002ro based on 13.04
What works
Currently working in ubuntu
[*] wifi
[*] bluetooth (not out of the box, requires additional configuration)
[*] display
[*] x tegra driver (only works where it is not clear to use)
[*] touchscreen (single touch only)
[*] hw button (volume and power button)
[*] battery (correctly determines the charge)
[*] usb host port (flash drives, mice, etc.)
[*] audio
[*] hdmi

Does not work
[*] no multitouch
[*] no built-in cameras
[*] GPS does not work and the fate of the compass and gyro is not clear (there seems to be a driver, but I did not find software for them)

Installation requirements:
[*]Last unlocked dual boot bootloader
[*] A USB flash drive (not microsd), at least 512mb formatted in Fat32, is needed for installation from it
[*] usb-clave (or copy login / password with the mouse)
[*] a500 / 501 or compatible tablet
[*] microsd, at least 4gb, split into 2 partitions, and the first one is formatted in ext4

Screenshots
Attached Image

Attached Image

Attached Image

Attached Image

Attached Image


Installation
To install it you need:
microsd volume of 4 gigabytes, better more, formatted in ext4, you can do this through acronis or from any linux distribution.
Ordinary usb flash drive and usb keyboard
Well, actually the installation files
1 Actuallyinstaller
2 rootfs
3 The linux kernel

I had a problem that the installer did not work correctly due to the difference in the paths to the flash drive, so if anyone has such problems (and they are likely to happen to everyone who has droid 4.2.2), I post the modifiedinstaller.
After the microsd has been prepared and the files necessary for installation are copied to the USB flash drive, we reboot into recovery and run the update_linux_installer-v1 file from the flash drive, wait for the operation to take about 15 minutes, if the installer didn’t fit in a couple of minutes or less, use my installer, then run the Kernel update .

After that, we reboot the tablet and hold down the volume up button and select "boot secondary kernel image" in the menu that appears and connect our keyboard, if everything went successfully, a window should appear where you will be asked to select a language and enter the user name and password.
Next, under your user log in.


Raring has gone to old-releases. Accordingly, the repositories no longer work.
Decision:
sudo cp -i /etc/apt/sources.list /etc/apt/sources.list_backup
open /etc/apt/sources.list in any text editor (sudo leafpad /etc/apt/sources.list) and replace everything that is there with this:
sources.list
# Seehttp://help.ubuntu.com/community/UpgradeNotesfor how to upgrade to
# newer versions of the distribution.
debhttp://old-releases.ubuntu.com/ubuntu/raring main restricted
deb-srchttp://old-releases.ubuntu.com/ubuntu/raring universe main multiverse restricted #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
debhttp://old-releases.ubuntu.com/ubuntu/raring-updates main restricted
deb-srchttp://old-releases.ubuntu.com/ubuntu/raind-updates universe main multiverse restricted #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. WILL NOT receive any
## review or updates from the Ubuntu security team.
debhttp://old-releases.ubuntu.com/ubuntu/raring universe
debhttp://old-releases.ubuntu.com/ubuntu/raring-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free license. Please satisfy yourself as
## your rights to use the software. Also, please note that software in
## multiverse will not receive any review or updates from the Ubuntu
## security team.
debhttp://old-releases.ubuntu.com/ubuntu/raring multiverse
debhttp://old-releases.ubuntu.com/ubuntu/raring-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively, although it includes
##
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
debhttp://old-releases.ubuntu.com/ubuntu/raring-backports main restricted universe multiverse
deb-srchttp://old-releases.ubuntu.com/ubuntu/raring-backports main restricted universe multiverse #Added by software-properties

debhttp://old-releases.ubuntu.com/ubuntu/raring-security main restricted
deb-srchttp://old-releases.ubuntu.com/ubuntu/raid-security universe main multiverse restricted #Added by software-properties
debhttp://old-releases.ubuntu.com/ubuntu/raring-security universe
debhttp://old-releases.ubuntu.com/ubuntu/raring-security multiverse

## Uncomment
## 'partner' repository.
## This software is not part of Ubuntu, but it is offered by Canonical and
## respective Ubuntu users.
debhttp://archive.canonical.com/ubunturaring partner
deb-srchttp://archive.canonical.com/ubunturaring partner

## This software is not part of Ubuntu, but it is offered by the third-party
## developers who want their ship software.
debhttp://old-releases.ubuntu.com/ubuntu/raring-proposed universe main restricted multiverse
deb-srchttp://old-releases.ubuntu.com/ubuntu/raring-proposed universe main restricted multiverse #Added by software-properties


Customization
For further actions you need to use a terminal emulator (lxterminal), and for all further actionsnecessarily Internet connection required.
We start the terminal and enter

sudo apt-get update
sudo apt-get upgrade


these two teams will check for updates and install them

In order for you to have a brightness slider we type

sudo add-apt-repository ppa: indicator-brightness / ppa
sudo apt-get update
sudo apt-get install indicator-brightness


then we add its appearance in the panel to autoload, for this we open applications ->system utilities ->options ->automatically running applications and add /opt/extras.ubuntu.com/indicator-brightness/indicator-brightness there
I can recommend to add an auto launch of a virtual keyboard for this in the same place we add the onboard command
Now each time it is turned on, the brightness applet and the virtual keyboard will start automatically.

I can recommend the vlc player to play video

sudo apt-get install vlc


Add codecs

sudo apt-get install ubuntu-restricted-extras
sudo apt-get install libavformat-extra-53 libavcodec-extra-53


You may also need java

sudo apt-get install icedtea-7-plugin openjdk-7-jre


Turn on the flash (contact unfortunately still does not work but YouTube works (albeit lousy) and advertising banners)

sudo apt-get install gnash
sudo apt-get install browser-plugin-gnash
sudo apt-get install mozilla-plugin-gnash

sudo cp '/usr/lib/mozilla/plugins/flashplugin-alternative.so' /usr/lib/chromium-browser/plugins/libflashplayer.so


Two panel file manager similar to Total Commander
sudo apt-get install gnome-commander

LAN support for it
sudo apt-get install libgnomevfs2-extra


Bluetooh activation

The easiest to type in the console

sudo su
rfkill block 0
rfkill unblock 0
brcm_patchram_plus --enable_hci --baudrate 3000000 --patchram /lib/firmware/bcm4329.hcd --enable_lpm / dev / ttyHS2


But this only activates bluetooh before the first reboot or shutdown, in order for it to work constantly, you need to bring the part responsible for bluetooh to this form in the /etc/init/patchram.conf file

# patchram - Broadcom brcm_patchram_plus utility.

description "bluetooth initialization"

start on starting bluetooth
stop on stopping bluetooth

expect fork

env PATCHRAM_ARGS = "- patchram /lib/firmware/bcm4329.hcd
--enable_hci \
--enable_lpm \
--baudrate 3000000 \
--tosleep = 50000 \
/ dev / ttyHS2 "

exec / usr / bin / brcm_patchram_plus $ PATCHRAM_ARGS &

pre-start script
rfkill unblock bluetooth
chmod 0660 / sys / class / rfkill / rfkill0 / state
chmod 0660 / sys / class / rfkill / rfkill0 / type
chgrp dialout / sys / class / rfkill / rfkill0 / state
chgrp dialout / sys / class / rfkill / rfkill0 / type
end script


Overclocking
On a clean ubuntu, you can set the processor frequency from 200 to 1000 MHz, so that frequencies above 1 GHz are available,
Install cpufrequtils
sudo apt-get install cpufrequtils

Then, in the /etc/init.d/cpufrequtils file, correct the values ​​to
ENABLE = "true"
GOVERNOR = "interactive"
MAX_SPEED = "1600000"
MIN_SPEED = "216000"

where 1600000 is the maximum available frequency for your device
Personally, I have worth 1,400,000 if I put above something that is not a stable job (reboot), but in general, how lucky.

miscellanea
Manualto launch 3 heroes
Installationmate
Viewvideo



Outdated way to run Ubuntu

Instructions for manual installation and assembly of rootfs:
1) First of all, it is necessary to prepare rootfs - the root file system (or find and download an already ready one, for example, via the link below), for this at the moment there are 2 ways: through Debootstrap and throughLinux Deploy(not yet suitable for Ubuntu).
There are 3 kernel options: one loads rootfs from rootfs.img-file in the internal memory (mmcblk0p8,Attached filerecovery.img(4.11 MB)
), another from the 2nd sd card partition (mmcblk1p2, core from sp3dev, newrec.img), from the 1st sd card partition (mmcblk1p1, recovery.bin). Depending on the kernel, we assemble the FS into either an img-image, or mount the necessary section of the sd-card. Immediately I will say, if you collect on a slow USB flash drive, the whole process can take 3 hours.
a) through Debootstrap. Requires an installed Linux distribution (you can also on a virtual machine).
Perform line by line in a Linux terminal:
# create a mount point / mnt / deb
mkdir / mnt / deb
# a) if we write to img, then we execute these lines (select an empty image in memory, into which we will work with):
fallocate -l 3G deb.img
# and format it
mkfs.ext4 deb.img
# then, mount to the previously created point
sudo mount deb.img / mnt / deb
# b) if we write to the section of the memory card (it should already exist (I havesdb2 , we enter our own), and in ext4, I broke it in GParted), then we execute the following line:
sudo mount -t ext4 / dev /sdb2 / mnt / deb
# run directly the creation of the file system:
here "armhf" / "armel" is the architecture, "precise" is the distribution code name, "/ mnt / deb" is the installation location
# process takes about 10 minutes, you can rest for now)
sudo qemu-debootstrap --arch armhf precise / mnt / deb
# Further we open mnt / deb / etc / apt / sources.list and add the necessary repositories (without the # signs), here for 12.04
#################################################
# debhttp://ports.ubuntu.com/ubuntu-ports/precise main restricted universe multiverse
# deb-srchttp://ports.ubuntu.com/ubuntu-ports/precise main restricted universe multiverse

#################################################
# log in as root to install the remaining packages
sudo chroot / mnt / deb / bin / bash
# if you do not mount / proc, then there arises the error bug (dbus and its dependencies)
mount -t proc proc / proc
#mount -t sysfs sysfs / sys
# set Russian locale
locale-gen en_US.UTF-8 en_US.UTF-8
/ usr / sbin / update-locale LANG = en_US.UTF-8 LANGUAGE = "en_US: en"

# load the package list
apt-get update
# put firewood on BT \ WiFi, then unpack and copy the folderAttached filebrcm.zip(219.91 KB)
in / mnt / deb / lib / firmware (min 15)
apt-get install broadcom-sta-common broadcom-sta-source firmware-b43-installer firmware-b43 legacy-installer b43-fwcutter
# we decide on the environment and install additional programs (about half an hour)
apt-get install ubuntu-desktop# Unity environment
# apt-get install xubuntu-desktop #XFCE with add. programmes
# apt-get install gnome-panel # gnome-fallback
# apt-get install xfce4 # bare XFCE (not even a notebook)
# desktop manager - installed with ubuntu-desktop and xubuntu-desktop, otherwise we execute
# apt-get install lightdm
# apt-get install slim #I had to install it, as lightdm started to restart cyclically, preventing it from logging in
#open /etc/lightdm/lightdm.conf or etc / slim.conf and configure autologin if necessary, very important in the absence of a USB keyboard
passwd<your root password>
now rename the image to rootfs.img (in the home directory) and drop it into / sdcard on our tablet.
b) throughLinux Deploy. And here it remains to perform only
# put firewood on BT \ WiFi, then unpack and copy the brcm folder to / mnt / deb / lib / firmware
apt-get install broadcom-sta-common broadcom-sta-source firmware-b43-installer firmware-b43 legacy-installer b43-fwcutter
all setup information is outlined inrelated topic, only as a destination /sdcard/rootfs.img or / dev / block / mmcblk1p2 depending on the kernel.
at)Ready image of Ubuntu Oneric (11.10, armel)Ubuntu4Arm, (unpacked 8GB, keep in mind)
from this topicubuntu on acer a500, dual boot with android on acer a500 and possibly a501, there are additional instructions on how to start a video, sound, etc. (checked, works).
 

2) Next, install the kernel, here are also 2 options - either it is put instead of recovery (did not try), or whenIcs-bootloader-v8- on the AKB section, describing the second
We are loaded into android, we throw the kernel in / sdcard and execute in the terminal
su
dd if = / sdcard / recovery.img of = / dev / block / mmcblk0p7

3) Turn off the tablet and turn it on with POWER + VOLUP, select BOOT FROM SECOND PARTITION and voila!
Possible problems / solutions:
1) gets stuck on the boot at the very beginning, before the screen is updated (thanksnick_on_off )
Add in / etc / fstab
proc / proc proc defaults 0 0
dev / dev tmpfs rw 0 0
/ dev / mmcblk1p1 / auto rw 0 1
Recommendations:
1) As a browser, install Chromium, and on it an extension for scrolling with your fingerChrome touch
2) Update the OnBoard virtual keyboard - on new versions, the interface is more convenient and they do not slow down.
WELCOME ANY INFORMATION ON NUCLEARS AND READY ROOTFS!
<not relevant>CORE 3.1 from Forzaferrarileo source coderogro82 kernel 3.1 mmcblk1p2
* correctly shows the battery charge, lightdm does not crash, the sound immediately works
Firewood on video brother onLAUNCHPAD HERE


Set for installation in/ data (thank Andrei Bakai ):
update-linux_installer-v1 (data) .zip
update-kernel (data) .zip

Instructions for building the file system and running Linux from different themes on the XDA and not only, but specifically:
Ubuntu 13.04 from Tor original post
[WIP / DEV / GUIDE] Debian Linux armhf
{HOW TO} Native Debian on A500 and building your own rootfs
[Dev] Native linux on Iconia
Changelog
21.10.2013
Added new kernel 3.8.13.11 and mate installation instructions
16.10.2013
Redid the cap


Thanks to user Ptu4ka for information about repositories.

Dear users! You are welcome,say thank you by raising your reputation ( Picture). If you have less than 15 messages, then clickPictureon the right post and tell the moderator who helped you and how.

All requests for filling caps send the curator of the topicleonidy-85atQMS.

Post has been editedleonidy-85 - 28.09.14, 19:00



Rep: (6)
on linux collected, nothing complicated-so
I can describe in detail, but until that instruction is not the best of me is)
set as the same as lubuntu, only its image Framed
really did not have time poschyupat, business est.krome wafers not checked anything
image upload nehochu yet for crude
later less finished



Rep: (6)
something Wi fi does not work to start
sound as though there are as it were not, ie, one hiss)
as well as a whole is stable and smartly
2 some of the sensor to identify and indicate the temperature



Rep: (575)
* pys60, Now try it for noise:
Getting rid of the hiss pulseaudio:

Edit the file:
sudo leafpad (a text editor) /etc/pulse/default.pa

We are looking for line there:
load-module module-udev-detect

And change it to:
load-module module-udev-detect tsched = 0

Those. reducible to this form:

.ifexists /system/lib/hw/audio.primary.manta.so
load-module module-udev-detect tsched = 0
.else
load-module module-udev-detect tsched = 0
.endif

According to the wifi does not only need to load the kernel module?

Post has been editeddimon2242 - 09.04.15, 14:30



Rep: (6)
sound not prokanaet
and which module to load necessary?



Rep: (575)
* pys60, fw_bcmdhd.bin in / lib / firmware /, bcm4329.cal in / etc / wifi / bcm4329-fullmac-4.bin in / lib / firmware / brcm
http://1drv.ms/1IvCG50



Rep: (6)
* dimon2242 2 beers you! started up wafer
Now I will try to eliminate the other rpoblemy
rutfs spread? or later?)



Rep: (402)
pys60 @ 09.04.2015, 15:41*
* dimon2242 2 beers you! started up wafer
Now I will try to eliminate the other rpoblemy
rutfs spread? or later?)

I think at first bring to mind, and there then and touch))) But all the same to you.



Rep: (6)
* meksis,
raw spread does not really want certainly, but one head is good, two is better) if you want to co-dopilivat and mozgovat, you will certainly lay

Post has been editedpys60 - 09.04.15, 15:49



Rep: (402)
pys60 @ 09.04.2015, 15:48*
raw spread does not really want certainly, but one head is good, two is better) if you want to co-dopilivat and mozgovat, you will certainly lay

Watching how dopilivat, I'm not much of a guru. But then as I realized there are men whose brain is able to do this is not bad: rolleyes:

Post has been editedmeksis - 09.04.15, 15:53



Rep: (575)
* pys60, pour! Waiting for image! ;)

Post has been editeddimon2242 - 09.04.15, 15:56



Rep: (6)
pour)
about the sound, I tried through aplay and one of the speakers poured rattle, opened the same file via mplayer and plays normally)



Rep: (575)
* pys60, if everything is OK, on ​​the assembly of the torus the same problem! I use VLC.
Perhaps the fact the output device installed in the default application settings.

Post has been editeddimon2242 - 09.04.15, 16:08



Rep: (402)
pys60 @ 09.04.2015, 16:02*
by mplayer and plays normally)

I did not want the sound to work through it, put the VLC and the sound came



Rep: (6)
I checked on the aac track in audacious he had not even played, but mp3 audacious normally opened
and here rutfshttps: //drive.google.c...RqdHc/view usp = sharing?
installed as lubuntu, but instead lubuntu-14.04-a500-v1t2 must substitute this file, and rename the
at startup is set debian, i.e. will not install like a torus (as he did the installer, do not know)
In this regard, I have created a user (a favorite)) and set a password, but to create another user, remove and change my password as root, I think, were not working
and even changes to the layout caapslock, but it is also fixable
login ruslan
password from the entrance and from the rue 35335
to create a user, you have to enter as root
# Adduser --home / home /<user><user>
Change your password from the same root as root command
#passwd
so do not forget to set a password to its user
#passwd<user>

I forgot to install the Russian language pack for iceweasel browser, for this set
# Apt-get install iceweasel-l10n-ru
with Bluetooth is not yet understood

wafer runs, webcam works and is recognized as / dev / video0 (to check mplayer tv: // -tv device = / dev / video0)
Russian locale is set, the system language is Russian



Rep: (6)
YouTube works, though at a resolution of 360p even inhibits)



Rep: (402)
pys60 @ 09.04.2015, 17:11*
YouTube works, though at a resolution of 360p even inhibits)

A driver on a video worth?



Rep: (6)
* meksis, with wood all night sat and did not come up with anything (

Posted on 09/04/2015, 20:48:

YouTube at 360r browser slows down, and if you download and open mpleerom but ok
higher resolution mpleerom not tried to open



Rep: (402)
pys60 @ 09.04.2015, 20:48*
* meksis, with wood all night sat and did not come up with anything (

Posted on 09/04/2015, 20:48:

YouTube at 360r browser slows down, and if you download and open mpleerom but ok
higher resolution mpleerom not tried to open

I'm on Tegra which is seen as the post to put the driver in the video. These official driver from nvidia. Even in my own Thor and I described the whole procedure.

Post has been editedmeksis - 09.04.15, 20:55



Rep: (2)
Hello! I can not understand, this device has a touch ubuntu? On the off site somewhere seen but can not find.



Rep: (575)
* Ghost riders in the sky, on XDA it was like, but it is hardly still supported!


Full version    

Help     rules

Time is now: 09/09/20, 12:08