Google Nexus 4 - Official firmware



Rep: (467)
Google Nexus 4 - Official firmware
PictureGoogle Nexus 4 aka mako, E960
Description | Discussion » | Purchase » | Accessories » | Marriage » | Power consumption and autonomy » | Firmware | Custom kernels » | Custom firmware » | Ubuntu touch » | Cyanogenmod » | AOKP » | ParanoidAndroid (v3 +) » | MIUI » | LeWa OS 5 » | Sailfish OS » | Yandex.Kit » | Android L firmware (OS 5.0) » | Modifications of software and decorations » | games and apps » | LG Google Nexus 4 club » |

FAQ:CHAhundred askedATpolls andABOUTanswers to them (FAQ)
Instructions for firmware / factory reset / rollback
Instructions on firmware for OS Windows (fully and in parts, problem solving)
Instructions on firmware for Windows + video .
Video 5.0 firmware manual
Instructions on firmware for OS Ubuntu Linux (13.10)
Mac OS X Firmware Manual
Instructions on firmware using Total Commander .
How to restore your Nexus 4 (including IMEI) (and memory loss) .
How to open the bootloader / get root rights without losing data / second option
Instructions for firmware through custom recovery (CWM or TWRP).
What to do if not sewn through TWRP .
How to install 4.4. * Through custom recovery (CWM, TWRP) without loss of applications and data .
Instructions. Backup EFS / IMEI .
Wug's Nexus Root Toolkit utility instructions
RestoreME for Nexus devices - Program for quick recovery / firmware of the last full image of the official firmware.
RecoveryME for Nexus devices - A program for flashing custom recovery.
Errors when flashing the full factory image via fastboot
What to do if the phone goes into Bootloop (Eternal download)
  1. Reboot the smartphone, holding the power button a little more than 10 seconds.
  2. When the screen goes out, hold down the Volume Down (volume -), get into Fastboot mode.
  3. Use the volume buttons to select Recovery mode, confirm the selection with the power button.
  4. Android appears with an exclamation mark. Press the Power button, then press the Volume Up button (volume +), it may not work the first time.
  5. Select wipe data / factory reset.
  6. Choose reboot system now.

If it does not help, we are flashing the full firmware using one of the instructions.

Official firmware
4.2 - (JOP40C; radio 2.0.1700.33; bootloader makoz10l) of 11/13/12
4.2.1 - (JOP40D; radio 2.0.1700.33; bootloader makoz10l) from 11/27/12
4.2.2 - (JDQ39; radio 2.0.1700.33; bootloader makoz10o) of 02/11/13
4.3 - (JVR66V; radio 2.0.1700.84; bootloader makoz20i) of 07/24/13
4.3 - (JWR66Y; radio 2.0.1700.84; bootloader makoz20i) 08/21/13
4.4 - (KRT16o; radio 2.0.1700.97; bootloader makoz30d) from 11/14/2013
4.4.1 - (KRT16S; radio 2.0.1700.97; bootloader makoz30d) from 11/20/2013
4.4.2 - (KOT49H; radio 2.0.1700.98; bootloader makoz30d) 10.12.2013
4.4.3 - (KTU84L; radio 2.0.1701.02; bootloader makoz30d) from 06/02/2014
4.4.4 - (KTU84P; radio 2.0.1701.03; bootloader makoz30d) from 06.20.2014
5.0 - (LRX21T; radio 2.0.1701.04; bootloader makoz30f) 11/14/14
5.1 - (LMY47O; radio 2.0.1701.06; bootloader makoz30f) 04/15/15
5.1.1 - (LMY47V; radio 2.0.1701.07; bootloader makoz30f)
5.1.1 - (LMY48I; radio 2.0.1701.07; bootloader makoz30f)
5.1.1 - (LMY48M; radio 2.0.1701.07; bootloader makoz30f)
5.1.1 - (LMY48T; radio 2.0.1701.07; bootloader makoz30f)
Official site .
Mirrors of images .
Stock firmware 5.1.1 (LMY48T) - under custom recovery.
Stock firmware 5.1.1 (LMY48I) - under custom recovery.
Stock firmware 5.1.1 (LMY47V) - under custom recovery. ( installation tips )
Stock firmware 5.0.1 - under custom recovery.
Firmware 4.4.4 (clean: odex, without root + separate radio) - under the last TWRP (there may be problems on CWM).
Firmware 4.4.4 (odex, without root and radio, ROM + Kernel) - under custom recovery.
While there is no need to sew stock deodex firmware, everyone has problems with applications and a back button.
What and where is the firmware image
Download the stock images of the firmware version you need (the image will have the extension tgz).
Unpack the downloaded archive into a folder, unpack it (for example, with the WinRAR program).
Carefully study the unpacked files: bootloader-mako - *. **. Img (bootloader), radio-mako -... img (radio), flash-all.bat, flash-all.sh, flash-base.sh (these three files are needed only for one-click firmware) and image-occam - *****. zip.
Carefully read the contents of the image-occam archive - *****. Zip, there are: android-info.txt, boot.img, recovery.img, system.img, userdata.img


Ota update
The main condition for successful firmware OTA, it is completely stock firmware.
The difference even in one system file will cause you an error when updating. This also applies to the presence of Root and custom recovery.

OTA from 4.2. * To 4.4. * - no (you cannot upgrade right away) .
What is checked before installing OTA.
All known PTA on nexus 4.
Mirrors on the PTA.
How OTA is sent and why you shouldn’t clean the Google Services Framework
OTA manual installation manual (in English)
OTA forcing methods
Attention!!! These methods can cause different glitches on the device and a malfunction of Google services. Therefore, these actions are at your own risk. Please note that they do not give any guarantee for the arrival of OTA. If the topic will be questions: "Why does not help me?" - these methods will be removed from the caps and topics. Before writing such a post, consider how you will be "grateful" to the forum users who did not find them in the cap.

Option 1.
1. Turn off the entire Internet (WIFI, 3G).
2. Disable location determination.
3. Delete the data from the Google Services Framework application, stop the application, if asked, prohibit determining the location.
4. Turn on WIFI.
5. We are updating.
6. Delete Google account and score it again.
7. Turn on location.
8. We rejoice.
Option 2.
1. Go to Settings-Applications-All.
2. We are looking for the Google Services Framework there and poking it, we need to clear its cache and delete its data.
3. Open the dialer and dial * # * # 2432546 # * # *
4. We are waiting for the "checkin succeeded" notification.
5. Check for updates and enjoy))
Possible problems
1) Eat changed the battery and when you upgrade get a recumbent android. RecoverSystemUI.apk and SystemUI.odex from backup or flush system from your current firmware.
2) If, after the update, you have problems with Google Play and your account, read the FAQ (FAQ).
How to flash OTA manually
Option 1: via adb sideload
1) Download OTA.zip to computer. Rename the archive file to update.zip, and move it to the folder where the adb.exe file is located
2) Connect the phone to the computer, and boot into fastboot.
3) Select “recovery mode” and click “Power”. You will see a lying android, press the "Power" button simultaneously with the "Volume up". In the menu, select “apply update from adb”
4) Open a command prompt on the computer (cmd). In it, go to the directory where the update.zip file is located, and enter adb sideload update.zip. Download will begin.
5) Reboot.

Option 2: Through custom recovery (for upgrade to 5.0 does not work).
1) Download OTA.zip and copy to your phone.
2) Boot into the recovery.
3) Sew OTA.
4) Reboot.
Wipes are not needed.

Option 3: Use the Tool Kit (program for flashing).

Drivers and Utilities
drivers
New USB driver .
Google USB Driver (required for Windows, only to run ADB)Attached filelatest_usb_driver_windows.zip(8.28 MB)

It can also be downloaded.here .
Attached fileUniversal_Naked_Driver_0.72.zip(8.28 MB)

Attached fileUniversalAdbDriverSetup6.msi(8.78 MB)
- USB driver installer from the CWM command (For all nexus and for all versions of Windows. In Windows 8, after downloading, select "More Info" and then "Run anyway").
USB driver for Win 8 Attached fileusb_driver_v8.zip(8.28 MB)

USB_driver_r06_windows Attached fileusb_driver_r06_windows.zip(8.28 MB)

ADB Drivers Attached fileadb.rar(738.28 KB)
.
tulkits (programs for flashing the whole, in parts, obtaining root rights, etc.)
Attention: before using the toolkit, make sure that it is updated and supports the selected firmware.
Wug's Nexus Root Toolkit (works with 5.0).
Nexus multitool - for OS X and Linux (works with 5.0).
SKIPSOFT ANDROID Toolkit - NEXUS 4 - Driver, Ruth, recovery. A single Android Toolkit, combines all the Nexus Toolkits.
N-Cry 4.4.4 - Analogue utility NexusToolKit, with a more simple and intuitive interface. Instruction .
Nexus 4 Mac Toolkit
Universal nexus linux toolkit - Similar to the Nexus 4 Toolkit, but only for Linux (compatible with MAC OSX).

Minimal ADB and Fastboot - A handy program (install the ADB driver itself, create a shortcut on the desktop to enter the command line (CMD).
15 seconds ADB Installer - Program for quick installation of all drivers (usb, adb_fastboot).
Android ADB - Plugin for Total Commander.
Flashify - Kernel firmware, recovery, zip, kernel backup, etc. from the phone (need root).
Flash Image GUI - A utility for firmware recovery and kernels directly from the phone (you need a root).
Boototlocker - Program for opening / closing the bootloader without losing data (root is needed). Also allows you to remove Tampered Flag (boot tag hacking mark on 30d).
Video instructions for installing drivers on Win 7 .
How to disable driver signature verification on Windows 7
How to disable driver signature verification in Windows 8
Windows 8 does not see the phone.
How to fix Code ** errors.
For Windows XP
For Windows XP users

Only for Windows XP:
1. Connect your Nexus to the Computer (USB Debugging must be enabled on the device).
2. Go to My Computer>Right click>Properties>Device Manager and double click on MTP device.
3. Go to the information tab and copy the similar code - USBVID_18D1 & PID_4EE2 & MI_00) (you can also copy it from here if they match).
4. Disconnect the Nexus from the computer.
5. Go to C: WindowsInf (the Inf folder is hidden, configured in the control panel).
6. Find the file wpdmtp.inf and open it in any text editor, even in Notepad.
7. Edit the wpdmtp.inf file, inserting into it what you copied in step 3 as shown below:
; Device is identified by Microsoft OS descriptor
; If your device doesn’t support it, use specific VID & PID for identification
;
[Generic.NTx86]
% GenericMTP.DeviceDesc% = MTP, USBMS_COMP_MTP
% GenericMTP.DeviceDesc% = MTP, USBVID_18D1 & PID_4EE2 & MI_00

[Generic.NTamd64]
% GenericMTP.DeviceDesc% = MTP, USBMS_COMP_MTP
% GenericMTP.DeviceDesc% = MTP, USBVID_18D1 & PID_4EE2 & MI_00

8. Save and close the file.
9. Connect Nexus to computer
10. In the device managerupdate MTP drivers
Next, unzip them into a separate folder (for example, in the c: driver disk)
We go to my computer ->Properties
select the service tab ->equipment ->Device Manager.

In the device manager, we are looking for a device with an exclamation point. This is our nexus.
Click on it with the right mouse button and click Update driver.
Click Run driver search on this computer.
In the Search for drivers line in the following place: drive the path to the folder where our drivers extracted (In my case, this is c: driver)
Put a tick in front of Including subfolders
Click Next
11. Done
If the drivers are not installed
Recovery
Easy way to install custom recovery without a computer
RecoveryME for Nexus devices - A program for firmware recovery.
ClockworkMod Recovery (CWM) 6.0.4.7
For firmware through recovery :
Touch version
Without tach.
For firmware via fastboot :
With that.
Without tach.
Also ClockworkMod can be flashed throughROM Manager by installing it from google play.
Where is the backup made in CWM stored?
XDA thread
Team Win Recovery Project (TWRP

PhilZ Touch 6 Recovery CWM Advanced Edition 6.x
TWRP Holofied - Able to flash img files, you can change themes.
What should I do if after the reboot the installed Recovery flies?
For 5.0.
for the rest: you need after installing Recovery without rebooting, go into Recovery and flash this archive:Attached filerevert-recovery-disabler_signed.zip(142,02 KB)
This archive removes the protection of Recovery from overwriting.


Root Rights / Root
The process of receiving rutprav data does not delete (if you have an unlocked bootloader). .
Kingo Android Rootgets root and unlocks the bootloader "in a couple of clicks" (with data loss)
Getting root without a computer
We get the root of the rights to 5.0: flash through the SuperSU custom recovery version above 2.27.
Instructions from green-08 and nazgul_ssm
RootME for Nexus devices - a program for obtaining root rights (works on 5.0)..
Removing root rights
SuperSU on4 PDA.
Superuser on4 PDA.

Useful
The last radio is 2.0.1701.04, the last bootloader is 30f .
Theme "Perezalete" .
Nexus 4 bootloader collection .
Collection of radio modems for Nexus 4
Kernels under custom recovery .
What and where is in the full image of the firmware.
ADB and all that can be done with it
Rar for android - unpacking / creation / treatment of archives.
Firmware in parts and in its entirety
Pharmacy (drugs, vitamins)
At 5.0, poor performance of WiFi on 11-13 channels was noticed on some devices - install others .
Speed ​​up mobile chrome .
Diskdigger - restore deleted images and videos.
wi-fi speed and range increase
help with changing the MAC address when rebooting and problems with pairing via bluetooth .
wifi connection troubleshooting
Attached filesoundfxfix.zip(265.07 KB)
- fix stuttering sound when listening through BT headset (worked on 4.3, on 4.4 they say fixed).
New dalvik and bionic patches for 4.4. * .
After installing these patchesbe sure to cleancache ( wipe cache partition ) and dalwick cache ( advanced - wipe dalvik cache ). To rollback, use backup or flush system.img . What do they give .
New Qualcomm GPU Drivers - tested on runoff 4.4.2 and higher.

Survey Screenshots
Attached Image

Attached Image

Attached Image


Post has been editedvaalf - 25.05.17, 20:45
Reason for editing: deleted broken links



Rep: (1829)
I recorded a video instruction on how to unlock the bootloader, get Root rights, install custom recovery - CWM Recovery on your Nexus 4 smartphone.
http://www.youtube.com/watch?v=DO8yEzBs59A




Post has been editedpincher65 - 14.12.13, 22:03



Rep: (9)
Shoker009,
it pleases of course =)
And the root / boot / CW do not fly off?



Rep: (356)
ArtemTLT,
I have a root and recovery have flown, to make back a minute thing ...

who needs, I can share the key for NEXUS 4 TOOLKIT, write in a personal

Post has been editedShoker009 - 19.12.12, 16:26



Rep: (174)
Zdarova guglovody.Cheto I have some sort of a mess with the installation using CWM.S programuliny NEXUS 4 TOOLKIT hardly received unlock, Ruth and rekaveri, (I thought) .After reboot smarta neither root nor rekaveri nema.Ladno, something like once again to Ruth got a hand, it turned out there is a shortcut, all rabotaet.Potom as (without this toolkit) rekaveri flashed, like sewing, in the console command writes all OK. Immediately after the reboot into CWM comes dashing, but if you download the smart, turn off the power and then try to go through the bootloader, it is no longer comes, the choice falls on the menu rekaveri android triangle krasnym.U somebody such was or try another CWM?
Thanks to all.

P.S. I put the recovery-clockwork-touch-6.0.2.3-mako.

Post has been editedmopss - 20.12.12, 01:15



Rep: (356)
mopss
version of NEXUS 4 TOOLKIT what?
Try in the NEXUS 4 TOOLKIT fifth point, it can help. I have TWRP recovery not crashing

Post has been editedShoker009 - 20.12.12, 01:21



Rep: (174)
Shoker009 @ 12.20.2012, 00:20*
version of NEXUS 4 TOOLKIT what?

Google_Nexus_4_ToolKit_v1.3.0

I'll try.

UPD. And even such a chip, when choosing to install the recovery, writes<waiting for device>supposedly waiting for the device, but nothing else happens.
old version, the latest 1.6.0

There is no CWM installer, there is only root-anrute, lok and unlock.

UPD. Hmm ... stuffed thisrevert recovery disabler, so far the recovery plows.

Tried and 5 and 6 points, does not sew.
Only via fast boot, and only with the use of the patch revert recovery disabler, 6.0.2.3 works

Post has been editedpincher65 - 23.12.13, 13:08
Reason for editing: combined



Rep: (27)
Shoker009,
I drive the first command and nothing happens .. Cmd writes "Waiting for device" ...

Posted 12/20/2012, 11:00 am:

Shoker009,
Apparently, no, there is an inscription in fastboot: secure boot - enabled

Found unlock instructions ...
M
No need to produce messages. This is not Twitter. Use the buttonPicture


Post has been editedLIR - 20.12.12, 15:20



Rep: (10)
I took the instruction from the first post of the topic "Firmware".
1 Step. Booth unlocked. All OK.
2 Step. I'm trying to install a recovery. Writes OK. In fact - how to run it?<Up>+<Power>do not help.
I changed it three times with two different recovery from xda. No reaction.



Rep: (356)
redrover
After fastboot flash recovery recovery.img, do you restart the smart?
robot with a red exclamation mark?

Post has been editedShoker009 - 23.12.12, 13:17



Rep: (10)
Shoker009,
Yes, after the above commandflash recoverythe console produces 4 lines, the general meaning of which is: the operation was successful, everything is OK.
Then manually reboot the smartphone. And I try to log in using a combination of buttons: Up + On.
Now I tried to go through the boot, as you indicated, and saw a robot with a red exclamation.



Rep: (356)
redrover
After the flash recovery command, without restarting the smart, try entering the recovery. if you need something to flashthisarchive

redrover @ 12/23/2012, 4:19 PM*
And I try to log in using a combination of buttons: Up + On.

so you just will not go down + on

Post has been editedShoker009 - 23.12.12, 13:22



Rep: (10)
Shoker009,
Hm! It helped without flashing extra. archive.
Just went into extended recovery and rebooted from there.
Then he rebelled again and entered again.

If it's not a secret, what does this archive do?



Rep: (62)
Hello,
There is such a question: if I unlock the bootloader and put the cmw, and then have to carry it under warranty, can I get everything back in place so that no one has noticed my interference with the phone?



Rep: (356)
ChesterBY
Yes, you can instruction in the cap

Post has been editedShoker009 - 27.12.12, 23:10



Rep: (45)
Attached Image

At one of the initial stages, something like this pops up - the phone reboots, debugging is turned on - further the void

Posted 12/24/2012, 17:36:

what does he want from me as a result further?

Post has been editedvitallus - 25.12.12, 12:24



Rep: (356)
finiok
debugging included?
settings / for developers / debugging by usb

I advise you to use the latest version of nexus 4 tools 1.6.0

Post has been editedShoker009 - 24.12.12, 17:43



Rep: (45)
Shoker009,
debugging enabled



Posted 12/24/2012, 17:44:

With any option, everything stops at the moment when you need to enable debugging in the loaded phone - it is there and a notification about it too - but



Rep: (356)
finiok
In the device manager, check if there is a device with a yellow triangle, maybe the firewood did not stand up



Rep: (45)
Shoker009,
Before that I checked - everything was normal, but now voila - there is no MTP .. how can I fix this correctly?
as I remember, auto-update only in the paid version of the script. where to install 1.6.0 ....

Post has been editedfiniok - 24.12.12, 17:49



Rep: (356)
finiok
device with a yellow triangle mako called?


Full version    

Help     rules

Time is now: 07/05/20, 12:09