> Attention!

We strongly recommend to readRules section "Android - firmware"

New threads need to be created only inroot partition! In the future, they will be processed by moderators.

Samsung GT-I9300 Galaxy S III - Official firmware

Rep: (691)
Samsung GT-I9300 Galaxy S III - Official firmware
PictureSamsung Galaxy S III, SGS3, GT-I9300, m0
Description | Discussion | FAQ | Accessories | Marriage / Repair | Wi-Fi setup and problems | Power consumption (autonomy) | Editing system apk | Modified and stock kernels | Custom recovery | EFS Recovery (IMEI)| Firmware:Official | Custom | MIUI | OpenSource ( 4.x | 4.4 | 5.x | 6.x-7.x ) | Topics for CM12 / 13

Drivers and Utilities


Firmware instructions

Frequently asked Questions
AT : What is the best firmware for Samsung Galaxy S3 I9300?
ABOUT :Best firmware

AT :How do I get the Samsung Galaxy S3 I9300 firmware update?
A: There are several options for receiving updates:
1. Wait for the phone to notify you that there are updates for your phone. To do this, in the "Settings" menu ->"About the device" ->"Software Update" checkbox "Auto Update".
2. Install the Samsung Kies program on the Windows computer, connect the phone to the computer and wait for the update notification in the Kies program.
3. With the help of instructions, firmware, tools and explanations presented in the header of this topic. It is very useful to understand the essence of the process.

AT :Where can I download the user manual
ABOUT :By this link

AT :The Russian keyboard is displayed, and prints in English
ABOUT :Decision.

AT :Where can I see the modem version and firmware version?
A: In Settings-About device-The firmware version is the version of the modem (transfer curve from Samsung), the Build number is the firmware version.

AT :How to change regional binding (Sales code, CSC)?
ABOUT :I have 4.0.4

AT :How to check the regional binding (Sales code, CSC), why does the code * # 272 * (your IMEI code) # not work, why does the CSCSelect program not work?
A: On firmware 4.0.4, this information is checked by dialing * # 272 * (your IMEI code) #. On firmware 4.1.1 and 4.1.2, the code * # 272 * (your IMEI code) does not work. This code can be seen in stock recovery (text in yellow, line - Applied the CSC-code: three letters of the code) and in the Kies program in the firmware version at the end in brackets.

AT :When I try to update by air (FOTA), in response, he writes me: Access to the software service is provided to users one by one in the order of request.
A: According to some data (there are reports of a successful update), you can get a FOTA update without a queue early in the morning, around 5-6 am by MSK. If you do not want to wait for the queue, you can update via Kies / Odin PC / Mobile Odin.

AT:Installed 4.1.2, flashing single-file 4.1.1 or 4.0.4, after the firmware Samsung screen saver hangs and then the phone does not boot, what should I do?
A: You will have to do Wipe with everything and Dalvik Cache and Cache and Data / Factory from Recovery, since there are different databases, so take care of saving your data. Just installing over will lead to Bootloop and the phone will not load further. And just resetting it to the factory settings will not help, all Wipe needs to be done from Recovery. Upgrading runs without problems, and downgrading carries some problems that can be solved, but problems В© vasyadubov

AT :How do I remove the root?
A: In SuperSu, on the Settings tab.

AT :Why is the update on OTA not going?
A: With custom recovery there will be no installation of OTA updates. So for the installation of OTA-updates, the recovery is used and there is still no custom recovery working on the stock algorithm with which and only OTA-updates are installed.

AT :How to add languages ​​to enter the firmware 4.1.2, if they are not?
A: "Menu" - "Language and input" - "Samsung keyboard" - "Gear wheel" - "Input languages" - "Available languages"

AT :When changing CSC with CSC Select, the message "preconfigui does not support single csc" appears
Рћ: You have a phone with carrier firmware and a single region, so there is nothing to display, besides, it can be locked under an operator

AT :How to download i9300 Galaxy S3 in Firmware Mode / Download Mod / Download Mode?
Рћ: Loading the device by simultaneously pressing the buttons "Volume down" + "Home" + "Switching on" / "Vol Down" + "Home" + "Power". Exit this menu - long press the "Power" / "Power" button.

AT :How to load I9300 Galaxy S3 into Recovery Mode / Recovery Mode / Recovery Mode / (CWM Recovery / TWRP Recovery, if installed)?
Рћ: Loading the device by simultaneously pressing the buttons "Volume up" + "Home" + "Switching on" / "Vol Up" + "Home" + "Power"

AT :Touchwiz drops when you delete the desktop, everything was fine before the update!
A: ReadFast.

AT :What applications can I remove painlessly from the firmware?
ABOUT :Here is a list(if it saysYes it does not mean that you will not need the application).

AT :I want to get rid of system update notifications, what should I do?
A: The simplest way (Root is required) is to freeze or delete 2 files from / system / app:FotaClient.apk and FWUpdate.apk

AT :How to reset the counters and that the state would be "Normal"
ABOUT :Here is a simple instruction

AT :What is the difference between 1-file, 3-file and 5-file firmware?
A: Mostly the differences are in the content, but the result may differ. 1-file firmware is official, 3-file firmware - service 4.0.4, and 5-file firmware isDetails

AT :What is the SS_DL.dll file for?
A: He is not needed. It can be removed

AT :On 4.1.1 or 4.1.2 the indicator has become dimmer
Oh yeah. This feature 4.1. He now looks at the light sensor and, depending on his data, sets the brightness of the indicator

AT :After the firmware sdcard became sdcard0
A: Starting from 4.1 so for everyone

AT :What Root is needed for my version of Android
A: For 4.0.4 and 4.1.1 CF-Root, Auto-Root, ExynosAbuse. For 4.1.2 CF-Auto-Root

AT :After upgrading to 4.1.1, Flash does not work.
ABOUT :Here is the solution

AT :How to connect the phone as USB flash
A: None.Details

AT :Can I flash my phone with operator firmware?
A: You can.

AT :When sending SMS, the recipient receives one question mark.
A: To send SMS in the SMS settings, set the input mode: Automatic.

AT :After firmware 4.1.1 (4.1.2) in Recovery mode, the robot lies with an exclamation point. What does it mean ?
A: The fact that you have firmware 4.1.1 (4.1.2) and this is stock recovery. Nothing else.

AT :Does stock recovery come in single-file firmware and how can it be restored?
A: Yes, enters. You need to flash it again with your firmware.

AT :How do I replace the font in the phone ?
ABOUT :Link. All questions in the link on the topic.

AT :Where can I find Service Manual?
A: Bby thispost

AT :What should I do if the memory card is not visible from the computer, but does the CWM see it?
A: Decision inby thispost

AT :What is the difference between Odex and Deodex firmware?
ABOUT :This is what.

AT :I put it in one of the Root methods, and no rights are given to applications, and SuperSU applications (or Super User) are not in the program menu
A: You need to put SuperSU from the Market.

AT :Does CF-Auto-Root modify the stock core or not?
A: CF-Auto-Root-m0-m0xx-gti9300 establishes stock recovery from 4.1.2 and adds 3 files to the system in order to obtain root-rights and control the receipt of other root-access programs through SuperSU. It is here called rutovanny stock.

AT :How to enter the "Developer Options" on 4.2.1, 4.2.2 or 4.3?
A: It is necessary in the Menu / Settings / Options / About the device - 7 times to tap on the assembly number and everything will appear.

AT :How to make a wipe?
Рћ: In stock Recovery, make wipe data / factory reset and wipe cache partition.

AT :Tell me how to determine which bootloader is currently installed on the phone?
Рћ: Use the programAndroid System Info. System section, subsection BuildInfos.

AT :After rolling back from the I9300XXEMG4 firmware, the IMEI has flown or changed and there is no possibility to call.Details.
A: The reason is that the new modem in XXEMG4 changes the format of the EFS partition and, when rolled back to earlier versions, IMEI crashes. The solution is to flash XXEMG4 back and IMEI will be restored. Or usesolution with xda

Useful information
A small FAQ on firmware 4.3
What is the difference between firmware for the CIS countries: SER, SEK, RTL, SKZ, CAC?
And what's the point in the "normal" state?
Firmware mode, recovery and how to enter into these modes?
Permissions for files and folders in the EFS folder.
What can be removed from stock applications Samsung Galaxy S III GT-I9300 in firmware from XXBLH1 (4.0.4) to XXUGOE1 (4.3) with the SER region
How to fix md5 sum error in backup
What regional application was added in 4.1.2 for Russia
About CSC and Sales Code
When the serial number starts with 0000 ... and the phone says: No network. The selected network is not available For custom recovery
Where to watch phone status?
Android from the inside or just about complicated
If from the settings menu, perform a reset or do Wipe what will happen to Root
What is the difference Samsung firmware
How Root and Custom Recovery Affect Firmware Updates
For lovers often flash. Possible consequences
Saving firmware downloaded via Kies
How to decipher the name of the firmware
About the features of installing new downloaders
How to check your Galaxy SIII (GT-I9300) for originality
Concerning dances with a sysscope and a "normal" state
What is the difference between the firmware La Fleur and the rest of the stock firmware?
How to remove a message when selecting an update over the air "Your device is changed. There are no updates"
Where does the RAM go?
What to do if your phone does not see the network or writes "No network" "The selected network is not available"
Secret Codes
About the reasons for the rally IMEI
Explanation of the new EFS formatta, patched modems and the lack of mobile communication after updating the firmware
How to enter the "Safe Mode" download
Differences between EFS Versions and Android Versions
Solving the problem with the Internet on 4.3 for Beeline owners
How to remove a translucent Factory Mode window with information about PDA, Phone, CSC, H / W, RF Cal Date, SMD,
Camera firmware(all questions - in the topic of the link).
Russian S-Voice
How to change labels in multi window to 4.1.2:Solution 1 Solution 2(All questions - in the topics on the links).How to activate multi-window?
Getting official stock firmware 4.1.2 SER without regional applications
Stock firmware for Russia with Root. Odex and Deodex
Downgrade to the old Bootloader with the new XXELLA:Method 1 Method 2 Method 3
About SDS (sudden phone death) from tester99 Sudden death fix Ultimate GS3 sudden death thread
Returning the state to "Normal" on a new bootloader and custom recovery and resetting counters
Instructions for "resetting" the counter and getting the status "Normal" using Triangle Away
Change CSC without deleting data (on XDA)(All questions in the link on the topic)
Scripts to clean the phone from the firmware and cores For 4.3
Triangle away. To reset the counter (to the status "Modified" \ "Special" is irrelevant).
Samsung Galaxy S3 Toolkit 7.0andAdb
An application that allows you to use an external ExtSD Card as a USB drive
Upgrading I9300XXLH1 SER (4.0.4) to I9300XXDLK1 SER (4.1.1) as root
Normal condition according to instructions from tester99
How to change the state of the Root phone to "Normal", while maintaining the root
Back up the system (backup) I9300 with / efs from TWRP custom recovery
For those who want to try new firmware 4.1.2 without changing their region
Transition from the old I9300XXELL4 (SER) to the new I9300XXEMA2 (XEF) with a new bootloader
Update official Russian 4.1.2 I9300XXELL4 (SER) to the new official 9300XXEMB2 (SER)
Personal experience on updating from XXELL4 to XXEMB2 from vasom
Firmware update with saving data, settings and, if necessary, resetting counters / status and firmware bootloader
How to flash Bootloader
When trying to turn on, it does not go anywhere and writesFirmware upgrade encountered an issue
How to remove the firmware from Kies
How to find out the region for which issued Samsung Galaxy S3 I9300
How to backup applications and their datawithout Root
How to flash a separate part of any single-file firmware
If you have trouble logging in to recovery
How to solve the problem if the efs folder flies (for those who installed firmware based on EMG4)
How to sign a backup EFS and how to determine from which firmware it is
The official program to raise the "littered" boot
How to find out which version of your EFS backup?
The program untie the smartphone SGSlll from the operator
The program allows you to emulate a USB cable JIG and enter the smartphone in Download Mode.
E: failed to mount / efs (Invalid argument) and how to deal with it!fromshoma_81
Problem resolution: failed to mount / system (Invalid argument)fromLichten
Stock recovery from UGMK6
Unified Android ToolKit v1.2.8 (25th April 2014)
Solving the problem with time zones after 10.26.2014 and the transition to a permanent winter time Method number 2
Incremental update FOTA (throughstock recowery)
Samfirm - utility for quick downloading of official firmware
Reset your pattern, PIN, or screen lock password
Unlock Network (Unlock)

For questions about filling and updating the topic header, contact the Curator at QMS
The curator of the topic is Vetal`M

Post has been editedVetal`M - 28.05.20, 18:10
Reason for editing: Logo

Rep: (63)
I9300XXALE8 peoplehttp://narod.ru/disk/50860786001.fcc6cacc2...E7_OJV.zip.html
Attached fileFlashprogram_Samsung_I9300 ___ Pit.rar(411.3 KB)

Post has been editedBladeMaster26 - 28.05.12, 18:17
Reason for editing: Added one

Rep: (4)
* Original flasher Odin3 v3.04
* PIT files
* Firmware I9300XXALE8_I9300OJVALE7_OJV
* Drivers
* Brief instruction (Flash guide I9300)

Rep: (2524)
Backup and Restore IMEI (efs) on I9300

As it is known, before starting the manipulations with the phone, it is strongly recommended to save the most exclusive information —IMEI of the phone, which is located in the / efs folder.
Let me remind you if you lose this folder or files from it it will not be possible to use the device as a phone, and the GPS function will also disappear.
This folder is exclusive for each device, and if it is lost, it is not recoverable ...
So, let's begin:

1. Method of copying efs folder to other media
This can be done through the Root Explorer (need root)
* the way it is done in execution, but after recovery you will have to re-set all rwx ----- radio.radio files

2. A way to create an archive on the internal sdcard using adb or teminal
A source:
1. Through RootExplorer or another tool we look in / efs. All files must be in place, incl. nv_data.bin and nv_data.bin.md5, nv_data.bak and nv_data.bak.md5. If not, this algorithm will not work for you.
2. Look at the date of creation of the above files. Their date must be different from the date of the bak files. Then there is a chance. In my case, the date nv_data.bin was 02/01/2012, and its bak version was 01/01/2011.
3. If you just carry nv_data.bak and nv_data.bak.md5, this can not help! Those. as if they kind of have to recover from bak files, but for unknown reasons this can not happen. I after removal and reset the date of these files has always 02.01.2012, and anything you do with them! With that, I have to delete a file after nv_data.bak.md5 he immediately recovered with the same ill-fated date. Even if you explicitly copy bak files renaming the bin and md5, past all the same after a reboot recovered from somewhere on the date 02.01.2012. Therefore, we go further.
4. You need to backup / efs now. Yes, now, after a breakdown, everything is correct. We do, for example, as described (with a slight revision):
adb shell
busybox tar zcvf /sdcard/efs-backup.tar.gz / efs

5. Copy the bak files next to backup: nv_data.bak and nv_data.bak.md5, rename them to nv_data.bin and nv_data.bin.md5 respectively. They will be useful to us for substitution.
6. It is necessary to reformat the / efs partition, then return the files to it. Because on signs there are some fierce problems with the file system, because of which the files can not work, neither we nor the system properly. We do:
umount / efs
mke2fs / dev / block / mmcblk0p3
mount -w -t ext4 / dev / block / mmcblk0p3 / efs
busybox tar zxvf /sdcard/efs-backup.tar.gz -C /

7. Here / efs is fresh, now you can rub nv_data.bin and nv_data.bin.md5 in it
8. Copy these files from those that were made in paragraph 5.
9. Restart the phone.
10. You can poke back and forth offline mode.

3. A way to create an image for firmware via Odin or from adb
A source
a) Install a terminal from the market, get root, in the terminal run:
$ su
# dd if = / dev / block / mmcblk0p3 of = / sdcard / efs.img bs = 4096

The image will be saved in the sdcard root.

b) via ADB:
adb shell su -c "dd if = / dev / block / mmcblk0p3 of = / sdcard / efs.img bs = 4096"

The image will be saved in the sdcard root.

$ su
# dd if = / sdcard / efs.img of = / dev / block / mmcblk0p3 bs = 4096

adb shell su -c "dd if = / sdcard / efs.img of = / dev / block / mmcblk0p3 bs = 4096"

I9300 EFS Backup / Restore

It will help to save and restore the image of the EFS partition:
* Need Root
* Extract from the archive, connect the device in USB debugging mode and run the desired .bat (depending on backup or restore)
* When restoring, the efs.img image should be located in the folder with Restore_EFS.bat

Attached fileEFS_Backup_Restore_new_ADB.rar(155.48 KB)

Attached Image
Attached Image

Blank EFS Image - for those who broke the efs section, anyway ...
So, I made an image for you, you can flash it alone to restore the broken partition for further filling from the saved folder (for those who have an image of their efs it does not make sense)
Attached fileI9300EFS_EMPTY.zip(5.02 KB)

But this is not all - after filling the section, you need to check the rights and owners of the root files in the efs folder with the Explorer and set them according to these screenshots
the owners
Attached Image

Attached Image

Attached Image

Attached Image

Attached Image

Attached Image

After that, you need to flash "First Aid" - you can without a pit ...
Samsung GT-I9300 Galaxy S III - Firmware


In general, I thought here and shoved everything into one ...

Automatic creation of a text file of all device parameters at the time of copy creation
Automatic backup efs:
* Odin flash file .tar.md5,
* raw.img
* tar.gz archive
Automatic naming of files and archives corresponding to the firmware version
Recovery to choose from archives and backup images
Automatic start of Odin and transition to the firmware mode when choosing Odin Restore

System requirements:
Samsung I9300 - root, USB debugging, busybox
Windows - Samsung USB driver
Attached fileSAMSUNG_I9300_EFS_BACKUP.zip(3.14 MB)

Post has been editedA.S._id - 22.09.13, 15:05
Reason for editing: +1 from Roma715 ...

Rep: (2524)

Attached fileOdin3_v3.04.zip(467.67 KB)

Attached fileOdin3_v3.06.zip(471.75 KB)

PIT- for partition markup(use extremely carefully and only on full firmware)
Attached fileI9300_PIT.zip(822 bytes)

To use enable USB debugging, run RUNME!
Attached fileadb_win.zip(402.68 KB)

Attached fileadb_linux.zip(71.13 KB)


Post has been editedVetal`M - 08.05.17, 14:45
Reason for editing: In the header

Rep: (4018)
I posted a dump of the firmware in partsI9300XXALEF (app + lib + framework + etc)

Post has been editedPako777 - 03.06.12, 22:14

Rep: (4018)
Roubchi @ 05/06/2012, 09:19*
I missed maybe, and the correct Service Manual (or what is his name) to SGS3 somewhere already there?

there is
Attached fileI9300_Service_Manual.rar(11.54 MB)


Post has been editedVetal`M - 08.05.17, 12:02
Reason for editing: In the header

Rep: (1138)
Roubchi @ 06/06/2012, 12:09*
coke and de clox

The Code of deodeksa differs only in the structure of the application. In The Code for each application executable code submitted separately in a file .odex, who was lying next to the application itself. In deodekse this code is packed into apkshki application. Saving space, this time, well, simpler modification of system applications, they can be changed easier. Less deodeksa and mythical IMHO - is that when you first turn on the device after the firmware is created Dalvik cache, so the device is loaded for a long time. But this happens once, and thereafter it works the same way. Anything more than this does not affect nor honest software or performance. Just if you feel an urge to deliver the modified system application (for example, to tie Russian search in the dialer or fix Rousseau strip in contacts), then deodeksirovannye application is very simple and convenient to change as root without dancing with The Code files.

Post has been editedVetal`M - 08.05.17, 12:04
Reason for editing: In the header

Rep: (4018)
As i9000 @ 06/06/2012, 16:55*
Here you have access to an external flash drive:

in the LEF firmware on the drain it already is

Rep: (2524)
cacagaga @ 8.6.2012, 13:16*
In other words "internal memory" (as written in all instructions)
This is what I call it: rolleyes:, for a better understanding of what is being said: D

Yes, the memory is there, but there is no section on it that can be mounted as a USB drive, well, as it was on the laptop, there the date was wiped, the settings went off, and all the music there and the music remained in the ums section, and here the date was wiped, I got the settings from the factory: )
But nevertheless, I here solved the issue with the wipe:
Samsung Galaxy S III - Firmware

Post has been editedAs i9000 - 08.06.12, 12:29

Rep: (385)
PANd4 @ 06/09/2012, 11:30*
what script the very core in the tar format, stuck in the zip archive

I guess I still did not put it correctly, or rather did not meaningfully translated the words of the author. (sorry)
But in princepe the essence is correct! (more thoughtfully translated again)

This is written by the author Maker (Chainfire) in the kernel descriptionCF-Root 6.1 :
CF-Root for all users. CF-Root is designed to be used in combination with Samsung firmwares.
This does not include a custom kernel. Adbd (ro.secure = 0), custom boot scripts, and custom boot animations are not supported.

CF-Root is a root for "beginner routers" and those who want to stick as close as possible to the drain. CF-Root is designed for use in conjunction with the Samsung stock firmware, it is the fastest and easiest way for the first root.
Unlike CF-Root for some other devices, this iteration of CF-Root does not include a custom kernel. Your kernel remains the stock kernel, hence this is a plus, in relation to unsafe adbd (ro.secure = 0), custom download scripts and custom download animation are not supported.

P.S ...

Yesterday I decided to do an experiment (turned out to be successful!)

As soon as I bought the body, I immediately rutted it from the PC using a scriptCF-Root 6.0
The counter ticked "1" (tick only with PC, afterMobile ODIN pro not ticking
Used the utility to reset the counterTriangle Away 1.51 , the counter is reset to "0" (in download mode )
But in the firmware itself, the state has not changed, it remains"changed" (bad for SC)

I decided to make my body out of the box (both counters to zero),but with full root.
1. Went to CWMR and did full wipe:
1. wipe data / factory reset
2. wipe cache partition
3. advanced /wipe dalvik cache
4. mounts and storage /format system
5. mounts and storage /format data
6. mounts and storage /format cache

2. Opened on PC Odin3 v3.04 to install an already routine stock firmware for Russia LEF from respected pro100gamer&Asi9000 which does not touch the counter!
I pressed the reboot of the device, but did not pull the battery, but here I also managed to press the cherished three buttons to go todownload mode
Tsepanul to lace and stitched completely with all three elements includingCSC . As a result, all the counters are on zeros and I have a full root! : D
On the internal memory, all the folders remained, not erased. But I decided to enhance the effect and made a complete reset of the body from the firmware (all the folders were erased, only the daftal ones remained)

3. I decided to reflash my native servist firmware:
InstalledMobile ODIN pro 3.0 and flashed with it Russian service stock firmware LEF (with all three positions)
Pre-installingall three daws for root (EverRoot, SuperSU and Mobile ODIN), including all two daws for wipe (dates, cache and dalwick cache)
The firmware was successful! (nothing worked without failures!) I checked both counters again just in case, everything is all right on the zeros.

How to properly flash the service 3-file firmware throughMobile ODIN pro 3.0 :
1. Open the field "Open file" specify the path toCODE _I9300XXALEF_611327_REV00_user_low_ship.tar.md5
2. Open the "Cashe" field and specify the path toCSC _OXE_I9300OXEALE4_CL606160_REV00_user_low_ship.tar.md5
3. Open the field "Hidden" specify the path again toCSC _OXE_I9300OXEALE4_CL606160_REV00_user_low_ship.tar.md5
4. Open the "Modem" field and specify the path toMODEM _I9300XXLEF_REV02_REV04_CL1147871.tar.md5
5. We are stitching "Flash firmware" (further agree to check the amount of md5: clickcheck )
Pictures :
Attached Image

Attached Image

Attached Image

Forsingle file firmware item is enough 1 (under the spoiler), specify 1. Open the field "Open file" specify the path to the firmware ... md5 )
Next installeverything 5 checkboxes and just flash (all data will be deleted, there will be virgin clean firmware).
Both Sd cards (internal and external) will not affect the wipe.

4. Stitched through Mobile ODIN pro 3.0 custom script CF-Root 6.1 , the jackdaws removed everything, since the script is already rutted.
Once again I checked both counters, everything is in order!
Now haverutovnuyustock Russian firmware with zero counters and a full set of utility from the kettle ( SuperSU v0.89 , CWM v5.5 :: CF-v1.3 and CWM Manager v3.55 )

All I calmed down !!! : heppy_dancing:

Attached Image
Attached Image

Attached Image

Information for those who just bought and did not do anything with the device!
To get a full root with zero counters, you need to start from point2

Post has been editedVetal`M - 08.05.17, 13:10
Reason for editing: In the header

Rep: (385)
And yet? In addition to the software, it is clear that the browser players and software from the Samsung, but there is also a lot of everything ... a lot of incomprehensible APK

Here are the pictures of the "garbage" that I deleted through Titanium:
Attached Image
Attached Image

Attached Image
Attached Image

Post has been editedcacagaga - 14.06.12, 16:31

Rep: (50)
I use this file for faster GPS operation (it contains settings for Russia)

Use CWM (MOD Surarus GPS file - [should work])
Attached file_MOD__Surarus_GPS.zip(143.54 KB)


Post has been editedVetal`M - 08.05.17, 21:54
Reason for editing: In the header

Rep: (84)
Colleagues, great advice to everyone
- if you have found some firmware / kernel / program / information on the Internet and ask a question about it - provide a link to the source, perhaps you missed something, more attentive forum users will find the answer to your question;
- if you want to share a new firmware / core / mod / know-how in the forum - cite a link to the original, and out of respect for the author of the original post, and so that others could come up to the original source if necessary;
- carefully read the original posts, as a rule the author puts all the necessary instructions. Do not know the language - use an online translator. Do not load the surrounding issues due to the fact that you are too lazy to understand the question yourself;
- Dear newcomers, do not rush immediately to flash everything that is possible, if you do not understand what you want to achieve, and what actions need to be done for this. Read a week's forums, reviews, get acquainted with the problems and experience of solving them. Start with the most reputable site -xda-developers.com, read the sites of specific firmware developers

following these simple rules will help make the forum more readable, and your life easier

Post has been editedMrMikeSv - 15.06.12, 07:32

Rep: (2524)
dunesf @ 15.6.2012, 3:30*
Triangle Away who worked? I passed, but the state is changed and it remains.

This is what our French comrade Chainfire tells us about this:
- On SGS3 in the firmware mode in the SYSTEM STATUS menu it is written custom and in
->Settings->About device->The state still shows “Changed” and Triangle Away does not restore this parameter to “Normal” ...
- It goes beyond Triangle Away. "SYSTEM STATUS" is not in the bootloader. If you are going to take advantage of the warranty, you must also reflash with full firmware (for Russia, a three-file service will work) with a full wipe. (If you load the device and find the root application, you will not receive a guarantee in any case). If you flush a full stock with a wipe, the "custom" value will be reset ...
Link to article:

Post has been editedA.S._id - 15.06.12, 08:17

Rep: (1138)
Frontoz @ 06/15/2012, 10:50 PM*

Naturally remains. When a wipe is formatted, the / data, / cache, / dalvik-cache partition is formatted, but the / system partition, where the root actually sits, remains intact. By itself, the root is the su binary, usually sitting in / system / bin or / system / xbin, the Superuser.apk application, located in the / system / app folder, and bizybox with its symlinks, it is in / system / bin or / system / xbin happens.
Ruth flies only when flashing, when the contents of / system are replaced.

Rep: (1829)
Well, this inscription to the counter has nothing to do. Apparently, the main system files are scanned, and if the hashes do not match, the system makes a conclusion about the modifications. In order to have the inscription "Normal", at least you need to have a stock firmware stitched with all the wipes.

I think that is not quite so. Rather, it scans applications related to the root. I made this conclusion for the reason that after flashing with a single-file official firmware I saw that the scan had passed and had written changed. When I made Hard Reset and all third-party software was removed, the scanner wrote - Usually.

Rep: (1829)
I recorded a video for newbies. How to flash through the latest firmware One and how to do then Ruth. You can add to the cap.
Good luck cutting and sewing guys. : thank_you:

Rep: (47)
After reading the forum, I did not stand up and decided to conjure a little and ask for a roll (I9300XXALF2 2012 June) for newer ones.
Originally stood i9300 XXALE8 .....
The easiest way to get root on sgs3 in my opinion is done in three stages and takes 2 minutes
1. Through one Odin3_v3.04 (and also checked Odin3 v1.83 also works) rolledSiyah-s3-v1.0
2. continue to run on the bodyTriangle away, reset the counter.
3. One rolls the kernel from the original Kernel_I9300XXALE8.tar.md5 firmware
All the root, recovery and super user in your body. Counterzeros (official) phone status the usual
With the firmware is also nowhere easier.
1. Boot into CWM (volume_up + home + power) and do Nandroid backup, wipe data / factory reset, wipe cache partition, reboot system now and immediately after the command again hold down the three volume buttons (lower key) + home + power and enter the body in boot mode (one).
2. In one boxPDA Substitute firmware I9300XXALF2 2012 June I9300OXAALF2 United Kingdom in advance
unzip it to the state.tar.md5 start and everything.
FARTHER making sure that there is no difference whatsoever (the performance is almost the same 5630 XXALE8 and 5570 XXALF2-quadrant
He also catches satellites at times, and in general he didn’t see the difference).Kies body saw and could then update myself.
Variant as it is advised to ask the official and everything will be a type-top does not roll, Kies will send you., Kies is interesting to check for updates. It looks at the currently installed ProductCode + firmware. the country is encrypted in the ProductCode (and the operator is often), and if there is no new firmware for this country / operator and your old firmware, it says that it cannot be updated.
Checked the data this way: when you connect the phone and the identification data of the current firmware, region, product code read from the phone and stored in the registry. When you click Update Firmware Kies reads data from the registry and looks there for a combination of new firmware. Those. to update the firmware to the desired us, we have to keep in registers readily combination: Tekushev firmware + product code, for which there is a upgrade (SoftwareRevision + HIDSWVER + ProductCode). It does not matter what firmware and any product code in the phone itself. (Change the code on your phone is not necessary!) (Description Kies work not mine Post # 36 temaInstruktsiya, FAQ rom. Problems and Solutions)
1. Knowing that I stood before the experimentI9300XXALE8 I download it from here (I9300XXALE8 4.0.4 2012 May I9300OXEALE1 Russia)
2 through one in the PDA field (without having forgotten to unarchive), we sew up as soon as one downloads the robot and in the body unscrews its cadabras, go to the usual recovery and do wipe data / factory reset, wipe cache partition, reboot system now.
And now you have a body in your hands like you bought in a store, with the possibility of upgrades through keyis and air. All counters are nil nos., Usual
All of the above is done on your phone. : blush:

Attached files

Attached fileKernel_I9300XXALE8.7z(4.7 MB)

Rep: (1138)
Roubchi @ 06/18/2012, 10:36*
So, where there are three wipes in a row and three formats of something there - the recovery-partition will NOT get stuck and even after the factory I will NOT get
quite a brick, because I will ALWAYS be able to boot into the Download Mode, after ANY wipe. Right?

I would pick it up myself for an hour, everything would understand what the forum is about: D ... It is easier to memorize with direct tinkering than empirically ...
So. Wipe data - formats the data section. That is, deletes all user data.
Wipe cache - the same with the cache does. Wipe dalvik-cache - speaks for itself.
Format system - here the firmware is being killed. Naturally, the recovery and boot are not affected, so that so ...

Rep: (60)
So, if someone suffers the same trouble when the memory card is not detected by the phone and computer, but is perfectly visible through CWM-Recovery, then here’s how to copy valuable data from it:

1. Boot into recovery and mount sdcard partition
2. Connect the phone to the computer, install the drivers for Android Phone, if there are none
3. Install ADB, eitherAndroid commander(recommend)
4. If you installed ADB, then mount the sdcard partition, if Android Commander, then just select this folder
5. Using the pull command, we copy all the necessary files and folders, or via Android Commander we simply copy to the right folder.
6. Rejoice :)

It also happens that if there were files with Russian names on the card, then after the “recovery” the names will take a deplorable look, since the names are written in UTF-8 encoding, to return them to a readable form, you can use the pluginWdx translitfor Total Commander:
1. Install the plugin
2. Go to the directory where the files with names in UTF-8 are located and select them
3. Press Ctrl + M and in the Mask of the file name field delete the template, then click Plugin, where we select translit and encoding UTF-8-CP1251
4. All

Post has been editedVetal`M - 08.05.17, 12:03
Reason for editing: In the header

Full version    

Help     rules

Time is now: 12/07/20, 22:03