> Attention!

New threads need to be created only inroot partition! In the future, they will be processed by moderators.



USB connectivity issues | Solving device connection issues to PC



Rep: (617)
Attached Image


Before asking a question with a problem, we read under the spoiler "✔ Solutions".

In addition, we strongly recommend that you familiarize yourself with:
Solving problems with files on the memory card
discussion topic of your device
Enable USB debugging
FAQ on your device
Android OS FAQ
It is possible that the problem you have is directly related to a specific device model,
widely known and its solution has long been found.


BE ALWAYS CAREFULLY READ THE FOLLOWING CAREFULLY!
Why was my post so important removed?
It probably doesn't matchforum rules. Delete without warning the following:
1. Flood, offtopic (p.4.18 PF)
2. Provocations, insults and assaults on the participants of the topic (p.4.8-4.9 PF)
3. “Apes” (messages like “answer me, please,” and the like) (Clause 4.13 PF)
4. Questions, the answers to which are given in the cap (except when the recipe from the cap does not help and you clearly indicated it) (Clause 4.4 PF)
5. Questions "why my post was deleted" in the discussion thread (p.4.21 PF)
6. Oral thanks (p.5.1-5.2 PF)
before creating a message, copy and fill in what is below:
-Brief description of the problem:
-Device / Model:
-Operating system and firmware:
-Even taken action:
If you want to add an image, please read.How to clean the image under the spoiler.
Description
There are five types of USB connectors:
Attached Image
From left to right: micro USB, mini USB, B-type, A-type connector, A-type connector
micro USB - used in the smallest devices like music players and mobile phones;
mini USB - also often found on players, mobile phones, and at the same time on digital cameras, PDAs and similar devices;
B-type - A full-size connector installed in printers, scanners and other devices, where the size does not have a very fundamental importance;
A-type (receiver) - connector installed in computers (or on USB extension cables), where the A-type connector is connected;
A-type (plug) - A connector that connects directly to a computer into the appropriate connector.
MicroUSB 3.0 connectorAttached Image
USB Type-C connector
Attached Image
Learn more about the USB standard
✔ Solutions

What you need to do first


1) Try to replace the cable.
2) Plug into another USB port (preferably behind the system unit, since these ports are soldered directly on the motherboard).
3) Try another PC.
4) Disconnect all USB devices (both external and internal (for example, card reader))

Alternative ways to connect to a PC using third-party programs.

Let's try to check the settings / applications / development / USB debugging .
Attached ImageAttached Image
Attention!If you can’t find a similar item in any way, then you have firmware version 4.1 and higher installed where it is hidden. To access it, in the "About phone" section (you may have a different name) several times (about 10) click on the "Build number". After this, the item "For the developer" should appear.
Enable debugging in particularly advanced cases.
How to return the choices when connecting the device?
Tip 1
Tip 2(review)
In the process of filling ...
Solving problems with the MTP driver. Solving common issues with drivers.
Connecting ZUK Z2 to a computer on Windows XP x32 SP3
Windows10. The phone was identified as a USB MTP device with code 19.
Video instruction Solving the problem with the MTP driver and other not properly installed drivers.
The phone does not want to connect via USB (USB - MTP device - Failure) Addition
Solution to the problemDevice driver software was not successfully installed
MTP USB Device Failed.

Solutions to problems with the MTP driver
Solving the problem of installing the MTP driver on a PC with Windows XP.
Solving the problem of installing a driver on an MTP device, failure to install a driver on Windows 7
Solving the problem with "Error. Code 10." from Microsoft.
Solving the problem of the MTP device by the smartphone
Solving the problem with MTP connection (Code 19) on Windows 10
Solving the problem with MTP connection (Code 1) on Windows 10
Solving the problem with MTP connection on Windows

Proper removal of device drivers from a computer
Device drivers are usually hidden in the device manager as soon as the device turns off or gives a command to hide it (despite the fact that they are still installed in the system). Very often, the "same-name" drivers conflict because of inconsistencies between versions, etc.

The method of cleaning the list of unused devices: (Already, it has been tested by many and gives good results when nothing helps to "see" a working "device."
0. Disconnect all external USB devices from the computer.
1. Create an environment variable named DEVMGR_SHOW_NONPRESENT_DEVICES with a value of 1.
For this: 1.1. Right-click on the “My Computer” icon (My Computer) and select “Properties” (Properties).
1.2. In the dialog box that opens, go to the Advanced tab and click on the Environment Variables button.
1.3. On the Environment Variables panel at the top of the dialog box, click the New button.
1.4. In the “Variable Name” field, type (better copy from here) DEVMGR_SHOW_NONPRESENT_DEVICES, and in the “Variable value” field, enter 1.
1.5. Press the “OK” button twice in a row.)

The created environment variable will allow the device manager to show all device drivers installed in the system (both hidden and all that have ever connected to the computer).

2. Call the manager / device manager:
3. Right-click on the “My Computer” icon, select “Properties” (Properties) and go to the “Hardware” tab.
4. Click on the “Device Manager” button, expand the “View” menu and select the “Show Hidden Devices” command.

5. Start "cleaning" the system from the "trash":
Section 5.1 "Disk Drives" Every time you connect a new USB flash drive, put a new driver. Each time you connect the same USB flash drive, but a different USB port, put the new driver. Drivers of all currently disabled removable storage devices in this section, you can safely remove - they put again when connecting flash drives and other USB-carriers. Among these hidden and unused drivers, and driver will be "on your device" (possibly "bad" and not one). It should be called "Your device" USB Device, but it is not always determined correctly and so the name could be more ... Feel free to remove everything that relates to the "Your device" in this section. When you first connect the "Your devices" new driver from the current established himself or ask you to install it.

5.2 Section "Other devices" Here you can remove all HID (gray) devices - these are all your unsuccessful attempts to put "something". You definitely do not need them ...

5.3 The section "Volumes of storage devices" Here you can delete the HID (gray) "volumes of storage devices" are the "letters" of your flash drives - they are not needed, because will be assigned again when you connect a flash drive ..

5.4 Section "Universal Serial Bus Controllers USB": Here you can remove all HID (gray) devices: "Your device" Device USB Driver, USB storage device, Unknown device and others.
5.5 Restart the computer.

6. After all these deletions, try reconnecting “your device”. It should show up as a new device and Windows will install drivers for it or you install them yourself (on some devices you need to install drivers without USB connection, i.e. connect after driver installation).
6.1 Restart the computer.
Typically, this procedure eliminates all the problems in conflicting drivers "of your device."

7. Thank you for the information provided.Alex_1959,: yes2:
When connected to a PC via usb cable, the device is not detected, but only charged
1) Try to replace the cable.
2) Plug into another USB port (preferably behind the system unit, since these ports are soldered directly on the motherboard).
3) Try another PC.
4) Disconnect all USB devices (both external and internal (for example, card reader))

5) Set the checkbox "Settings \ Connect to PC \ Ask". If installed, remove and reinstall.
6) Try another flash card.
7) Prohibit / remove task killer (if one is installed), or add "PC Synchronization" to the exclusion list.
8) Try not to use adapters / extenders
9) Install the driverAttached filelatest_usb_driver_windows.zip(8.28 MB)
The drivers will also be installed when installing programs from various manufacturers for synchronizing devices with a PC (HTC Sync, Samsung Kies, etc.).IMPORTANT: When installing drivers, be sure to disable anti-virus software on your PC.
10) Make a wipe through the settings of the PDA (reset to factory settings) or through recovery (go to ClockworkMod recovery and perform wipe data / factory reset). This will remove all installed applications and restore the default settings.
11) Reload the PDA and / or PC.
12) Delete the installed drivers and the corresponding software on the PC (for example, HTC Sync), restart the PC, install the drivers again, restart the PC again.
13) use the advice indicatedhere.
14) Turn off the PDA, get the battery, SIM card and memory card for 15-30 minutes.
15) Clean the connectors in the machineUSB connectivity issues (Post # 19849241)and FAQ for Samsung Galaxy Ace GT-S5830iUSB connectivity issues (Post # 20080680).
16) Update Windows Media PlayerUSB connection problems (Post # 20228084)
17) For Samsung owners: update KIES and press "update driver" in itUSB connectivity problems (Post # 20192608)
18) How to connect a smartphone to UBUNTU via USB?USB connection problems (Post # 20478060)
19) Possible causes of problems connecting Samsung Galaxy S III (G
T-I9300) to PC under Windows and their solution.

20) For those who have a computer stopped seeing the tablet (phone)USB connection problems (Post # 24022682)
21) No USB connection to Kies:USB connection problems (Post # 26358851)
22) Reflash.
23) Hike to the service center.
When connected via USB, nothing happens at all.
1) Try to replace the cable. To tryneatlymove the cable in the smartphone connector.
2) Plug into another USB port (preferably behind the system unit, since these ports are soldered directly on the motherboard).
3) Try another PC.
4) Disconnect all USB devices (both external and internal (for example, card reader))
5) Try to clean the connector

In the process of filling ...
He asked himself, he answered. Solving your problem from the user
Some tips for ownersSamsung
Advice for LGP500 owners (and possibly other phones) with custom / original firmware
Thank:maximum117
ATTENTION!Before all manipulations, save all data and close running programs, since When installing the driver, the system displays a blue screen.
Config:
LGP500 CM7.1-N2 + ta-gb-1.3
Decision:
1. Connect the phone to the PC, the PC does not find the driver.
2. Go to the task manager, look for our device (will be with an exclamation point).
3. Right-click - update-driver-select the installation of the driver from the computer-select the driver from the already installed ones.
4. In the list we are looking for a USB controller; we select a universal one (it may come from small ones as well as others) -component usb device.
5. The system will install the driver, you can use the usb-flash drive function.

Shl. The most important point is 4. The main thing to find in the list is a driver of the type "composite usb device", on xp and 7-k points can be missed. If the system does not fall out of the blue screen (the appearance of a blue screen is very rare, for example, when installing the driver from the drive for usb hub =)).

If issuedblue screenwithout disconnecting the phone from the computer, poking on the reser on the system, the PC will reboot, after giving the choice of loading the operating system, selectSafe mode. The system will boot into safe mode, then start-up control panel-dispatcher device-look for our phone (in my case, the phone had a name like .... LG USB ...), right-click to remove the driver. Reboot.

It is also possible to force the booting into safe mode during the next reboot before all manipulations (in win7 we launch start-in search, enter msconfig - the load tab - put a tick in the Safe mode - click on OK - the system will ask Restart or Logout without rebooting - select Exit without reboot).

ZZY. The method works on 7-ke exactly - checked on the stationary and on the beech (win7x32).
(!!!) P.S. Do not forget that problems with connecting the device to a PC via USB can be caused by:
  • features installed on a specific device, custom firmware;
  • third-party software installed on the device and / or PC, a conflict between them, etc .;
  • The problem may be in the "hardware" (technical malfunction of the memory card, USB-port, wires, etc.).

In the presence of these circumstances, universal methods, indicated anywhere else, may not be of help to you.
Other useful


IMPORTANT!
If a forum member gave you good advice that helped you solve your problem, you should not put a message with the text"Thank! You are super!!!". On our forum, thanks are accepted to express byraising reputationspecific participantPicture.
If you can’t change your reputation yourself (did not score 15 posts), use the buttonPicture
and inform about the desire to change the reputation of the party.



For questions about filling caps, please contact the section moderators via the "Complaint" button under the messages to which you want to add links.

Post has been editedMaks.hackdog - 30.05.20, 16:50
Reason for editing: Solving the problem with MTP connection on Windows



Rep: (4)
It was the same way .... But then somehow, over time, everything fell into place. I just in the settings, it seems, changed the "Actions at connection" - I put "ask when you connect." And rolled ...



Rep: (0)
-Brief description of the problem: we need a usb host weekly roota
-Device / Model: htc wildfire s
-Operating system and firmware: android 2.3.3
- Actions were taken: no, you just need a host



Rep: (1965)
Konisransk, edro rebuild mastered? And consider, with a usb-tail, the battery burns in six seconds.



Rep: (0)
- After a three-file firmware through Odin on KH3 sewed and CSC, the computer refuses to see the phone, as indicated in the header is charging current. The computer sees the phone current in donload mode.
- Samsung Galaxy S II
- At the moment, back to 2.3.3 KE1
- Reinstalled kies, drivers, cleaned the registry, tried it on another computer, changed the firmware.

Post has been editedDeeMaN_uzer - 25.09.11, 10:50



Rep: (0)
-Brief description of the problem: when you connect via usb to the WB in drive mode, a removable disk icon appears on your computer, but when you try to open it, you are prompted to insert the disk into the drive.
- Device / Model: HTC HD2
-Operating system and firmware: BB Windows XP, build android BoxmaXMccM S3.5 v3.1 [MixTheme v3.5] [3dak] [Runnymede + Rhyme + 235 + Sense3.5] (SD / Magldr)
- Actions were taken: I honestly do not even know where to go)))



Rep: (1965)
RomantikDR,
Is the card in the computer itself readable?



Rep: (0)
Yes, it is read. from under Windows it turns on normally as a removable disk.



Rep: (29)
RomantikDR,
I'm pretty sure you know this, but still ...

After connecting the YUSB cable, you need to pull down the status bar, and in the rolled out curtain, poke into the YUSB connection point. After that, you will have an offer to mount the SD card, or something like that.

Post has been editedmax2327 - 14.01.12, 01:18
Reason for editing: + from wenday



Rep: (34)
-Brief description of the problem: When connecting a samsung galaxy sl9003 comp (vin hp sp3), the phone does not detect. Writing the device is not recognized. I had such a problem before. then he connected to the computer and, purely by chance, he identified my phone. I didn’t long after downloading the latest firmware and firmware. I’ve done it. Day 3 was all good as once, the phone was not detected again when I did.Somehow I have already begun to sin on the fact that I am doing manipulations so that the external card is defined as internal. Maybe this is a problem ??? What do you think the craftsmen?
-Device / Model: samsung galaxy sl 9003
-Operating system and firmware: 2.3.3 CRANIUM mod without any overclocking of cores and processes.
-Even taken action:
Format-not
digging in the settings, delivering all possible checkboxes (debugging usb, etc.) -not
p.snot -did not help)))



Rep: (2)
I was going to reflash the phone, but it turned out to be a problem, the computer does not recognize the phone, writes an unidentified device, tried on several computers, Kies stands, firewood stands, everything is fine in the settings too (with android sign for a long time) Contacts are wiped, ports changed. exclamation mark. The problem is frequent in the network queries, but there is no clear answer .... I would be very grateful for the help! firmware 2.2.1. kernel 2.632.9 root @ S608 # 2



Rep: (0)
A similar problem, like that of SIDJAY, the same phone, tried on three computers with different cords, formatting, resetting, etc. does not help :(



Rep: (1)
damn guys tell me who can according to the message above, pliz, zadalbal this emergency mod ... ((((



Rep: (234)
dkl89 I suggest that you first eliminate the Emergency mode message, since it has nothing to do with USB and, as you say, it appears after a reboot, and then we fix your USB connection.



Rep: (39)
Hello. Perhaps not quite on the topic, but also about USB.
We have: tel1- ZTE Libra CM 2.3.5, tel2- SE Xperia X1 WM 6.1, radio with USB input.

When you connect the phone 2 to the radio, it is defined as a USB flash drive and the melodies recorded on the phone card are normally played by the radio tape recorder.
When connecting tel.1, it is also defined as a flash drive, it can be determined from the screen of the radio tape recorder where the inscription Read lights up immediately, but this is not the case.
When you connect both bodies. To BB everything works fine without any differences between tel1 and tel2.
Is it possible to solve this problem, if yes tell me where to dig.



Rep: (0)
Hello everyone! They gave me a Galaxy S phone, without wires, without an installation disk. I went to the Samsung website and downloaded the Kies version for Mac (I have a Mac). Synchronization didn’t happen. right? And where can I get them? Nothing much was nuggulil. Was it really done for the PC only for PC?
The phone in Kies is visible, but in the process of connecting ...



Rep: (255)
When you try to connect the Xperia x10 phone to your computer, the blue screen of death crashes with the error 0x0000000A drivers all stand, only an unknown device appears in the device manager ... a phone flash. Tell me how to overcome it?



Rep: (34)
It may be that the blrk power of the company is weak ...
If you observed frequent reboots over the eomp, and so on, this is the diagnosis. Conclusion buy a new bloo food ... to me, too, when it was so ... I did so. It helped.



Rep: (234)
SIDJAY, if after wipe your computer still doesn’t see the phone, then it’s probably a matter of firmware. Try to put stock.



Rep: (34)
The stock was the same. Overcame a suit at the beginning of the rules was all. Then it began again ((



Rep: (14)
Hello to all.

Similar to my post in the topicThe computer does not see the phone connected via USB(post 27)
Not editable, gives an access error. I ask the moderator to delete the message.

So there is exactly the same problem.

Tablet Mireader 801. New, just sent.
No programs were put, all from the factory.

Android version 2.3.1
Gingerbread build number v 1.28

When connected to someone not found.
Windows HP writes:
One of the detected devices does not work correctly, and Windows cannot identify it ...

We go My computer - properties - equipment - device dipetcher
Section "universal serial bus controllers"
We see the new appeared "unknown device"

- Properties - details
Hardware code - USB \ UNKNOWN
The device code is USB \ VID_0000 & PID_0000 \ 5 & 18EA5B2 & 0 & 2

Drivers are not set.
The same connector on the tablet with the cord-host works. A flash drive is seen through it.
But not sure that everything is smooth here.
It seems that it is seen, but when you turn on in the status bar, there are no messages. Flashing only the music scanning icon and that's it.

There are no inscriptions for safely removing the flash.
But after the flash drive turned off the message pops up
@Removed USBMassStorage. Insert a new one.

I did not do a hard reset, I do not know how it will look like from the point of view of warranty.
Suddenly you have to send back a pill.


Full version    

Help     rules

Time is now: 12/07/20, 22:29