Questions beginner root user | You got root-rights, but do not know what to do next

Rep: (1964)
Attached Image

This topic is intended to discuss issues that arise among users,
who only got Root access and do not know what to do next.

It does not discuss the questions "how to get root".
Such questions will be deleted without warning!

In addition, we strongly recommend that you familiarize yourself with:
discussion topic of your device
FAQ on your device
Terms and jargon
Android OS FAQ

It is possible that the problem you have is directly related to a specific device model,
widely known and its solution has long been found.
Brief rules of conduct in this topic
1. It does not discuss:
1.1. Questions "how to get root". Such questions will be deleted without warning! (All instructions, as a rule, are contained in the branches on the firmware)
1.2. Configuring specific programs that require root rights (refer to the discussion thread of the corresponding program)
1.3. Questions resuscitation devices after: unsuccessful firmware, over-enthusiasm for removing system software, applying incorrect application settings, etc.

вњ” How to ask a question in this topic
When posting in this thread, please follow these rules:
1. Describe your question or problem calmly and in detail. Try to write correctly.
2. Be sure to include your device model and Android OS version.
3. Indicate what actions you took before you received (when resolving) the question (problem). What applications / programs were used.
4. If you want to add an image, please readHow to clean the image under the spoiler.

By following these simple rules, you will quickly get the answer that interests you.

What is root?
root (from the English root - root; reads the "root"), or caliper - This is a special account in UNIX-like systems with an identifier (UID, User IDentifier) ​​0, the owner of which has the right to perform all operations without exception.
A bit of theory
Multi-user Linux system capabilities are of fundamental importance: all user actions are possible only after the identification of the user with any of the records. Linux allows users to defined his rights to work with files and directories. It is believed that each file belongs to a particular user and a particular group of users. Each file is also associated rights table indicating which actions (read, write, program execution, opening the catalog and some others) can take the file's owner, a member of the group that owns the file, and an arbitrary user. In addition to records of ordinary users, there is also the root login account with a reserved name root. The super-user can perform any legal action on any file, regardless of who owns it and what is the right table of the file. In addition, the superuser can change the owner information of any file and its rules table. A root also has a much more extensive rights not associated with file operations.

Routing (English Rooting) - the process of obtaining superuser rights on devices running the Android operating system. The main objectives of the routing are the removal of restrictions of the manufacturer or carrier, the manipulation of system applications, and the ability to run applications that require administrative rights. A device that has undergone a rooting process is called rooted.

What is "access rights"?
Permissions - This file or directory attributes that indicate a server who can do what with the relevant file or directory. Typically, access rights govern actions such as read, write to a file (or directory), the performance. On UNIX systems, all users are divided into three groups: "user" (owner of the file directly), "group" (a member of the same group that owns the file owner) and "other" (everyone else). When you connect to a server, it determines which group you belong to. For example, connecting to the FTP server, you enter with your username, respectively, the server assigns you to the "user" group. Other users, connecting by FTP, be attributed to the "group" group, and when a person gets to your site through your browser, then falls into the "other" group.
After defining the group, the user gets the rights to actions with objects. Ie he can read, write or execute the file. To view a directory, it must be executable; to view its contents, it must have a read attribute, and to create a new file or directory in an existing directory, you must have write permission. Thus, in order to run an application or a CGI script, it is necessary to put a read and execute attribute on the directory.
To assign rights to the respective groups, numerical designations are used:
4 = read (read permission) 2 = write (write permission) 1 = execute (execute permission)
The first digit in the designation establishes the rights for the group "user" (ie, actually for you), the second for the group "group" and the third for "other". Simple addition of numbers can achieve the establishment of rights to a set of actions. For example, 3 (2 + 1) allows writing and executing a file (directory); 5 (4 + 1) allows reading and execution; 6 (4 + 2) allows reading and writing; 7 (4 + 2 + 1) establishes the right to read, write and execute. Ie only seven options:
7 = read, write & execute
6 = read & write
5 = read & execute
4 = read
3 = write & execute
2 = write
1 = execute
The most common permissions (rights):

644 (-rw-r - r--) Rights with the letter “G” - all system .apk and .jar files are under this permission (rights)
Example 644 rights in RootExplorer
Attached Image

755 (-rwxr-xr-x) Rights with the letter "P" - all system directories (folders) are under this permission (rights)
Example 755 rights in RootExplorer
Attached Image

More about access rights
How to get root on my device?
With a high probability, the answer to this question is contained in Android - Firmware
If the forum does not publish a proven way to get root-rights to your machine, or such methods for some reason do not work for you, then you can try universal methods at your own risk:

Getting ROOT on device
Getting root in one click

If you have questions on these methods, or something will not work with them, then ask questions in the topics about a specific method.
In this topic, a discussion of how to get rootPROHIBITED!

Tried to get root, everything broke!
Again, go to sectionAndroid - Firmware
How to verify that root rights are obtained?
1. It is possible (but not necessary) to appear in the program list of an application called Superuser or SuperSU
Attached Image
Attached Image

2. When you run programs that require root privileges, the corresponding request will pop up.
Attached Image

3. Programs that previously did not work, citing lack of rights, are now fully functional.
Attached Image

4. In the terminal emulator, when you enter the su command, a prompt appears in the form of a grid: #
Attached Image

5. In the terminal emulator type "/ system / bin / id" [Enter]. If we see in response - "uid = 0 (root) gid = 0 (root) "then rejoice, phone rutovan -depends on the way of gettingroot rights (for example, when using Universal Androot this method of verification is unacceptable)
Read more
Since the initial way to get root on most phones was through a terminal session, launched by the command "adb shell", the most correct way, in my opinion, is this:
a) Make sure that USB debugging is enabled: "Configuring the Application Developing USB Debugging";
b) connect the phone to the BB and execute the "adb shell" [Enter] on the command line;
c) if the system prompt looks like "#", then skip paragraph "d" and go to paragraph "d";
d) if the system prompt looks like "$", then on the command line type "su" [Enter]. After that, the system prompt should change to "#". Not changed - try "/ system / bin / su", "/ system / sbin / su" or "/ system / xbin / su". If you still see - "$", then you most likely do not have root-rights;
e) type in the command line "/ system / bin / id" [Enter]. If we see in response - "uid = 0 (root) gid = 0 (root)", then we are happy - the phone is rooted.

A similar test can be done through a terminal emulation program, which must be run (after setting if it does not exist) in the phone. Running, begin to act with n. "In." The essential difference is that in Step. "G" may be prompted to privilege escalation. Or it may not appear. If there was - answer "Allow". The invitation should be replaced with "#". If the request does not appear, then there are two possibilities: either the program "Superuser" is already installed or not. If you see the response "permission denied" system (permission denied), then the "Superuser" is not installed. Install it. If it is not set (or set, but is not functioning properly) - root phone is offline. A curtain.

If the program "Superuser" has already been established earlier, then there are also two options: terminal emulator allowed to run as root or vice versa is prohibited. If allowed, we should immediately see a welcome symbol "#". If smoking - launching a "Superuser" and remove the ban by removing the record of our terminal. We go back to the terminal and repeat the "su" [Enter], waiting for a request for privilege escalation, resolution increase, see "#". With trembling hands, type in the terminal "id" [Enter]. We analyze it.

In which case it is impossible to get full-featured root rights?
Some phones haveNAND lock , which does not allow anything to be written / deleted in / from the / system partition, even if it is remounted for recording, and this results in the impossibility of either installing the Superuser program in / system or deleting system applications. It turns out the case of incomplete rooting - so-called. Shell root . You can find out if your NAND lock device is available in the discussion section of your model. Android - Devices
How to replace KingRoot / User with SuperSU?
Root rights are obtained, but files are not copied to the / system folder. Why?
You need to mount this folder folder for writing. This operation can be done by various programs.
Here's how to do it by example.Root explorer:
- in the upper right corner (of course, with root-rights acquired) there is a button for switching between read / write modes (r / o - r / w).
This is how it might look
Attached Image

How to remove applications embedded in the firmware?
To remove software wired into the phone, you can use the following programs:

Root manager- it has a System Apps section, in which, in turn, there are three items: App Remover - the actual removal of applications, Data Remover - removal of data associated with programs, and App Backup / Restore - backup and recovery of applications. According to reviews, the backup works quite crookedly, so it is recommended to use third-party software such asTitanium backup
NB: to completely remove the program, you need to delete the program.apk and program.odex files

В® SystemApp Remover- also a program designed to remove system applications. According to reviews in the program branch, almost no one works, so here it is presented more like an example.

Also the program itselfTitanium backupcan be used to remove programs. When you tap on the line with the name of the application to be deleted, a window will appear prompting you to create / restore a backup copy, delete the copy, delete the data and the application itself. All system applications are highlighted in red.

Keep in mind that Google services (programs whose names include google), regular contacts, messages, launcher in any case it is not recommended to delete and move to the card in order to avoid loss of nerve cells and the appearance of gray hair when turning the animal!

Remember! Before you remove something, MANDATORY!MANDATORY! MANDATORY! make a backup!
How to hide root for certain applications?
You have received a root, and such an important application for you does not work / gives errors / crashes / swears on root-rights? There is an exit!
Xposedand moduleRootcloak
Attention! This is only a solution, and not the fact that it will work with your application. Details of the use or an easier way to solve the root problem is to be found in the topic. specific applications.
How to remove root rights so that no traces are left?
It is enough to flash any OFFICIAL firmware.
How to flash your device look inAndroid - Firmware
What applications from the firmware can be safely removed?
The most complete information is collected here:Android stock program. We remember that it is not recommended to touch the stock launcher, dialer, messages.
Often (but not always) a list of applications that can be deleted is in the firmware thread of a specific deviceAndroid - Firmware
Those who want to get rid of additional Google applications can try this manual:The leak of Internet traffic in Android (Post # 9762760).
Removed system applications, but no space was added in the system partition! Why?
on Linux systems, there is such a thing as mount points (similar to partitions in Windows). The main points are: root (root, not to be confused with the root user) or /, / data, / system, / sdcard. The system software is all in / system, respectively, it is at this mount point that the space is freed up. Roughly speaking, it is foolish to delete files on section D: and wait for space on section C to be added:
In order to free up space on the system partition, you need to transfer the necessary installed applications from / data / app to / system / app (and, of course, assign them the same rights as the neighboring files -rw-r - r-- ) - in this case, the applications will become systemic and will not be lost when the phone is reset to the factory settings, and the free space on the system partition will increase. For example, you can transfer the launcher in this way if you installed a different one from the one that came with the firmware. Note that in addition to application files with the * .apk extension, you also need to transfer * .odex files with the same name, if such are present.
A detailed description of the sections of the Android memory available language.
Is it possible to update the routine device "over the air" or with the help of official software like Kies?
Doing this is strongly discouraged. Opening root privileges involves interfering with system files, and the OTA update of official firmware can lead to unpredictable consequences. The most innocuous is the loss of root privileges, but more fatal variants are possible - up to scaling. In particularly advanced cases, you can bring your phone back to life only through JTAG.
This item does not apply to OTA-updates of custom firmware (for example, CyanogenMod), in which there are own utilities for updating by air.You can find out if an OTA update is supported by a specific custom firmware in the discussion thread.

A set of tools for a novice root user. Useful and necessary applications.
Discussion of the work of specific programs in this topic is not supposed !!!
Any questions about a specific program should be asked in the topic about the program.

В®UMS Enabler (Universal)- Application for connecting Mass Storage Mode to install a memory card as a USB drive (verified by the Curator)
В®suhide- The suhide utility allows you to hide the presence of "ROOT" on your Android device.
SuperSU- Advanced access control for superuser rights to applications on the device that need root.
Root explorer- File manager for Root users. Most of the instructions are written based on the use of this file manager.
Titanium backup- Backup of applications and user data (sms / mms / contacts). It is often found in all sorts of instructions.
LuckyPatcher-Patcher to most programs and games.
Xposed-Program to change the settings of applications and firmware without the need for their decompilation, compilation and signature.
Link2SD-Allows you to transfer installed applications to a memory card in the absence of such an option in the firmware.
Foldermount-Mounting directories c internal memory to external. Serves to transfer the game cache (usually) to an SD card.
Android Terminal EmulatorTerminal emulator There is nothing to add.
DroidWall- The program allows unlimited access of applications to the Internet via WiFi and restricts access via GPRS / EDGE / 3G
NextApp SDFix- Troubleshooting the write to an external SD card in Android 4.4+
AdAway- Ad blocker with support for white and black lists.
SU File Manager & Terminal- File manager and terminal for Root users
SetCPU- A program to control the frequency of the processor(all responsibility for use lies with you!)
Autostarts- Shows which programs run automatically after loading, as well as other system events occurring in the background
Cachemate- Clearing data cache from applications
Root manager- Toolkit for Root user
Shootme- Taking screenshots by shaking (incatalogthere are analogues)
Wi-Fi Tether- Device as an access point (incatalogthere are analogues)
Adfree android- Removes ads in the browser and other applications.
AROMA Filemanager- File manager with access to system files from custom Recovery.
Nandroid manager- The program allows you to view, explore and edit your Nandroid backups.

This is not a complete list of programs that work with root-rights. All these programs (and not only them) are inThe catalog of programs for Android OS.If you have not found any program in this list or Catalog, then the questions "Prompt a program that ..." are set in the subject:SEARCH software for Android OS.
Attention!If you know a useful program that is not listed, refer toCurator.

For the creation and initial development of this topic, special thanks to the distinguishedW.Master

If a forum member gave you good advice that helped you solve your problem,
do not put a message with the text"Thank! You are super!!!"
In our forumthanksIt is accepted to express by raising the reputation of a particular participant by clicking on the button
If you do not have 15 posts, ask the moderator to raise the reputation of the person who helped you through the button Picture.

Theme needsCurator. Those who wish, please readRequirements for candidates to the curators of the forum. If the desire is not lost, the application can be left in the topic -I want to be curator .

Post has been editedKEEPERekb - 25.03.19, 19:32
Reason for editing: edit

Rep: (3)
How do I know that I got root? did everything on the FAQ
Attached Image

put root (superuser icon appeared)
Attached Image

then I installed a "better terminal emulator" on my phone, I write su in it and he answers permission denied why so?

Post has been editedBespectacled - 17.05.13, 21:04

Rep: (285)
astrocuba Most likely, your firmware does not support adb remount. As far as I know, only users (modified firmware) support remount. At least that's how things are with acer.

Rep: (3)
Max.g @ 11/16/2010 04:16 AM*
Quote ([email protected], 22:05) *
I write su in it and he answers denial denied why so?

and you gave this application superuser rights?

But how to do it?
Astrocuba, Most likely, your firmware does not support adb remount. As far as I know, only users (modified firmware) support remount. At least that's how things are with acer.

The firmware of my device is really standard. Do you think this is the case?

Rep: (1964)
But how to do it?

we start Superuser Permissions and we drive the rights

Rep: (234)
Do you think this is the case?
It's not about the firmware, because standard firmware "rutted" without problems, but that you, relying on applications like "Ruth in 1 click" immediately rushed to get root. Read not only the FAQ on this topic, but also capture the adjacent ones in order to understand the essence of the process. Analyze the system messages that are issued to you in the process.

Rep: (3)
I only have the "#" icon underneath it says -Superuser Whitelist, the grid icon is among all applications.

Post has been editedastrocuba - 16.11.10, 11:49

Rep: (285)
astrocuba if not, put a root explorer, give it root-rights. In it, mount the desired folder for writing, and try to execute all commands without remount.
Bodtak Just the stock firmware does not support adb remount. I myself faced this a week ago. A mount folder for recording in the program and further push commands should work.

Post has been editedBulwak - 16.11.10, 11:51

Rep: (234)
Bulwak @ 11/16/2010 11:48*
Bodtak, just the stock firmware does not support adb remount. I myself faced this a week ago. A mount folder for recording in the program and further push commands should work.
As far as I understand, "adb remount" does not depend on the firmware, but depends on the adb.exe program, otherwise it would be:
a) this command would not be in the list of commands supported by this program;
b) what was the point of implementing it (remount command), if the phone is sold with native firmware?
Remount will only work if adb has the ability to start a session with root rights, otherwise there will be the same “permission denied” and it seems to me that it does not depend on the firmware.
Bulwak @ 11/16/2010 11:48*
A mount folder for recording in the program and further push commands should work.
I agree, but with the condition of prior obtaining root rights and remounting the / system folder for writing.

Post has been editedBodtek - 16.11.10, 12:11

Rep: (3884)
Astrocuba @ 11/15/2010, 11:05 PM*
put root (superuser icon appeared)
then I installed a "better terminal emulator" on my phone, I write su in it and he answers permission denied why so?
Eh ...
It’s like a car:
- got a driver's license, but you can not go? BUY a car !!!
- bought a car, but you can not go? Turn the ignition key !!!

With root rights the same way (greatly exaggerating):
- got root-rights (saw the icon) ->turn them on (did you try to press the icon or just looked at it?) ->put the necessary tools (programs) ->if necessary, configure the program data ->and only then use.

In each case, there may be nuances in the setting, switching, etc., everything on the go and not universally described, but the principle is always the same: - "buy a car, fill up the gasoline, turn the ignition key", without all this, on some root - right far away.

Rep: (3)
W.Master @ 11/16/2010, 16:33*
(tried to press the icon or just looked at it?) ->put the necessary tools (programs)

The icon clicked writes: - The whitelist is currently empty.
Put Better terminal and Root manager (standard applications are not deleted through the root manager either)

Rep: (285)
Bodtak that's the way it is, but how to explain what I have at the last office. 2.2 adb remount leak did not work (although the device was with root and all applications requiring root-rights worked fine), and after flashing to t & l mod everything works? ;) Otherwise, how not to explain with the firmware :)
astrocuba in theory, when launching the same root of the explorer, a window should pop up asking for permission / prohibition of the application receiving root-rights. If there is no window, then, most likely, and you do not have a root.

Post has been editedBulwak - 16.11.10, 13:27

Rep: (234)
that's the way it is, but how to explain what I have at the last office. 2.2 adb remount not working
And what was the message when trying to perform "adb remount"?

Rep: (285)
Bodtak the same - operation not permitted. But when I mounted / system for manual recording, push worked as expected.

Post has been editedBulwak - 16.11.10, 13:32

Rep: (3884)
The icon clicked writes: - The whitelist is currently empty.
Well, here it is necessary to understand how to fill this “white sheet”.
The easiest way (and more logical) is to go to the topic, according to which you get your root-rights and figure out how to make it all work.

P.S. Eh ...time, apparently, we open the topic "Questions novice root-user" , because by itself, the use of root-rights implies that, as it were, the user is no longer new to Android, he has decided that he has enough knowledge to move in a way that is always done "at his own peril and risk." Type: - graduated from primary school, but with the program of "junior high school" problems.

Post has been editedW.Master - 16.11.10, 13:34

Rep: (3)
Yes, the topic is how current and no I did as it is written in the FAQLG GT540 - FAQ
Can someone tell someone how to fill out a white sheet? As I understood in this sheet, applications that have root access must be entered.

Rep: (285)
astrocuba I do not know about you, but everything is just elementary for me - an application that requires a root is launched, a window appears to choose to deny / allow. And it is worth tick "always allow." Ask in the thread with the firmware for your device. As I understand it, this way of getting root-rights is valid only for LG. So, only optimus owners can help you with this :)
/ part of the message has been deleted due to transfer to another topic /

Post has been editedW.Master - 16.11.10, 18:30
Reason for editing: part of the message has been deleted.

Rep: (234)
the same - operation not permitted.
and when started adb shell - what was the system prompt "#" or "$"?

Post has been editedBodtek - 16.11.10, 14:53

Rep: (285)
oboroten1968 @ 11/16/2010, 17:23*
and when started adb shell - what was the system prompt "#" or "$"?

# It was. Well, this seems to mean that the root has been received, right?

Rep: (234)
Bulwak, exactly.

Rep: (3)
+ Got root privileges using this application (see carefullyNOT all modelssupported) no problemsUniversal_Androot.apk- there is a forum.
+ Using this appRoot_Manager.apkdeleted the standard Odnoklassniki application, in this program you can also perform many other operations with root rights. - Also there is a forum.
How to find out that root rights are obtained:
1 . Among all the applications, a black and gray icon will appear showing "android pirate" :) and signed with "Superuser Rights".
2 . When you start an application that works according to root rights (eg. Root_Manager), a window will appear on it that says "Request for Superuser".

o4kareg @ 11/16/2010, 10:49 PM*
I propose to add to the header:
Signs that root access is activated:
1. In the list of programs appeared application Superuser Permissions
2. When launching programs that require root (for example, DroidWall), a window appears asking for root privileges
3. Programs that previously did not work, citing lack of rights, are now fully functional.
4. In the terminal emulator, when you enter the su command, a prompt appears in the form of a grid: #

also, in order to avoid questions "give!" I propose to put in the header links to recipes for getting root, with the obligatory large and red warning, so that questions on these methods are asked in the appropriate branches, or PO for 3 days.

This is if you get rights through the "hard way" which is described in the FAQ for LG GT540.
It's easier, but not for all models to get root permissions "in one response" :)

Post has been editedastrocuba - 16.11.10, 22:03

Full version    

Help     rules

Time is now: 11/03/20 03:00