X96Max (S905X2) [Android] | [Media console]
New poll. !!!
HDMI Worker or Burned Out.
I have a worker. [ 1664 ] ** [90,78%]
Burned out For no reason. [ 111 ] ** [6,06%]
Plugged in hot. [ 54 ] ** [2,95%]
What firmware is right for me.
Stock. [ 1333 ] ** [72,72%]
Beelink. [ 181 ] ** [9,87%]
Android ATV. [ 309 ] ** [16,86%]
Boxing version.
Version 2/16. [ 214 ] ** [11,67%]
Version 4/32. [ 847 ] ** [46,21%]
Version 4/64. [ 772 ] ** [42,12%]
Do I like Boxing.
Like. [ 1383 ] ** [75,45%]
I do not like [ 78 ] ** [4,26%]
So-so. [ 370 ] ** [20,19%]
Total votes: 1833
 



Rep: (3)
DiscussionX96Max (S905X2)
Tv box
Discussion | Marriage and Repair | Folk "firmware for Android TV consoles X96 Max
Specifications
CPU - Amlogic S905X2 quad-core Cortex A53 processor up to 2 GHz
GPU - ARM Dvalin MP2 GPU
Memory - LPDDR4: / 4 GB LPDDR3: / 2 GB
Flash - EMMC: 16 GB No BT4.0 2 / 16g, 2.4 GHz WiFi RJ45 ethernet 10/100 port
Flash - EMMC: / 32 GB / 64 GB 4 / 32g and 4 / 64g Wi-Fi 2.4 and 5 GHz + BT4.0 RJ45 ethernet port 10/100/1000
Wi-Fi - IEEE 802.11 b / g / n / ac, 2.4g Wifi or 2.4 g and 5.8 GHz Wi-Fi
Bluetooth - BT 4.x + HS; Voice console support
I / o
1 * HD - HD 2.1, support HD CEC, dynamic HDR and HDCP 2.2, 4 K x 2 K 75 Maximum resolution output.
1 * AV - 480i / 576i standard definition
2 * USB - 1x USB 3.0, 1x USB 2.0
1 * IR - Remote connection receiver
1 * RJ45 - Ethernet interface, support 10/100/1000 m
1 * TF card - Support 4 GB / 8 GB / 16 GB / 32 GB / 64 GB
Power - DC 5 V / 2A; LED indicator, Work: blue; Standby: red
OS - Android 8.1
Video
* Amlogic video engine (AVE) with dedicated hardware decoders and encoders
* Support multi-video decoder up to 4K x 2K 60fps + 1x1080 P 60fps
* Supports multiple “secured” video decryption sessions and simultaneous decoding and encoding
* Video / picture decoding
-VP9 profile-2 to 4 K x 2 K 60fps
-H.265 HEVC MP-10 L5.1 to 4 K x 2 K 60fps
-AVS2-P2 profile up to 4 K x 2 K 60fps
-H.264 AVC hp L5.1 to 4 K x 2 K 30fps
-H.264 MVC up to 1080p 60fps
-MPEG-4 ASP L5 up to 1080p 60fps (ISO-14496)
-WMV / VC-1 SP / MP / AP up to 1080p 60fps
-AVS-P16 (AVS +) / AVS-P2 JiZhun profile up to 1080 P 60fps
-MPEG-2 MP / HL up to 1080 P 60fps (ISO-13818)
-MPEG-1 MP / HL up to 1080 P 60fps (ISO-11172)
-RealVideo 8/9/10 to 1080 P 60fps
A photo
Attached Image
Attached Image
Attached Image
Attached Image
Attached Image


Firmware
A selection of firmware (received from the seller)
https: //droidboxforums…-firmware-links.14717/
Message No. 2094, author A.S._id Archive of firmware For Box X96 MAX.
Mail.ru cloud
Google drive
Beelink GT1 MINI total firmware for the whole series 2/32 4/32 4/64
Perezalita on poison. "Mirrored" .img + ota-11/30/18
2019.02.23. For stock firmware version boxes 2/16 and 3-4 / 32-64
Firmware for 2g ram.
Firmware for 3-4g ram.

Build. Custom firmware.
Useful.
Scattering
Firmware instructions.
Recovery.

Afrd - This is Automatic Framerate Daemon
SuperSU for AndroidTV boxes
List of software problems with the X96 Max console and their solution
The most reliable way to check Root rights.
Instructions for setting up a regular remote.
Smart YouTube TV
Setting up a physical keyboard.
ADB through the local network.
Run the Auto Frame Rate in SPMC using a script.
The perfect bundle of SPMC + Amlogic + AFR, for film fans
Setting the Power button on the Vontar G10 remote
For Beelink firmware for remote control.
Post number 1822, by anpaza "Direct audio output 2.0-5.1 from Cody"
KODI MIRRORS All versions 15.0-18.0 + Repo all assemblies.
Alternative Core for X96 Max
The Reset button does not work after flashing a problem on Beelink.
Connect our box via AV connectors.
The method of flashing with SD card on the principle is the same as through the cord.
Launcher Bilink (Lighthome) in Russian
Made a small mod launcher Lighthome 1.1.4
INSTRUCTIONS FOR DISPLAYING STARTED APPLICATIONS AND THEIR DELETION ON STOCK
Another instruction Recently launched applications on X96 Max
A small patch, for STOCK firmware, as a double tap, call the "Recent" menu
Multi-window mode.
Mbox Launcher v2
X-Plore Transfer files from one device to another.
Instructions for optimal operation of the PRA on the S905X2
No Ads on YouTube.

To help the user of choice.


Post has been editedVasily_5 - 30.08.19, 18:13
Reason for editing: A selection of firmware (received from the seller)



Rep: (5)
* jan58, and maybe it’s the case in the sd card, I’m launching it on a flash drive, I’ll say for sure that the first versions (as I understand it a week ago just done somewhere) on sd cards do not work, only a flash drive, I don’t know the latest versions, they update something every day



Rep: (246)
* lolas34 Can I link to the working version? As I understand it, you just need a quick flash drive?



Rep: (9)
I have a version from 07.22 from a flash drive did not want to start, today I downloaded the latest from 07.24 and tried to put on microSD. Now works fine.

Posted on 07/25/2019, 21:49:

* Roccuyanun,
https: //relkai.coreele... 0190724-Generic.img.gz



Rep: (5)
* Roccuyanun, I have on a flash drive (not an sd card) this version of CoreELEC-Amlogic-ng.arm-9.1-nightly_20190722-Generic.img.gz, it’s located in button (Nightly) should be somewhere in the archive already, I don’t know what CoreELEC-Amlogic- means ng .arm-9.1-nightly (eat without ng ) In this version everything works both wifi and bluetooth, the video rotates 4k HDR perfectly (everything else worked in the previous ones), but I don’t know about sd cards, I’m sure that the release will be released soon (not a nightly build, I just don’t know what else can I fix and add, and so everything is super)

Post has been editedlolas34 - 25.07.19, 22:00



Rep: (0)
Izum4ik @ 07.25.19, 20:37*
A toothpick is not necessary, from the market you put the terminal emulator and in it the reboot update command

And so it happened, thanks! It’s strange that it didn’t start through a toothpick ...



Rep: (9)
Manual (taken from herehttps: //discourse.core...o-install-coreelec/677) to create a flash drive / microSD with CoreElec:
1. Download the last nightie withhttps://relkai.coreelec.orgthe name must contain ng and Generic.
2. Unpack the archive and create a bootable USB flash drive using Rufus, take it herehttps://rufus.ie
3. After successful completion, go to the created flash drive by any file manager and copy the file containing the name S905X2_4g_1gbit to the root of the flash drive from the device_trees folder
4. Rename it to dtb.img
5. We insert the USB flash drive into the box and here as you like more, either we reboot with the inserted toothpick, or from the market we put any terminal emulator and in it we give the reboot update command
6. If the download does not occur, then try the same thing on another flash drive.
P.S. I ask you not to kick much, I write the manual for the first time)

Post has been editedIzum4ik - 25.07.19, 22:40



Rep: (160)
* Izum4ik,
Well, the manual is the same as theirshttps: //discourse.core...o-install-coreelec/677



Rep: (5)
* Izum4ik, have you figured out about the clock and the remote?
About the watch:Itself did not check yet, once , throw the x96-max-vfd.conf file into /storage/.config and rename it to vfd.conf
Attached filex96-max-vfd.rar(727 bytes)



Rep: (9)
* myboris2005
The same, unfortunately, not everyone is friends with English.



Rep: (204)
Roccuyanun @ 07.25.19, 9:40 p.m.*
Yes, even a memory car

I'm happy for you. Yes, the korelek does not allow you to go far from the code, if not red-eyed. But with a sharpened crust, amlodzheg becomes a shield. And if you are not in the topic, then you don’t need to ... and in the case of x96mah - the HD pastern appears and the box becomes a full-fledged media box, and not a surfing tablet ...



Rep: (204)
Lolas34 @ 07.25.19, 9:30 p.m.*
In general, amcodec is still a great option for our console

Well, the fact is that amlodzhik corrected h264 in 9k or something like that and the media codec became excellent. So right here is the difference between amcodecs in korelles or media codecs in 9ke is not special. And it’s hard for Amco codec to turn h264 4k a hundred mb / s - the code drops. What does not happen in the media codec at 9k. But these are all worms, the HD is driving! :)

Post has been editedkigba - 25.07.19, 22:52



Rep: (5)
* kigba but here the flow start speed, for example, at 9ke (on the media codec) and the launch speed in coreelec (amcodec) is very different, in favor of the second, while in coreelec (amcodec) there are no friezes at startup (the picture goes perfectly when zapx, without initial twitches ), channel switching is generally gorgeous, it's more comfortable flipping channels (switching alternately) again comfortable, though I’m already unaccustomed to it. This is not a contradiction to your words above, I'm just glad that coreelec appeared, a really cool thing!

Moreover, there is a difference in the blurring of the picture, it was on 9ke (on the media codec) that a small soap appeared (on 8 there wasn’t), in coreelec (amcodec) the image is clearer

Now I’m thinking about buying an expensive sd card (fast), it’s a pity that they sell at least 16GB now, I'm talking about Samsung evo, for coreelec and 4GB it would be enough, but 8GB is for the eyes, or I don’t understand something and coreelec only works after loading in RAM?

Post has been editedlolas34 - 25.07.19, 23:28



Rep: (9)
* lolas34,
I tried to throw a config, the clock on the console worked, there is no native remote control.



Rep: (5)
* Izum4ik, I’m not sure, but the point is that there is no line in the native console:

factory_code = 0x10000001 (this is an example of a working config for libreelec, not for our console)

Post has been editedlolas34 - 25.07.19, 23:32



Rep: (38)
thinking about buying an expensive sd card (fast)

On this console, reading a memory card is several times slower than flash drives. A usb3 card reader can be used or a flash drive is fast.



Rep: (9)
Who does not want to bother with SSH connection, throw the conf file for hours on samba to the Configfiles folder
Attached Image


Post has been editedIzum4ik - 26.07.19, 00:00



Rep: (7)
Hello. All the same, I would like to deal with the keyboard, put the Russian keyboard, in principle everything works, switches from Russian to English. I chose the Ukrainian language in the settings, but I have to type the letters i є ї with the mouse.



Rep: (0)
1

Post has been editedbrazota - 26.07.19, 11:57
Reason for editing: Error



Rep: (51)
I tried coreelec. I did not earn hdmi cec, a clock and a native remote. Installed a usb flash drive 2.0. I realized that you need a quick flash drive version 3.0 because when scrolling through movies to the elementum or movie trend, posters do not have time to load. In a simple system, it consumes 320mb of memory, if the temperature sensor displays correctly then it is 53 degrees, three cores in idle sleep, one lightly loaded. By default, the frame rate is 59.94. The autofreight works perfectly, the smoothness of 4k videos on YouTube is higher than in the same kodi on android, there are no frames and drops, turned on debugging and looked at statistics. The image is also juicy and clear, although it is excellent on android. Amcodek works in the system, it turns everything with a bang. Deinterlacing works as it should. Forward multichannel sound also works. Torrents online turns the same without problems. If in the future the system can be put on internal memory, then there will generally be fire. Here are brief observations.

Post has been editedmaximelson - 26.07.19, 12:24



Rep: (8)
After this firmware, it buzzed! Buratino Karlovich, this firmware is suitable for our console ......... Generic.img.gz (for S905X2 and others), after installing it on a USB flash drive, the file will contain S905X2_4g_1gbit in the folder, we will drop it into the root and rename it to dtb.img, after that the bootable USB flash drive is ready (we reboot the prefix with a toothpick) and it’s ready (it’s worth clarifying to you!, the latest version works on sd cards, before that it worked only from a flash drive, I stuck it in USB3)
Closing contacts, nothing happens. Is everything in the trash?


Full version    

Help     rules

Now: 09/07/19, 01:36