> Attention!

We strongly recommend to readRules section "Android - firmware"

New threads need to be created only inroot partition! In the future, they will be processed by moderators.



Xiaomi Redmi Note 5 Global / Note 5 China - MIUI Firmware



Rep: (2422)
Xiaomi Redmi Note 5 Global / Note 5 China - MIUI Firmware
Attached ImageHMN5P, Xiaomi Redmi Note 5 Pro / Note 5 China,whyred
Description | Discussion » | Purchase » | Accessories » | Marriage and Repair » | Xiaomi club » | Camera talk » | Mi Account » | Power consumption and autonomy » | Modification and decorations » | FAQ of general instructions and recommendations for Xiaomi devices | Perezalete » | Bootloader unlocking » | Custom Kernels » | Unofficial firmware » | MIUI firmware »

F.A.Q.

Administration Decisionsavagemessiahzine.comon banning posting and discussing Miuipro content
Important information!
In connection with the innovation Xiaomi, namely the introduction of the system "Anti Roll Back" (Antiotkat), cases of flashing bricks have become frequent.



Drivers and Utilities
Mi software
Xiaomi firmware updater
Mi Flash
savagemessiahzine.com | AFH| (Mi Flash) Russian - Bullik01 | 2018.05.28.0
MIUI | AFH | (Mi Flash) MIUI ROM Flashing Tool | 2018.05.28.0
MIUI | AFH | (Mi Flash) MIUI ROM Flashing Tool | 2017.04.25.0
MIUI | AFH | (Mi Flash) MIUI ROM Flashing Tool | 2016.08.30.0
MIUI | AFH | (Mi Flash) MIUI ROM Flashing Tool | 2016.04.01.0
MIUI | AFH | (Mi Flash) MIUI ROM Flashing Tool | 2015.10.28.0

MiFlashPro
savagemessiahzine.com | AFH | MiFlashPro | 3.3.703.67 - Flashing Xiaomi smartphone from recovery mode, without unlocking Bootloader

Mi Unlock
MIUI | AFH | Mi Unlock | 3.3.827.31
MIUI | AFH | Mi Unlock | 2.2.406.5
ADB / Fastboot and others
savagemessiahzine.com | ADB Driver Lite | 32/64-bit
savagemessiahzine.com | QDLoader HS-USB Driver | 32/64-bit
savagemessiahzine.com | Platform-tools (adb / fastboot) | r.25.0.4 | Windows
savagemessiahzine.com | Platform-tools (adb / fastboot) | r.23.1_. | Windows - XP support
savagemessiahzine.com | Platform-tools (adb / fastboot) | r.25.0.4 | Linux
savagemessiahzine.com | Platform-tools (adb / fastboot) | r.25.0.4 | macOS
AFH | Minimal ADB and Fastboot | 1.4.2 | Setup
AFH | Minimal ADB and Fastboot | 1.4.1 | Portable
Google | Dropbox | 15 seconds ADB Installer | 1.4.3

Xiaomi Check & Flash
savagemessiahzine.com | Xiaomi Check & Flash | 0.2
savagemessiahzine.com | TOOL ALL IN ONE - Drivers | Unlock | TWRP | Factory Image | Stock Recovery

Hashtabfile checksum utility
USBDeviewa list of all USB-devices with the possibility of their removal from the system

Firmware
Instructions
Installing firmware, Upgrade
Installing TWRP, getting Root

Scattering
Sensor Recovery, EFS

Loader
Anti-rollback

Recovery
Modems, Images, System Files
miscellanea
Uninstall / Disable Xiaomi / Google Services / Applications
Google FRP Workarounds
Poll results
5.03.2019
Attached Image
Attached Image
Attached Image
Attached Image







For filling caps, please contact gyord at QMS

Post has been editedgyord - 15.01.20, 12:36
Reason for editing: Eclipse



Rep: (114)
It did not seem to
Redmi Note 5 Pro / Redmi Note 5 8.7.12 fastboot
fastboot 8.7.12

Post has been editedeserguei - 13.07.18, 09:26



Rep: (5198)
TOOLKIT TWRP
by fendyperdana
Attached Image

Decompress in a convenient place ->run "KLIK 2X TOOLKIT INI.bat"
translate laziness - if someone will translate - perezalil!
Download: Attached fileTOOLKIT_TWRP_REDMI + NOTE + 5 + WHYRED.rar (108.61 MB)



Rep: (341)
Whyred unbrick
(Precast post)

Part 1: Introduction
A quick write, there will be many edits.
Before you read any further, I highly recommend to get acquainted withby thismessage. You do not need to understand everything at once. Just flip through.
As shown by today (conversation in the QMS) and past debriefing, users generally do not read anything, but quickly get down to business. Matter and problems.
Part 2. Antirollbek
The Xiaomi this took a long time and here's the first result: all through the income statement *.
At the same Samsung, in firmware version, bootloader version available. Where is she here? The question is rhetorical.

Antirollbek - a mechanism prohibiting downgrade software. On platforms Qualcomm implementation of this mechanism it is possible (and recommended) through the processor QFPROM.
Part 3: Firmware Version
Pro chain downloaders
If you extract any file with the firmware for your device, you will see the following files in it: abl, cmnlib, cmnlib64, devcfg, hyp, keymaster, mdtpsecapp, pmic, rpm, tz, xbl.
All of them are boot loaders. This is the minimum set of components to run the platform. Exactly the same set of files you can see in the firmware of any other device on the same processor.

All feeders (in our case) are digitally signed Xiaomi.
All feeders are composed of three certificates. In one of the certificates listed bootloader version.

If XBL has the wrong version (or just does not work) platform will open the 9008 emergency.
If XBL works, but plugging in one of these downloaders, the platform will open the emergency 900E.
In all other cases, the device falls into the Fastboot or Recovery. But it provided that all the coders have done according to the rules.
Here literate will not talk about the firmware version, but a version of the firmware boot loaders. Qualcomm on their platforms (downloaders) a lot (see. Spoiler).
Watched a few firmware for your model (figure on the right - loader version chain), it turns out like this:
20180705 8.7.5 Global 2
20180712 8.7.12 China 3
yyyymmdd 8.7.12 Global 3
20180410 9.5.6.0 Global 2
20180629 9.5.17.0 Global 2

A full list can be found inthis message. Thank you say* Netv : yes2:

What you see in the modefastbooton command
fastboot getvar anti
This version downloaders 1. (Out of date, to be confirmed) Why are implemented so that question to the developers.
Part 4. About okirpichivanie
MSM_HW_ID: 0x000cc0e1
OEM_PK_HASH: 0xa7b8b82545a98eca23d6e9105fb464568d1b5828264903441bdef0cd57e3c370
SBL SW Version: 0x00000003
Here is one of the responses from the device with your phone model (bricks).
As you can see the SBL (XBL) third version. Version of XBL are registered in QFPROM when you downloaded the 8.7.12 and click the trigger.
After some time, you lower firmware version, which included a second version of XBL. At the start, the main processor in the loader (PBL) sees that the XBL version on a flash drive below that he is registered in QFPROM and opens emergency port for downloading the "right" firmware.

Hoses (programmers firehose) for your device, also have versions. It is believed that now Xiaomi proshesh not easy (in the EDL / 9008 mode), as it was earlier. After downloading the programmer (firehose), waiting for the last (or demands) from us some commands. Probably the password is not clear yet. Those. Now all on Qualcomm devices can (and will) to implement a specific authentication mechanism. For firmware devices require no additional files or special flasher. In some cases, access to the network may be required. Those. flasher will knock on the server ..
Part 5. About recovery
miflash log
[9:37:48 COM4]: file C: \ 123 \ images \ prog_emmc_firehose_Sdm660_ddr.elf transferred successfully
[9:37:50 COM4]: send nop command
[9:37:50 COM4]: send command:<? xml version = "1.0"?><data><nop verbose = "0" value = "ping" /></ data>
[9:37:50 COM4]: get response from target
[9:37:50 COM4]: dump:<? xml version = "1.0" encoding = "UTF-8"?>
<data>
<log value = "Binary build date: Jul December 2018 @ 1:02:39" />
</ data><? xml version = "1.0" encoding = "UTF-8"?>
<data>
<log value = "Chip serial num: 4294967295 (0xffffffff)" />
</ data><? xml version = "1.0" encoding = "UTF-8"?>
<data>
<log value = "Supported Functions: program configure sig nop firmwarewrite patch setbootablestoragedrive ufs emmc power benchmark readtorageinfo getsha256digest erase peek poke" />
</ data><? xml version = "1.0" encoding = "UTF-8"?>
<data>
<log value = "Binary build date: Jul December 2018 @ 1:02:39
"/>
</ data><? xml version = "1.0" encoding = "UTF-8"?>
<data>
<log value = "fh.attrs.Verbose is set to 0" />
</ data><? xml version = "1.0" encoding = "UTF-8"?>
<data>
<log value = "Chip serial num: 4294967295 (0xffffffff)" />
</ data><? xml version = "1.0" encoding = "UTF-8"?>
<data>
<log value = "Supported Functions: program configure sig nop firmwarewrite patch setbootablestoragedrive ufs emmc power benchmark readtorageinfo getsha256digest erase peek poke" />
</ data><? xml version = "1.0" encoding = "UTF-8"?>
<data>
<response value = "ACK" />
</ data>


[9:37:50 COM4]: send configure command
[9:37:50 COM4]: send command:<? xml version = "1.0"?><data><configure verbose = "0" AlwaysValidate = "0" ZlpAwareHost = "1" MaxPayloadSizeToTargetInBytes = "131072" MemoryName = "emmc" SkipStorageInit = "0" /></ data>
[9:37:50 COM4]: get response from target
[9:37:50 COM4]: dump:<? xml version = "1.0" encoding = "UTF-8"?>
<data>
<log value = "ERROR: Only nop and sig tag can be recevied before authentication." />
</ data>
After downloading the programmer (firehose) miflesh (MiFlash2018-5-28-0) Sends command nop
send nop command

Programmer it shows all the available commands
"Supported Functions: program configure sig nop firmwarewrite patch setbootablestoragedrive ufs emmc power benchmark read getstorageinfo getsha256digest erase peek poke"

Miflesh sends a configuration command
send configure command
and had to send a team autenfikatsii (something like this)
send sig command

And if he did not send, I need another flasher. Or something else that the logs are not specified. After talking with several owners of the bricks, which tried thus restore their devices, managed to "isolate" a common point. After entering your account, all of them have seen the same image, such as "Your account is not authorized." Here is the script (or algorithm, as you wish) runs between the teams (see. Log)nopandconfigure.

There on some forum accounts collect ID may be "to authorize manually." Personally, I'm worried about the other question: how (in general) it will (or should) work in the future? So, if I have a new device, the account I have not had time to make all - tube pipe? Let's wait - we'll see.

There is another option. It will be a service programmer (firehose), which does not require authorization. Or something else.

The same problem (in piercing of EDL mode) experienced users Mi 6x, Mi 8, Redmi S2 / Y2. There are bricks.
Part 6. Final
Questionable
Who is now ARB4 Nothing you can not flash the EDL mode. Nothing at all, until the "Authorized Account". That the "authorization" means, in practice, will soon find out.
Who is now ARB3 , The flash mode may EDL any firmware version of the second loaders (and firehose) and not be able to flash the EDL mode EEPROM with a third version of the downloaders. Firehose third version will require authorization (verified).

In connection with the emergence of conflicting information and lack of (the owners working units) of interest in solving the problems, the post is frozen for an indefinite period.

I ask each and everyone (especially the owners of the bricks) are not hysterical, not flood the topic and (especially) the PM.
No need to ask questions that (so far) no answers.
Thank you for your attention: thank_you:

Right now (see. Edit date) information is cross-checked. Too many gaps.


Post has been editedSasha Gray - 17.07.18, 15:53
The reason for editing: cosmetic changes, the reference to a list of boot versions (Part 3)



Rep: (59)
* shurkesha ,
from 9/5/17
Attached fileThemeManager.zip(6.76 MB)


Post has been editedDyakon2012 - 13.07.18, 18:41



Rep: (3445)
MIUI 10 EU 8.7.12
Changelog
Lockscreen, Status Bar, Notification Bar Optimization - Face unlocking speed (07-12) Fix The problem of flashing screen in the process of fingerprint unlocking (07-12) Fix Fixed background in PIP mode Themes Fix Fixed themes details loading Fix Fixed Nature sound missing in sounds
Security Optimize New Security Center UI Notification Optimize - Media volume can be 'changed only when media playing (same as in MIUI 9) Camera New -Al Portrait mode for single camera devices (07-06) New AI Portrait mode for the front camera ( 07-06)

Forum EU
DownloadAFH
Warning - there is no mention of antiotkate like masik, if you are on anti 3, can not comment.



Rep: (237)
Unlock FastBoot teams!
Flashing TWRP! (ARB4)


After the introduction of closed steel ARB4 some fastbuta team, including firmware TVRP.

This method allows you to restart or start twrp fastboot command

1. Download the fastboot-unlock-anti-4-whyred ofattachments

2. The image format .img throw in a folder with adb and there to run the command line

3. Start fastboot, execute this command

fastboot flash antirbpass dummy.img

4. Now you can flash the TWRP, and run any command fastboot.

you have to perform dummy / unlock every time you enter the fastboot, or ARB blocks your commands.

Attached Image

Resembles revert to ARB3
LEADS TO bricks!


Duplicate attachment:Attached filefastboot-unlock-anti-4-whyred.zip(178 bytes)

Sourse of information:https: //forum.xda-deve...ing-anti-roll-t3816219

Automated program:
Xiaomi Redmi Note 5 Global / Note 5 China - firmware MIUI (Post gyord # 75082655)

Important! I am not responsible for your actions and the consequences. I'm just sharing the information indicating the source of the original.

Post has been editedCrazyzyman - 15.07.18, 14:26
Reason for editing: Refinements



Rep: (5198)
for fastingUnlock FastBoot commands! TWRP firmware! (ARB4) collected another easy example program!
you have to perform dummy / unlock every time you enter the fastboot, or ARB blocks your commands
Resembles revert to ARB3
LEADS TO bricks!

Softinkoy sewing section dummy.img and twrp immediately!

Attached fileantirbpass.exe(36.41 MB)


Post has been editedgyord - 15.11.19, 15:47



Rep: (44)
Way to pick up a brick (my translation)
Original post on XDAhttps: //forum.xda-deve...5-pro-unbrick-t3816178

Right tools:
- version Miflash, which is attached to the post.
- Qualcomm HS-USB QDLoader 9008 driver (attached to the report).
- extreme developer firmware for fastboot (can be found in the header).

important Note
Provide the account ID at the office. Online Xiaomei your brick in the form of a comment in this threadhttp://ru.miui.com/thread-10664-1-1.html

After that, your ID will be registered in the list of bricks and queued for release.

Step 1. Download the latest firmware complexed MiUi 10 to fastboot, and unzip it.

Step 2. Download and install the above drivers (Qualcomm HS-USB QDLoader 9008).

Step 3. Connect your device via testpoint (how to do it is in the subject header)

Step 4: Download, extract MiFlash Tool v.2018.5.28.0.
Open MiFlash Tool.
Select download and unzip the firmware.
Press "Start".

Step 5. Log E account, which is attracted to the device. OTHERWISE YOU WILL NOT BE ABLE beg your device!

Once entered a valid username, then sew

Attached files

Attached fileQDLoader HS-USB Driver.7z(13.12 MB)
Attached filef267b936-45cd-4b3d-b15a-947fb4b674b1.zip(49.41 MB)


Post has been editedcahta1122 - 15.07.18, 01:45



Rep: (156)
For owners BRICKS

I will add a little postvovcik3

If you do not have an official service center in your city, or guarantee, you can try this.
Make sure your phone is defined as QHSUSB 9008

1. Open your browser and sign in Russian Forum Miui. Place there MI ID, do not worry, it will be seen only by moderators. Use on Google Translate.
http://ru.miui.com/thread-10664-1-1.html

collection term Mi ID:
16 July 12: 00 [Beijing time (GMT / UTC +8


2. Wait for confirmation of your account, they will send you a message.Standby time up to July 16 12:00 [Beijing time (GMT / UTC +8 hours)

3. Download the latest Miui10 disk fast download 07/08/12 Global
http: //bigota.d.miui.c.../whyr...e775b9c0d5.tgz

4. Login and download the latest Miflash here.
https://c.mi.com/thread-1220989-1-0.html

5. Try using a flash MiFLASH and choose Clean All.

6. If you do not flash, try a power cycle. Disconnect from the PC holding the power button for 20-30 seconds. Try to flash repeatedly.



I know that an accordion, but put because I want to draw attention to paragraph в„–2
Wait for confirmation of your account, they will send you a message.Standby time up to July 16 12:00 [Beijing time (GMT / UTC +8 hours)

Tomorrow is waiting for letters from the Chinese and try to be sewn. Good luck to all of us.

Post has been editedNetv - 15.07.18, 06:44



Rep: (5198)
Otklyuchalka applications Root is not needed! Disables system applications(NOT ALL!)
Attached fileMiuidisabler.apk(414.71 KB)


Post has been editedgyord - 15.07.18, 14:06



Rep: (5198)
Balvanki to install applications!
Gathered balvanki, use self storage software in one place, the software I have the minimum possible so that someone will not need them.

Applications will be set as usual in"/ Data / app"
What and how:
  • Inside the blanks have a folder ->data
  • It ->app
  • Put in the necessary software app (with extension apk) ->reset on a flash drive (internal memory) ->TWRP-->sew

DO NOT USE THE RUSSIAN LETTERS, DASH, BADGES - ALL THAT TVRP do not understand!
Attached fileBalvanka.zip(125.31 KB)

Do not forget when repacking archive compression Set to 0

Installing applications as "Sistemenye"
The same patch but with the possibility of installation of applications as "System".
The patch has a system folder, it is created (in English and without spaces) folder with the name of your application, a folder with the name of your application throws (* .apk). There are applications that are bundled to go libs to work correctly (as a rule are already either in the apk, or see the posts with the application may attached already there), then this libu put in the same folder as the apk-file - nearby.
DO NOT USE THE RUSSIAN LETTERS, DASH, BADGES - ALL THAT TVRP do not understand!
Attached fileBalvankas.zip(125.55 KB)

Do not forget when repacking archive compression Set to 0

slippers not throw;)

Post has been editedgyord - 15.07.18, 14:45



Rep: (5198)
Root toolcase

ROOT REQUIRED (the app will not work without root)

Screenshots
Attached Image
Attached Image

Attached Image
Attached Image
Attached Image

Attached Image
Opportunities
App Manager can:
• clear data and cache of applications
• enable / disable (Freeze) applications
• delete applications

Firmware Wizard can:
• flash the ZIP-file for recovery
• Create firmware queue for a few zip-files
• flash files for kernels
• stitch images recovery

init.d Emulator:
• run scripts at start
• No own init.d support

Build.prop Editor:
• edit the properties build.prop

Additional options to reboot:
• loading in recovery mode or bootloader (fast loading)

Widgets:
• Task Cleaner
• Advanced Reboot

Legal information:
The developer of this app IS NOT RESPONSIBLE FOR DAMAGE TO EQUIPMENT! Backup no one has repealed

Download:Attached fileroot-toolcase-1-14-7.apk(6.4 MB)


Post has been editedgyord - 15.07.18, 15:59



Rep: (212)
Attached Image
Redmi Note 5 Pro
whyred
MIUI9 9.6.4.0 OLD END
MIUI10 10.2.1.0 NEW
(NoARB) Global stable under TWRP
Without a boot loader! ARB3 not make UP to ARB4!
If necessary, you can flash the FIRMWARE ARB3!

FileFIRMWARE_ARB3_OLD_vs_NEW_8.1.zip
carries the last downloader ARB3 from 9.5.17.0 and firmware DSP-MODEM-BT module from the latest current version and MIUI9 / MIUI10 (NoARB) full flash only firmware modules DSP-MODEM-BT without downloaders ARB3i4, everything else untouched MIUI version that works the same as the one with which ARB4 ...

Download: GoogleDisk

Attention!
This is not the ROLLING BACK! This update is for those who have not yet updated to the official version 9.5.19.0 and above of a cap which has a ARB4 same applies to the latest version MIUI10 8.7.12 and above, with this firmware version MIUI9 / MIUI10 (NoARB) with FIRMWARE ARB3 on top of the which cap MIUI9 9.5.19.0 (ARB4) and above, will not lead to a rollback to ARB4 back to ARB3 and get bricks in any case not sew if you already ARB4! Only if stitched on to this version with embedded ARB3 or cut FIRMWARE at the status ARB3!

PS .: As a regular update on the katabatic rekaveri not pass do not even try, especially TWRP.


I am not responsible for your actions, written warning is forearmed, check the status of the version of one of these ARBThe program / Manuallymethods before flashing!


Post has been editedShadyTiger - 11.01.19, 13:55
Reason for edit: Update from 9.6.4.0 to 10.2.1.0 and reincarnation.



Rep: (2863)
The experimental results (of my)
On the problem of a lot of bricks will not be distributed.Here all described in detail. I approached the problem from the other side. Wondered how it is possible to raise / lower the firmware version. Previously I wrote about it (there were just guessing). What was done :
I downloaded several versions of the firmware (and old with the notorious "the ARB 3" and a new "the ARB 4"). To begin, simply deleted from the archive folder firmware-update (because it lives in it the main "villain" - loader with a modified version) and the corrected script (deleted line to install downloaders chain (too much, but ... just reinsured)).
At the time of the experiments on board was Global Stable 9.5.6.0. unlocked bootloader.
Installed TWRP.
For understanding
a subject was not on hand. I had to go to the salon (there running my very good friend). After much persuasion and promises that if the "put" the device, you'll buy it, a subject was issued on his hands. The solution is not spontaneous. For the (most likely), similar measures will soon touch and other devices. I decided in advance "podstelit straw", so that later there was "excruciatingly painful"
Furthermore sewn (with all wipe) 08/07/12 remote firmfare. Reboot the system. All is well. Then sews Global Developer 8.5.10 (also from a remote firmware). Reboot the system. The patient is alive and no indication of malfunction.
Next - podpihnul firmware 8.5.10 from the archive since 8/7/12 (copied with replacement). 8.7.12 flashed (s firmware from 8.5.10). Reboot the system. All is well. I fell back to 8.5.10 (honestly, my heart skipped a beat, flashed the thought of parting with money). But ... the system starts, the patient is alive.
I decided to change one modem. Sew one NON-HLOS to 8.5.10 from 7.8.12. No sign of "falling into someone." Subject worked flawlessly. Reflash on 08/07/12 (modified by firmware 8.5.10). I beg your modem from 08/07/12. Everything worked.
All manipulations were carried out in the unlocked Bute. Experiment on katabatic rekaveri had no desire (for someone else's device, and so risked the money). In this experiment with the device (on my part) finished. I wanted to find out. Or remove all firmware-update folder from the archive with the firmware, or change to another (desired). If you need another modem, please separately. The device was sewn back on 9.5.6.0 with clearing all data loader lock and successfully given back.
Nobody, nowhere call. All the above description made at your own risk. Before you do something, think. Is it worth it? There is always a risk (especially in the current situation).
All of the cookies and good. And ... Avoid the bricks.
ps ... If someone is not, tomorrow I will post a detailed description of what, how, where and what to change

We read the continuation.

Post has been editeddraiv88 - 16.07.18, 23:09
Reason for editing: Edited.



Rep: (1716)
* X30n,
M
Check outResource rulessavagemessiahzine.com!
4.19. Forbidden abuse of quoting (overquoting, overquoting). It is not necessary to quote fully opponent posts - just select the main points and press the buttonPicture



Rep: (2863)
A small addition toto this fasting
Firmware change
What I want to warn in advance.This is not a manual or guide. And this is not a way to lift bricks . What you need to the first turn? Light head, arms straight and awareness of all ongoing procedures.
Because Xiaomei made it impossible to downgrade to version 8.7.5 above, will open a small "loophole." In order to be able to both upgrade and downgrade.
Stage One - upgrade
If you have firmware 8.7.5 and below, but there is a desire to try new firmware and painless back.
1: Download the correct firmware zip file
2: Do not archive unpacking (in order to avoid errors when zapakovke back) delete the folderfirmware-update (For in it lies the main "evil" - the whole chain of downloaders). Can be done both on the PC and on the devayse (I do through total commander).
Attached Image
You can remove or comment out the line in the script to install the contents of the folder firmware-update (for the paranoid, because in the absence of "idle" running script files themselves)
3: In TWRP doing necessary wipe. Install firmware Ruth. Reboot into TWRP, reboot the system
4: poyuzat firmware if you do not like, rolling back. Or a backup, or install clean
Step two - downgrade
If you have firmware version 8.7.5 and higher than she is not satisfied and there is a desire to revert to an earlier version.
Repeat step 1-3
Important. If you do not remove the firmware-update folder:
When upgrading will become a hostage of the new loader
When you get a downgrade brick

Similarly, one can switch toany firmware (official, localization, custom bikes)
Modem change
The modem itself (NON-HLOS.bin) does not affect the upgrade nor downgrade. Changes only version and the quality of communication / Internet (for better or worse). To change the modem is enough to extract a file NON-HLOS.bin of firmware-update folder and replace in the archive with the modem (you have a cap). Or sit and wait until someone does not do it for you. Delov for a moment longer to download.
Attached Image

All writing is applicable tounlocked bootloader . As will be locked, I do not know.
You can poudalyat entire chain downloaders from the archive under fastbut and sew through the PC. If there is an understanding, you can do. If not, do not touch. For ... easily you can get a brick.
Wishes
I'd add something. You (all here) are faced with a problem. Wine is not yours, the vendor. But ... as it sluggishly try (or even the lack of it) to help ourselves. A few days ago, I asked the person to help deal with your problem. Intelligent and lucid mind. He knows a lot. It's just his profile. With it has solved the problem (at the time) with the bricks in a branch mi 5x. He once again tries toget through to all. In response to the silence. It is necessary first of all to you. We have with him there is not even a subject on hand. A blind poke ... Help yourself. Or ... just wait, when to do it (and do it?) Vendor.


Post has been editeddestroyer71 - 16.07.18, 17:07



Rep: (5832)
MIUI | 8.7.17 Global | 10 | 8.1 | System / TWRP (daily)



Rep: (156)
At the request of the distinguishedSasha Grayand for the benefit of all who suffer "Kirpichnikov" I made the selection.

Boot versions in the firmware MIUI Xiaomi Redmi Note 5 (Whyred).

China StableMIUI 9, 8.1

  • miui_HMNote5_V9.5.22.0.OEICNFA_9b767a4ef1_8.1version 3
  • miui_HMNote5_V9.5.21.0.OEICNFA_5fbec543ba_8.1version 2
  • miui_HMNote5_V9.5.16.0.OEICNFA_d74d585a49_8.1version 2
  • miui_HMNote5_V9.5.14.0.OEICNFA_9fed96d8fa_8.1version 2
  • miui_HMNote5_V9.5.12.0.OEICNFA_52780e6b7c_8.1version 2
  • miui_WHYRED_V9.5.4.0..OEICNFA_b18a3c94aa_8.1version 2




Global stableMIUI 9, 8.1
  • miui_HMNote5HMNote5ProGlobal_V9.5.19.0.OEIMIFA_b370a6bc7e_8.1version 3
  • miui_HMNote5HMNote5ProGlobal_V9.5.17.0.OEIMIFA_35b0cda8a7_8.1version 2
  • miui_HMNote5HMNote5ProGlobal_V9.5.14.0.OEIMIFA_236e5090ac_8.1version 2
  • miui_HMNote5HMNote5ProGlobal_V9.5.13.0.OEIMIFA_9447b2a71f_8.1version 2
  • miui_HMNote5HMNote5ProGlobal_V9.5.6.0.OEIMIFA_3b50aa3537_8.1version 2



China DeveloperMIUI 10, 8.1
  • miui_HMNote5_8.7.12_818474d37a_8.1version 3
  • miui_HMNote5_8.7.5_3adb935c82_8.1version 2
  • miui_HMNote5_8.6.28_7dd98b6b17_8.1version 2
  • miui_HMNote5_8.6.21_fc95878dcc_8.1version 2



Global developerMIUI 10, 8.1
  • miui_HMNote5HMNote5ProGlobal_8.7.12_61b1bc7ff7_8.1version 3
  • miui_HMNote5HMNote5ProGlobal_8.7.5_066aab3bca_8.1version 2



Post has been editedNetv - 17.07.18, 15:36



Rep: (3445)
"KIRPICHNIKOV"!

There is reliable information that some raised byinstructions !
We check to try while not working at all. Nor any letters did not come.
Firmware should be 7.8.12.

Post has been editedvovcik3 - 17.07.18, 17:47



Rep: (3445)
addonis1982 @ 17.07.18, 18:21*
what version miflesh there?


Attached filef267b936-45cd-4b3d-b15a-947fb4b674b1.zip(49.41 MB)


Full version    

Help     rules

Time is now: 17/02/20, 1:46