> Attention!

We strongly recommend to readRules section "Android - firmware"

New threads need to be created only inroot partition! In the future, they will be processed by moderators.

Huawei P10 - Firmware

Rep: (1515)
Huawei P10 - Firmware
VTR-L09, VTR-L29, VTR-AL00, VTR-TL00.
Description | Discussion | Purchase | Accessories | Themes for Huawei Emotion UI | Google Account Bypass (FRP) Ways After Reset | Unlocking Huawei & Honor Device Downloader | Huawei P10 - Firmwares (Android OS 7.X) | Huawei P10 - Firmwares (Android OS 8.X)

Important information
Information on lowering the firmware to get the unlock code!
For those who use the program Huawei Firmware Finder to update the firmware
Huawei made changes to the process of installing the firmware. Now the firmware passes the online check before installation. Accordingly, before installing it is necessary to check the firmware for availability via IMEI. Otherwise, you will get "Authentication failed" before installation. This means that at the moment the installation of this firmware on this unit is currently impossible.. [/ center]

Drivers and Utilities

Official firmware

Unofficial firmware


Kernels / Recovery



For questions about filling the caps, contact the Curator of the topic. Drawn777 at QMS

Post has been editedDrawn777 - 21.06.19, 09:19
Reason for editing: Added new service firmware

Rep: (4)
* 7OH , * Drawn777 well, got it. Now you just need to remove supersu?

Rep: (46)
* inturned,
Yes, but he may just not go away.

Rep: (2704)
Paraguay @ 05/26/19, 1:39*
Yes, but he may just not go away.
There is also a twrp - uninstaller for alternately for Super and for Magisk, flashing the stock boot and following Magisk should work.

Rep: (46)
* PalychRv,
It works, but it's not that easy. You can roll the service again.

Post has been editedParaguay - 26.05.19, 01:43

Rep: (4)
* Paraguay , * PalychRv , thank. Then we have to do the installation again through 3 buttons, only the stock recovery will be returned. So I think for sure everything will be.

Post has been editedinturned - 26.05.19, 01:59

Rep: (1208)
Inturned @ 05/26/19, 1:33*
4. Put Magisk 16
5. Put Super SU 2.82
Amateur on the car to visit the maximum of chrome.
You need to put one thing. And the magic is old

Rep: (4)
* redhaos , I first did not fully understand what a magic is. Is to blame.
Now everything is done. Reinstalled the service and did everything in stages. I'm trying to get a GPay.

Rep: (46)
* inturned,
This method helped meGoogle Pay does not work (Post Dinamond # 85051183)

Rep: (7)
Tell us why everyone needs root.

Rep: (899)
* bacardi_57,
Games, normal backup, garbage removal, fixing the work of a highly intelligent AI (deletion, to be precise) ....
Everyone else can throw a ton of useful.
The question is - why can not I have full access to my device?
I agree with the loss of warranty (which is not 3-5 years).

Rep: (7)
* 7OH, Standard backup seems to work, with games it is not clear, and the root? About the garbage is also incomprehensible. The AI ​​in which it appears at all, personally, I don’t see what he does there at all. I’m not criticizing the calls and working without the root. I don’t criticize, I just want to understand. there was no, well, no phone is suitable for this, I do not even recognize the console. The PC is what it is for games. But this is my point.

Rep: (1208)
* bacardi_57 , customization of the shell for yourself, without this in any way. Well, mostly for a working gpay

Post has been editedredhaos - 27.05.19, 12:21

Rep: (899)
* bacardi_57,
Standard backup copes? Oh well.
I sometimes need a story in 2-3 iterations.

Games and garbage: yes - the phone has a lot of memory, but I am not ready to share resources with the garbage that was imposed on me. And the games - well, such a mentality - I am not ready to pay for the game, which by all means squeezes donates from me.

AI: for many, after a “shutdown”, non-working notifications and scheduled programs start working normally. If everything works for you, I am sincerely happy, but there are other options for the “work” of the device.

Well, customization - yeah - it's a fat piece)).

Rep: (398)
bacardi_57 @ 05/27/19 11:38*
I have not been using it for 3 years already
also 3 years do not smoke, it is harmful

redhaos @ 05/27/19 12:15*
for working gpay
for me, for example, the boot is closed

7OH @ 05/27/19 12:22*
Standard backup copes?
I don't like backups, but I tried to do it from one P10 to another with the same firmware version using an otg flash drive and everything is fine

Rep: (1208)
DrawN777 @ 05.27.19, 15:02*
for me, for example, the boot is closed
everyone is free to choose

Rep: (103)
Only with root you can fully remove all advertising in applications.

Rep: (4)
* Paraguay, helped way, plus flew away. ;)

And how can I see the logs? for example, the application stopped working
I hid the root in magisk from it and it worked, but why would a regular checker of reference numbers have bugs with root ?!

Post has been editedinturned - 28.05.19, 00:05

Rep: (1)
When there was a root, then through the lakipatcher blocked the firmware update. Now the root has flown down, I want to start the system to update, but the device does not respond to pressing the corresponding menu item? What to do? Can I do without dumping on default?

Rep: (1208)
filat18 @ 05.27.19, 10:12*
Can I do without dumping on default?

Rep: (4)
Prompt for VTR-L29 (C10) FF says that VTR-LGRP2-OVS is available.
Can I try to put it on the device through HiSuite? Through eRecovery - it did not work out, although the DNS set the correct one and the verification passed - the page opened on the link.

Full version    

Help     rules

Now: 07/19/19 05:00