Rollback with futurerestore (Odysseus) | For iPhone (4S, 5, 5C), iPod touch 5G, iPad (2, 3, 4), iPad mini 1



Rep: (1515)
Rollback with futurerestore (Odysseus)
\ iPhone (4S, 5, 5C), iPod touch 5G, iPad (2, 3, 4), iPad mini 1 /


Attached Image

What is a rollback (downgrade)?
  • Rollback (downgrade) - install the old version of iOS, which is officially no longer relevant on the Apple server and is not signed by the SHSH certificate. Officially, you can only flash on the latest, current firmware.
  • For informativeness -> Wikipedia
You need to understand the following:
  • For rollback using futurerestore need a jailbreak.
  • For rollback using futurerestore previously saved SHSH required.
  • futurerestore supports ->iPhone (4S, 5, 5C), iPod touch 5G, iPad (2, 3, 4), iPad mini 1
  • futurerestore supports ->Linux and macOS, does not support Windows.
To roll back / restore iOS, we need:
  • macOS (10.10 Yosemite, 10.11 El Capitan, 10.12 Sierra).
  • Firmware for our device on which we roll back -> IOS firmware
  • Previously saved SHSH from the firmware on which we roll back.
  • futurerestore for rollback.
  • kDFUApp from repository -> http://repo.tihmstar.net
For example, take futurerestore for macOS, iPhone 4S (A1387, A1431) (onboard iOS 9.3.5) with an identifier ->iPhone4,1 (n94ap) and SHSH ->******** 44587-iPhone4,1-7.1.2-11D257.shsh to roll back to iOS 7.1.2
Create a folder on your desktop ->Downgrade
From the archive ->futurerestoreportable ->futurerestore_macosin the folder on your desktop ->Downgrade
SHSH ->******** 44587-iPhone4,1-7.1.2-11D257.shsh copy to the folder on your desktop -> Downgrade
Firmware (iOS 7.1.2, to which we roll back) ->iPhone4,1_7.1.2_11D257_Restore.ipswcopy to the folder on your desktop ->Downgrade

In folder ->Downgrade must be 3 a file.
Attached Image
******** 44587-iPhone4,1-7.1.2-11D257.shsh ->certificate from the firmware for which we roll back / restore (iOS 7.1.2).
futurerestore_macos ->executable file futurerestore for macOS.
iPhone4,1_7.1.2_11D257_Restore.ipsw ->The firmware for which we roll back / restore (iOS 7.1.2).

For normal operationfuturerestoreadditional packages are needed, we open the terminal and enter commands.
🢃🢃🢃
Open a terminal and enter commands one by one
Attached Image
  1. xcode-select --install

  2. / usr / bin / ruby ​​-e "$ (curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

  3. brew install automake autoconf libtool pkg-config libplist openssl libzip
    git clone https://github.com/tihmstar/libirecovery && cd ./libirecovery && bash autogen.sh && make install
    cd
    git clone https://github.com/tihmstar/libcrippy && cd ./libcrippy && bash autogen.sh && make install
    cd
    git clone https://github.com/tihmstar/libfragmentzip && cd ./libfragmentzip && bash autogen.sh && make install
    cd
    git clone https://github.com/tihmstar/libpartialzip && cd ./libpartialzip && bash autogen.sh && make install

  4. cd / usr / local
    sudo mkdir ssl
    sudo chmod 777 / usr / local / ssl
    cd
    git clone https://github.com/openssl/openssl.git
    cd openssl
    ./config
    make
    make install

  5. brew install curl

  6. ln -s /usr/local/opt/openssl/lib/libcrypto.1.0.0.dylib / usr / local / lib /
    ln -s /usr/local/opt/openssl/lib/libssl.1.0.0.dylib / usr / local / lib /
    ln -s /usr/local/Cellar/openssl/1.0.2j/bin/openssl openssl

After preparing the necessary files and system, go to the main, preparing the device for rollback / recovery.

1. Open Cydia on your device and add a repository -> http://repo.tihmstar.net
2. Install from repository -> kDFUApp .
3. We connect the device to the computer and run kDFUApp from the main screen.
Attached Image
4. Activate all switches so that they become green at kDFUApp .
Attached ImageAttached Image
5. It does not matter which version is listed in the Bundle.
6. Push enter kDFU The device will go into DFU mode (black screen).
Attached ImageAttached Image
7. Open the terminal.
8. We enter cd , press the spacebar and drag the folder to the terminal -> Downgrade
Attached Image

Attached Image
9. Hit Enter
Attached Image
10. To be sure that we are in the right folder, enter ls and hit enter
Attached Image

Attached Image
11. We enter chmod + x futurerestore_macos and hit enter
Attached Image

Attached Image
The next step will be final, after which the rollback / restore will begin. The core team looks like this:
./futurerestore_macos -t **. shsh --latest-baseband --use-pwndfu **. ipsw

Where**the names of the main files in the folder ->Downgrade
My team, with my data looks like this:
./futurerestore_macos -t ******** 44587-iPhone4,1-7.1.2-11D257.shsh --latest-baseband - use-pwndfu iPhone4,1_7.1.2_11D257_Restore.ipsw

If your device is without a SIM, the command will be
./futurerestore_macos -t **. shsh --no-baseband --use-pwndfu **. ipsw

Data example
./futurerestore_macos -t ******** 84401-iPad3,4-7.1.2-11D257.shsh --no-baseband --use-pwndfu iPad3,4_7.1.2_11D257_Restore.ipsw

12. We enter ./futurerestore_macos -t ******** 44587-iPhone4,1-7.1.2-11D257.shsh --latest-baseband - use-pwndfu iPhone4,1_7.1.2_11D257_Restore.ipsw and hit enter
Do not close the terminal window, do not disconnect the device from the Mac, check everything several times.
Attached Image
Attached Image
Attached Image
Attached Image
Done: restoring succeeded. Congratulations, after successful recovery, block iOS update ->How to disable automatic iOS update

Post has been editedT0ugh - 18.08.17, 12:25



Rep: (0)
It's great that there is such an opportunity, maybe my touch 5 just slows down a lot, but unfortunately I do not have SHSH (it was updated 9.3.5 a long time ago) / Is there anything I can’t do to roll back the firmware?



Rep: (1)
* d_dron,
I also have an iPod Touch 5g, and it works fine on 9.3.5, although naturally it flew on version 6 of the firmware, and even in my opinion on 7, but problems started with 8
And the most serious of them - multitasking practically does not work, that is, when switching to another application, the first after 30 seconds - it is cleared from RAM

there is a way using Jailbreak to write the firmware version of something like 6.x.x, and then he will offer to flash the latest version of iOS 8, but as you know everything is not much better there
______

In general, the only way to experience 9.3.5 in full force (it does not slow down, only multitasking works very poorly) is to reflash the device in DFU mode and configure it as a new iPod

You can throw Old in Icloud, and then copy

Post has been editedsin89rus - 07.04.18, 20:07



Rep: (0)
* sin89rus,
thanks for the advice! How can I upgrade to 6 using a jail? I found only how to roll back 4s

Post has been editedd_dron - 08.04.18, 20:20



Rep: (0)
Hello
Stumbled upon a problem
iPhone 5S, a year ago, fell into the water, and a year later (that is, now) the Home + Touch ID button stopped working
At first, the Home button itself hung (on firmware 11.2.6), and the Touch ID worked fine, then the Home button did not press at all (on firmware 11.2.6 and 11.3), the Touch ID still worked, and now neither Home nor Touch works ID (Error in the settings in Touch ID)
Even if you press the Home button very hard, it can be pressed, but not always.
Is there a malfunction in the phone?

And there is no rollback, as I understand it, from 11.3 to 10?



Rep: (1515)
* Vasul2010,
No rollback.



Rep: (47)
If someone comes in handy, here is the patched iBSS for iPad mini 1 (2.5) for firmware 8.4.1
pwnediBSS iPad2.5 8.4.1 (Yandex.Disk)
You can roll back from under Windows using this instruction:
http://www.3u.com/news/articles/5841/untethered-downgrade-iphone-5-ipad234-ipad-mini-to-ios841-without-shsh(Custom firmware in the instructions)



Rep: (0)
Ipad 3 64gb lay around for a long time without work, turned it on and updated it stupidly - the terrible lags started.
I read the topic and did not understand. Is there an actual method to roll back to 6 iOS? Now 9.3.5, SHSH has never been uploaded.



Rep: (23)
Now there is a Windows version with Odysseus support.
Attached Image


https://bbs.feng.com/read-htm-tid-11594187.html



Rep: (5)
* amonraaa3,
Tell me, how did the minicut translate to kdfu mode? firmware downgraded from 9.3.5?

Post has been editedT0ugh - 12.05.18, 14:15
Reason for editing: Removed overclocking



Rep: (-1)
Hi. People I completely read the topic, tried a couple of instructions, but still ... If the normal way to rollback ipad 4 ?? Who knows, please answer very much and discard the method for instructions, just do not drop the instructions on the Tweak by changing the firmware version, they have not been working for a long time ...



Rep: (5)
* asd2332,
Literally at the weekend, the iPad mini 2.7 tried to roll back according to the instructions from this topic, again no luck, just tried the methods from under Windows (several messages earlier), it also doesn’t work.
The main problem, it is not possible to correctly switch to kDFU mode, at least with the iPad2.7 model, I did not succeed, more precisely, only one of the methods translated (enterkdfu tweak) but apparently it didn’t translate as it should, because the Windows futurerestore terminated on an attempt to connect to the device when uploading iBBS, iBBC and gave an 94 error, through the utility from 3u also does not upload the modified firmware.

As a result, I got tired, took the old proven (albeit clumsy) method and did a downgrade from 9.3.5 to 8.4.1 through changing the firmware version to 6.1.3.
1) on firmware 9.3.5 with a jail we put the file manager (for example, Filza File Manager)
2) using the file manager, edit the file "/System/Library/CoreServices/SystemVersion.plist"
3) replace Version with 6.1.3 and Build with 10B329 then save the file
4) after that we send it to reboot with recovery (hold down the power + HOME button until the boot screen with a stub appears)
5) after downloading, go to the update and agree to download and install the updates by plugging the device into a wall outlet, then installing the update (this step doesn’t work for me every time, the ILV trip with its locks helped, if it doesn’t start, turn off the Internet on the device and again include until it issues a license to install).
6) after installing the update, we ignore possible errors / messages, go to the settings and run "Erase all content and settings" ->happy 8.4.1
Whatever they say about the clumsiness of the method, I did not find another for my model, but it works a million times more stable and faster than 9.3.5



Rep: (-1)
Hi. I also tried to follow this instructionhttp://www.3u.com/tuto... 10-10-3-3-to-ios-8-4-1
But during installation, it generates an activation error. But the instruction has a method with swapping poppy addresses, but I have not tried it, since I'm not sure if it is safe ...

Posted on 05/14/2018, 11:33:

Maybe there are still some options ??



Rep: (465)
* asd2332,
An activation error during rollback through a version and build spoofing has long been fixed. The man above confirms my words. Itself yesterday rolled back the first minicar in such a way. Why you can not do it, I have no idea. Try with a tweak that changes the poppy address, there is nothing dangerous in that. Millions of people on the planet use it and do not cough) And you’re hammering your head with different nonsense)



Rep: (-1)
What tweak changes poppy? Fashionable link if not complicated. Through mterminal it did not work to change ... Thanks for earlier



Rep: (4)
Good evening, gentlemen.
Maybe someone is interested or it was already there,
but according to this instructionhttps://trashbox.ru/to...ukciya-po-dzhejlbrejku
I rolled back iPad 2.



Rep: (0)
I confirm ipad 2 was updated according to the instructions on 8.4.1



Rep: (12)
Sorry about this error, what about us?
[Error] Error: failed to load shsh file iPhone4,1_n69uap_10.2.shsh
[Error] Fail code = -38
Failed with errorcode = -38



Rep: (1515)
iPhone4,1_n69uap_10.2.shsh

What is it ? iPhone4.1 ->4S, latest firmware for this device is 9.3.5
n69uap ->SE



Rep: (12)
* T0ugh
I pulled the certificate from the device according to the instructionsSave SHSH for all devices. He called me that himself.
* T0ugh
--convert -s name of future_ertificate.shsh C: \ specify_full_path_to_APTicket \ apticket.der

It doesn’t matter what to call. Followed by example
To begin with, I want to clarify whether the certificate was correctly extracted from me. The structure is as follows. Inside Data there are many letters and numbers
Attached Image

Is rollback exactly up to date? It doesn’t work in any way. On the poppy, the error already resulted above, on windows according to this instructionhttps://www.youtube.com/watch?v=wjTRu0YwH3oan error at the last stage that cannot be transferred to recovery mode
ERROR: Unable to connect to recovery device
ERROR: Unable to place device into recovery mode from DFU mode

Even English-language sites do not give an answer.
I wanted to, damn it, put 6.1.3 on my head. Now hike on it and stay: wacko:

Post has been editedT0ugh - 28.07.18, 21:28
Reason for editing: Extra spaces



Rep: (10)
Hello! iPhone 5 from 8.4.1 to 6.1.3 with shsh can be lowered on Windows? or you need to install a virtual machine with Linux?

Post has been editedvaservaga - 01.08.18, 14:34


Full version    

Help     rules

Now: 09/09/19, 10:58