> Attention!

We strongly recommend to readRules section "Android - firmware"

New threads need to be created only inroot partition! In the future, they will be processed by moderators.



Xiaomi Mi Max 2 - Unofficial firmware
What kind of firmware and TWRP do you prefer
Android 7.1_NOUGAT
LOS 14.1 [ 23 ] ** [14,56%]
RR 5.8.3 [ 16 ] ** [10,13%]
AOSP Extended [ 33 ] ** [20,89%]
Viper [ 3 ] ** [1,9%]
AOKP [ 2 ] ** [1,27%]
AICP [ 2 ] ** [1,27%]
Xenon [ 6 ] ** [3,8%]
crDroid [ 1 ] ** [0,63%]
Dot [ 1 ] ** [0,63%]
Other [ 51 ] ** [32,28%]
Android 8.1_OREO
RR [ 18 ] ** [11,39%]
LOS [ 17 ] ** [10,76%]
Xenon [ 2 ] ** [1,27%]
MSM [ 1 ] ** [0,63%]
Dot [ 2 ] ** [1,27%]
AOSP Extended [ 28 ] ** [17,72%]
Bootleggers [ 2 ] ** [1,27%]
Pixel Experiens [ 11 ] ** [6,96%]
Havoc [ 8 ] ** [5,06%]
Other [ 47 ] ** [29,75%]
Android 9.0_PIE
Havoc [ 42 ] ** [26,58%]
RR [ 7 ] ** [4,43%]
LOS [ 14 ] ** [8,86%]
Bootleggers [ 2 ] ** [1,27%]
Pixel Experiens [ 13 ] ** [8,23%]
Arrow [ 10 ] ** [6,33%]
Posp [ 4 ] ** [2,53%]
Viper [ 1 ] ** [0,63%]
AOSP Extended [ 19 ] ** [12,03%]
Other [ 33 ] ** [20,89%]
TWRP
TWRP by rkmadotra [ 10 ] ** [6,33%]
TWRP Red Wolf [ 7 ] ** [4,43%]
TWRP by ashwin [ 1 ] ** [0,63%]
TWRP official [ 39 ] ** [24,68%]
TWRP by NFound [ 7 ] ** [4,43%]
TWRP by brigudav [ 5 ] ** [3,16%]
TWRP by Codered [ 3 ] ** [1,9%]
Orange fox [ 11 ] ** [6,96%]
Pitch black [ 1 ] ** [0,63%]
TWRP by greeshan [ 4 ] ** [2,53%]
TWRP_MOD by sanek-creed [ 11 ] ** [6,96%]
TWRP_mod_ pie [ 27 ] ** [17,09%]
Other [ 32 ] ** [20,25%]
Total votes: 158
 



Rep: (3321)
Xiaomi Mi Max 2 - Unofficial firmware
PictureXiaomi Mi Max 2
Description | Discussion » | Purchase » | Accessories » | Marriage and Repair » | Camera talk » | Power consumption (autonomy) » | Modification and decorations » | Mi Account » | Unlocking XIAOMI bootloaders » | FAQ of general instructions and recommendations for Xiaomi devices | MIUI firmware » | Custom kernels » | Unofficial firmware »


mini - F.A.Q.

Important information!
  • Carefully read the cap, we study the necessary information. We use Picture
  • Before any manipulations with the device, it is recommended to dobackup efs
  • Be sure to make a full backup before any manipulations with the device!



Drivers and Utilities
Drivers
Utilities

Tools

Firmware
Project treble
Instructions
TWRP / ROOT
GApps
Useful
miscellanea
Polls archive
Attached Image
Attached Image

Attached Image

For questions about filling the caps, contact the curator of the topic. sanek-creed

Post has been editedsanek-creed - 30.07.19, 07:26
Reason for editing: Resurrection Remix 5.8.8 and Review



Rep: (6)
* theosoph
and non-switchable button press sound when entering text?

Flash archive and change level from 800 to required (value from 116 to 3596 - by default 2088) in the file / system / etc / init.d / 97-vibro.sh




Rep: (76)
Nikita Borisov @ 04/21/18, 19:05*
and eva0034's AEX is faster and smoother

and I have the feeling that the second version is better than the first and plus the second equalizer does not crash on the second version, it crashed on the first
and from pranava also crashed

Post has been editedthe_Mentalist - 21.04.18, 20:03



Rep: (11)
Cutieboy @ 04/21/18, 23:40*
I freaked out and rolled it right on top of the previous AOSP. I don’t see the difference yet. The volume bar still does not disappear.

Maybe someone will help ...
I also had a story with the volume panel. it, this panel, did not disappear when in the background hung the service of the VibeOn program, which regulated the force of vibration, because the firmware does not seem to have this feature. As soon as I erased this program, everything was fixed, the sound panel began to disappear as expected.

And, in general, I like the latest version AOSP Ext Eva more than all the firmware. No need to patch, no minor dirty tricks, it just works.

Post has been editeddomovoirt - 22.04.18, 07:50



Rep: (2694)
All firmware (at the moment)
AICP_UNOFFICIAL_20180417 by pranavaryans
AIM Rom_UNOFFICIAL_20180414 by pranavaryans
AOKP_UNOFFICIAL_20180328 by pranavaryans
AOKP_UNOFFICIAL by V_v3k
AOSCP_UNOFFICIAL_20180406 by pranavaryans
AOSP Extended_UNOFFICIAL_20100418 by pranavaryans
AOSP Extended_UNOFFICIAL by eva0034
CARBON_UNOFFICIAL_20180418 by pranavaryans
crDroid_UNOFFICIAL by pranavaryans
ColtOS_UNOFFICIAL by Jay_B

DarkRom_UNOFFICIAL by pranavaryans
Dotos by Jay_B
DotOs_UNOFFICIAL_20180409 by pranavaryans
Firehound_UNOFFICIAL by V_v3k
Flyme 6_OFFICIAL
LOS Extended_UNOFFICIAL_20180423 by pranavaryans
LOS 14.1_UNOFFICIAL by ashwin007
LOS 14.1_UNOFFICIAL by xuefer (port)
LOS 14.1 ota by scissor
LOS 15.1_UNOFFICIAL by ashwin007
MoKee_UNOFFICIAL
NukleaRom_UNOFFICIAL by pranavaryans
OctOS_UNOFFICIAL by pranavaryans
RidonOS_UNOFFICIAL by pranavaryans
RR_v5.8.5_UNOFFICIAL by kenzolo
RR_v5.8.5_UNOFFICIAL by pranavaryans
RR_v5.8.5_UNOFFICIAL by iscle
RR_v5.8.5_20180417 by yasshda (Scissor)
RR_5.8.5_20180510 by scissor
RR_v5.8.5_OFFICIAL by ROMFACTORY
XenonHD_UNOFFICIAL by Jay_B
SlimOS_UNOFFICIAL by pranavaryans

ps ... If anyone needs it, translated AOKP from parnavaryans
AOKP_mod

Post has been editeddestroyer71 - 29.04.19, 05:49
Reason for editing: RR 5.8.5 official



Rep: (300)
AOSCP_UNOFFICIAL_20180406 by pranavaryans

There is one unpleasant feature of the firmware, if it were not for the friendship with MIUI, I would have already demolished and put the moose on the 14th.

In short, someone doesn’t want to use Wi-Fi from any application - we stomp on the settings.
Battery
Tap the three dots at the top right.
Battery saving
Sort All Applications
Choose the application we need from the general list.
Tap, put it into "Does not save battery" mode
Restart the application.

Damn, I thought I would go crazy ... and reconfigured the router ... and hit a tambourine in dances .... everything is ok on the mobile Internet, but there was no traffic exchange on Wi-Fi.



Rep: (1090)
M
Dear users!
I urge you not to translate the discussion in offtopic and flood.
Messages with violations removed.



Rep: (225)
Kazakhbox @ 04/26/18, 14:28*
2) I requested TVRP

Try to flash another version of tvrp.



Rep: (2694)
Alternative fastboot and adb firmware without PC
Description
This method is suitable for installing recovery, boot, system and other things in "traveling" conditions. Without resorting to the help of a PC, just using another device.
On the device (with which you will flash, then ... "donor": D)necessarily There must be a root.
Installation and firmware
We install and work on the "donor"
1: Flash this archive without wipes from TWRP
Attached fileFastboot_for_Android.zip(498.38 KB)

In the absence of TWRP, unzip and put the fastboot file along the pathSystem / bin . We set permissions 0755. Reboot
Attached filefastboot.zip(376.99 KB)

2: Installterminal . We start. We introduce
su
We provide root access.
Further
fastboot

If such a window opens with a list of commands, we begin to work with the "patient"
Attached Image

Turn on usb debugging on it. Turn off and put into fastboot mode.
We connect the "patient" to the "donor" using the OTG cable. Check connection
fastboot devices
If the "patient" is determined, then, as necessary, to whom what is needed.
Files for firmware are better to put in the root directory of the device. It’s more convenient to prescribe the path. For example, to flash boot.img, enter
fastboot flash boot /sdcard/boot.img

Recovery
fastboot flash recovery /sdcard/twrp.img
etc
Addition
Checked at home. First uploaded to the "patient" recovery, boot. I also installed firmware for fastboot. The only inconvenience - I had to flash one partition (system, boot, cust, etc.).
There are no limits to bullying the device, there would be a desire: D
In addition to fastboot, there is also adb. Everything is similar. We lay on the same path. Or flashing this archive from the recovery.
Attached fileAdb_for_Android.zip(202.84 KB)

Attached fileadb.zip(63.02 KB)

Prerequisite - "patient" must be with unlocked bootloader (with regards to this vendor).
A source . I hope someone comes in handy;)


Post has been editeddestroyer71 - 19.02.19, 09:15



Rep: (76)
Gentlemen
and who can explain how RR (from 03.21.18.) differs from AOSP, in terms of not "put it and see for yourself", but on the basis of what are the firmware made? This impression is both made on the basis of one thing (I'm not special in this, so do not kick). I must admit that there are no network failures on RR, but on AOSP it happens that I catch a cross, at work there is none, but at home it happens on Wi-Fi, routers are naturally different, but I can’t understand why this happens. After a clean installation, the RR feels faster, but after the same set of software, the RR, compared to the AOSP, begins to sag in smoothness, again in sensations. But RR without crosses is always in touch, and AOSP sometimes catches this cross on wifi. They seem to have the same modems (I tried to flash different ones from the header), I can’t understand what could be the problem? And yes, on AOSP the sound is better (namely from the speakers) than on the RR even with viper installed, but this again feels like.



Rep: (324)
* the_Mentalist ,
RR is made based on LOS, AEX based on AOSP.
Used almost all the custom that is at the moment. I use AEX from eva0034 from the moment of release. There have never been any network dumps, communication problems and wi-fi. However, like on RR, and on other custom ones.
I chose AEX for myself, since it is subjectively smoother and faster than RR.

Post has been editedDotsmaster - 04.05.18, 18:39



Rep: (76)
Dotsmaster @ 05/04/18, 19:24*
I chose AEX for myself, since it is subjectively smoother and faster than RR.

I have the same opinion, but only after comparing the installed software, RR saved (I return for comparison), and I’m sitting on eva's AOSP, but there was a connection failure to eva, but I never had RR (I’m thinking of changing my home router asus 12 years ago, but damn it, it works and suits me, and two laptops with a TV also suit me, but 5G is probably better, but 2.4 suits me))).
In terms of energy consumption, in my opinion, at the level of error.

Here, in the comrade topic, one really wrote that there were also network dumps on AOSP, there are probably two of us)), but AOSP seems to me better than all the past including offs.



Rep: (2694)
Drevoborod @ 05/08/18, 10:45*
I don’t know the exact procedure
log
Unpack archive
Attached fileadb_logcat.zip(702.35 KB)

Connect the device to the PC. Run batch filelogcat_devices.bat . Launch problem software on the device. Log removal will go. Upon completion, simply close the batch file window. From the folder with tools to pick up the file logcat.txt . We are looking for a "villain" in it: rabbi:



Rep: (1421)
jmter
M



Rep: (242)
They simplified our fate. Fix for fingerprint on AEX Oreo. Sew via TWRP
FILE FOR TWRP


Post has been editeddraiv88 - 14.05.18, 20:04
Reason for editing: In the header



Rep: (324)
Who cares, the person on xda found a way to fix the navigation keys on the Pixel Experience Oreo. I checked it myself, the method works. And of that, after fixing the keys, only the SOP and LED indicator do not work. Those who are not confused by these two points can use the firmware for every day.

So, the fix itself. I say right away, I used the Root Explorer program. The presence of root is required!
We follow the path System / usr / keylayout / Generic.kl, open the Generic.kl file in a text editor and change the corresponding values ​​to the following.

key 102 HOME
key 139 APP_SWITCH

Reboot, and enjoy the working navigation keys)



Rep: (324)
I am writing in a separate post (I hope I’m not breaking anything) :)

Specifically, in this firmware on android Oreo there is still the maximum number of additional settings from the firmware currently available on the cookie. Even more than on AEX v5.5. According to the settings, the firmware is the same as AEX 4.6 Nougat. For me personally, this is a huge plus. I was very pleased with the presence of such a setting
Attached Image

Now, indeed, every time you connect a smart to the BB, the body is connected in the MTP mode, and not charging. The firmware itself feels very fast. So far, only the most positive emotions) It’s a pity just with the dynamics of zapara.

I haven’t forgotten yet ... Fast charging doesn’t work yet (maybe it’ll be cured by installing a custom kernel, I haven’t tried it yet). And the LED indicator does not work. In general, the firmware is still damp, but among the ones available at the moment, I will wait for its fixes probably more than AEX v5.5)



Rep: (1627)
M
dantist_140 Appointed by the curator of the topic. Please love and respect.



Rep: (2694)
Trimmed Gapps


With the ability to disable / enable

Description
In the archives, contacts, calendar (services and synchronization), market. There is nothing more. Flash like ordinary gapps. Those. immediately after installing the rum. Add account manually - Settings / Accounts

28.05.2018
7.1.2 Attached fileMini_Gapps_N_7.1.2.zip(54.49 MB)

8.1.0 Attached fileMini_Gapps_O_8.1.0.zip(62.46 MB)



03.10.2018
7.1.2 Attached fileMini_Gapps_7.1_NOUGAT.zip(66.72 MB)

8.1.0 Attached fileMini_Gapps_8.1_OREO.zip(66.23 MB)



26.11.2018
9.0 Attached fileMini_Gapps_9.0_PIE.zip(86.68 MB)



21.08.2019
7.1.2 Attached fileMini_GApps_N_21082019.zip(70.45 MB)



Universal_gapps
It contains only a calendar and contacts (with synchronization). To add an accountSettings / Accounts / Add Account . Suitable for all versions of android (7/8/9)
Attached fileUniversal_Gapps.zip(4.16 MB)



Post has been editeddestroyer71 - 21.08.19, 19:19
Reason for editing: 08.21.2019



Rep: (30)
I'm sitting on Eve 4.6. Iota is defined as Orensot. Tips where to pick?



Rep: (108)
Ksandrius @ 05/31/18, 00:38*
Tips where to pick?

system / etc / spn-conf.xml
Search byOrensot section <! - Russian Federation ->
Change toYota save changes and reboot.

Post has been editedgvshil - 31.05.18, 06:33
Reason for editing: clarified


Full version    

Help     rules

Now: 09/11/19, 9:24 PM