DD-WRT - Alternative Firmware | [firmware] General theme. FAQ, software discussion, tips, problem solving



Rep: (39)
OpenWrt / LEDE (General theme) | Build OpenWrt / LEDE from source | Collect bin (dump) for the programmer | Upgraded UBOOT loaders


DD-WRT FIRMWARE

DD-WRT - free alternative firmware for wireless routers

Attached Image

Latest version:See the official FTP
The forum decided to post images under the spoilerPicture


Difference DD-WRT firmware from factory
First, it is worth noting that DD-WRT firmware is an operating system based on the Linux kernel. Even with the default settings it has a very wide functionality, much wider than in the factory firmware. Built-in components such as FTP server, Samba, WOL and more. Through the Web interface, detailed statistics and load on the channels of the local, wireless network and the Internet are available, as well as the load on the processor and the memory of the router.

If you configure the router to install additional packages, you can turn your router into a home media server. A connected hard drive with a torrent client installed, broadcasting ITPV via HTTP, for viewing via wi-fi. If you have a TV with DLNA standard support, you can connect the TV to the router and watch IPTV, as well as watch movies from your hard drive.
Opportunities
13 languages ​​(including Russian)
802.1x (EAP (Extensible Authentication Protocol) encapsulation over LANs)
Access Restrictions
Adhoc mode
Afterburner
Client Isolation Mode
Client Mode (supports multiple connected clients)
Client Mode WPA
DHCP Forwarder (udhcp)
DHCP Server (udhcp or Dnsmasq)
DNS forwarder (Dnsmasq)
DMZ
Dynamic DNS (DynDNS, easyDNS, FreeDNS, No-IP, TZO, ZoneEdit, custom, and others)
Hotspot Portal (Sputnik Agent, Chillispot)
IPv6 Support
Jffs2
MMC / SD Card Support (hardware modification required)
NTP client in a client-server basis
Ntop remote statistic
OpenVPN Client & Server (only in -vpn build of the firmware)
Port triggering
Port Forwarding (max. 30 entries)
PPTP VPN Server & Client
QoS Bandwidth Management (Optimize for Gaming and Services / Netmask / MAC / Ethernet Port Priority)
QoS L7 Packet Classifier (l7-filter)
RFlow / MACupd
Routing: Static entries and Gateway, BGP, OSPF & RIP2 via (BIRD)
Samba FS Automount
Syslog to remote server
Rx / Tx Antenna (Select or Auto)
Uptime / Processor Utilization
Site survey
SNMP
SSH server & client (dropbear)
Startup, Firewall, and Shutdown scripts (startup script)
Static DHCP Assignment
Style (Changeable GUI; v.23)
Supports New Devices (WRT54G V3, V3.1, V4, V5 and WRT54GS V2.1, V3, V4)
Telnet server & client
Transmit Power Adjustment (0-251mW, default is 28mW, 100mW is safe)
UPnP
VLAN
Wake On Lan client (WOL)
WDS Connection Watchdog
WDS Repeater Mode
Wireless MAC Addresses Cloning
Wireless MAC filter
WMM (Wi-Fi Multimedia QoS) or Wireless Multimedia Extensions (WME)
WPA over WDS
WPA / TKIP with AES
WPA2
Xbox Kaid (Kai Engine)
Web Interface Screenshots
List of supported devices
How to flash (install) DD-WRT

factory-to-ddwrt.bin - file for installing DD-WRT from under the router's native firmware.

webflash.bin - file for updating from already installed DD-WRT.

For some models, only one file is available for all operations.

Forthe originalDD-WRT installations:

In the address bar of the browser we typehttp://192.168.1.1orhttp://192.168.0.1,depends on the router, enter the data for authorization and update the filefactory-to-ddwrt.bin through the standard update menu in your router.
After some time, the router will reboot, after which you will see the updated interface (DD-WRT's address is 192.168.1.1 by default). On the main page when you first start you need to specify the username and password for administration.
Firmware dd-wrt installed, you can proceed to configure. (It is also recommended to do a reset to the factory settings after the firmware and before the setting)

If you have problems not being able to log into the DD-WRT admin panel after the firmware, go to the network connections on your computer and make sure that the ip addresses are issued correctly: ip: 192.168.1.xxx (the last digit may vary) mask: 255.255.255.0 gateway: 192.168.1.1. If the addresses are different, then the easiest option is to restart the network card (on and off then the network will again request the addresses via dhcp), if this did not help, manually enter, for example, ip 192.168.1.2, mask: 255.255.255.0 gateway: 192.168. 1.1 and try to enter the browser again at 192.168.1.1.
Going to the web interface of the router, the tab "Settings" - "Basic Settings" - find this item:
Attached Image
Must be "DHCP server", if not, put.
The fact is that if there is a "redirection" your router will redirect the provider's IP address to your computer, that is, it will work as a switch.

ForupdatesDD-WRT already installed:

In the DD-WRT menu, select “Administration” - in the submenu, select the “Firmware upgrade” item. Click on the button “select file” and specify the firmwarewebflash.bin which was downloaded earlier. Click on the “Upgrade” button, the software update process will begin.

Options for rolling back to stock (native) firmware
Important!If you do not know how to return the stock on your router or do it for the first time, before performing any operations with the router, it is better to ask in this topic or topic visited by your router.Not all methods are universal., each router needs its own approach.
FAQ

AT: How to properly flash the router?
ABOUT:
  • Do not flash the router via WiFi; connect it to your computer with a network cable;
  • Before and after the firmware, make a hardware reset of the router (for example, "30/30/30");
  • Disable firewalls, antiviruses and ad blockers on your computer;
AT: What is "Reset 30/30/30"?
ABOUT: Press the reset button and hold it. After 30 seconds, turn off the power without releasing the Reset button. After another 30 seconds, release the Reset, turn on the power, wait until any other light on the router lights up except for the power supply, or the PC does not see the router, again we hold the Reset. Wait another 30 seconds and release the reset.

AT: How to view the system log?
ABOUT: You must first enable the syslogd service in the Services tab. (The field with the server name can be left blank.) And follow the link http://192.168.1.1/Syslog.asp, The page can be accessed only through the address bar.
If you don’t open the System Log page, then you have an old firmware version, and the log messages are written to the file / var / log / messages, which can be viewed with the commands cat, tail, more, less, etc.

AT: How to connect telnet to the router with DD-WRT?
ABOUT: Open a session in telnet client with the address of the router (by default 192.168.1.1) and the standard port (23). When prompted for a username (login), enter the standard root name - even if you changed the username to log in to the web interface. And when prompted for a password, enter the password you set for the web interface.

AT: How to load into the router not one script, but two?
ABOUT: Put the & sign at the end of the first script and load the second one. If you later need to load the third one, put the & sign at the end of the second script, etc.

AT: The Russian language does not work. Why?
ABOUT: Most likely the problem is in the firmware, the Russian works again in all releases of 2016. Also in the old stable versions.

Q: "retracker.local" stopped working, what to do?
ABOUT: It is necessary to turn off "No DNS Rebind" in the section "Services" - "Services" - "DNSMasq".

Q: Can I enable HTTPS?
ABOUT: You can, but to use it you need a special browser. Also, if you uncheck HTTP and leave only HTTPS, then you will most likely have to do a reset, since you will not access the Web GUI through a regular browser. (If you uncheck both checkboxes, you won’t go to the web interface at all)

Q: Does Universal Plug and Play (UPnP) work?
ABOUT: Yes, but you need to enable it manually, in the section "NAT / QoS" - "UPnP"

Q: I climbed in the settings and now I have a low rate of return or reception, why?
ABOUT: Most likely you have enabled "QoS", check if it is, then disable it.

Q: I set the TX Power to 20, but shows 16 dBm, why? I know for sure that the router can work on this power!
ABOUT: Perhaps the power is limited, because of the region you selected in the WiFi settings.Change to another, for example "US".

Q: TX Power has set 20 (or 21), the region is needed, but the router shows 19 dBm, why?
ABOUT: Maximum power can be obtained only on channel 6.

Q: How to set up a router in repeater mode?
ABOUT: Instruction

Q: How to reassign a burned out WAN port to a LAN?
ABOUT: We read here .

Q: How to get the maximum WiFi speed on routers with N mode
ABOUT: We read here .

Q: It is written on the official website that I lose the warranty when installing DD-WRT. This is true?
ABOUT: Theoretically, yes, but you can flash the stock, and most routers will be out of the box.

Q: I need a built-in OpenVpn, is it in this firmware?
ABOUT: Yes, but only in firmware for routers with more than 4 mb. of memory. (You can find out how much flash memory in your router model, for example, in WikiDevi )

Q: I need the router to automatically turn on and off WIFI on a schedule, DD-WRT can it?
ABOUT: Yes that's instruction

Q: DD-WRT does not allow the provider’s local resources (personal account, etc.), what to do?
ABOUT: You just need to remove one tick. instruction

Q: How to change the TTL value on the router?
ABOUT: Here is instruction

Q: How to enable multicast on DD-WRT?
ABOUT: Instruction

Q: How to make the router work as a switch, but with wifi?
ABOUT: Instruction

Q: How to make the router automatically restart at the right time?
ABOUT: Instruction

Q: If you don’t see the neighboring computers on the router’s local network (for example, on Samba)
ABOUT: Instruction

Q: I switched the language to Russian and in some places (for example, on the tab of the MAC filter of a wireless network) there are cracks.
ABOUT: Yes, this is a bug; it is very easy to overcome - by forcibly switching the page encoding in the browser to UTF-8
(for example for chrome there is an encoding menu plugin)instructionAlso, this bug is missing in the version of r27086 and earlier.

Q: How to activate the firmware on Ubiquiti routers.
ABOUT: No Only buy a license for dd-wrt on the official site. There are no working key generators.

Q: My provider has local sites in the .local zone, having trouble accessing them. How to be ?.
ABOUT: Here is instruction

Q: I need to block a site on my home network, for example, youtube. How to do it?
ABOUT: Here is instruction

Q: I heard that using dd-wrt, you can somehow access Pandora, HBO Now, Spotify, Amazon Video and Netflix outside the US without using vpn. How?
ABOUT: Here is instruction

Q: I need to get internet via wifi and distribute it as usual, that is, connect the router with a "client". Can this be done?
ABOUT: Yes that's instruction
useful links
Download DD-WRT

Topic Curator: Topic with no curator


Post has been editedstp101 - 09.06.19, 17:08



Rep: (24)
AndreyP68 @ 11/22/17, 19:13*
Here is an option with igmpproxy

This is all wrong.

Posted 11/22/2017 at 10:36 PM:

And with openwrt?

Posted 11/22/2017 at 10:38 PM:

AndreyP68 @ 11/22/17, 19:13*
I apologize in DD-Wrt, it seems there is no this ...

You need to register the ip assignment commands on the LAN and it will work. What teams - I do not know.



Rep: (219)
Kemchuk @ 11/21/17, 8:43 PM*
Question: how to allocate ip on LAN1 or LAN4 for access to iptv from Rostelecom via HD MINI prefix?

Not knowing how it is now in RT, but previously there were several connection diagrams, one of which (was checked) on the fingers:
- Specialists come from RT with their equipment (only a prefix), connect to my router as a regular client, turn it on and everything works.
- turn off their set-top box, connect another player to the LAN port of the router, take a playlist for your region, and watch everything on TV from RT (in this case, igmp proxy worked on the router, the essence of which was to transfer the resulting multi-files from the WAN port to the home network in dd- wrt this service also has this "igmprt").
play
# EXTM3U
#EXTINF: -1 group-title = "Rt" tvg-name = Rus-24 tvg-shift = 0, Rus 24
udp: //@2xxx.x.x.9: 5000
#EXTINF: -1 group-title = "Rt" tvg-name = TV100 Rus kino tvg-shift = 0, TV100 Rus kino
udp: //@2хх.х.х.70: 5000
#EXTINF: -1 group-title = "Rt" tvg-name = Sci-Fi tvg-shift = 0, Sci-Fi
udp: //@2xxx.x.x.9: 5000
...

Conclusion: in this case, the prefix is ​​connected as an ordinary client (the login / password on it is purely for the RT service), it is important that the multicasc arrived at our port (that is, it was opened on the RT equipment in our direction, everything is done when customer registration). At the expiration of the time after blocking this service in RT, this scheme has stopped working. About another scheme with a dedicated port has already been written a lot about it.
In this case, the multicast needs any IP address, RT does not give it when connected, but you can register any IP as packets from it will go to 224.0.0.0/4 (also Dual Access implies something like a provider’s network, i.e. Assign IP on WAN interface). Also, the assumption that this scheme is used is that the QCA9533-AL3A chip in your router has Atheros, usually two physics are two independent network interfaces - WAN (for example eth0) and LAN (for example eth1) or it can be vice versa. It is unlikely to select a port from eth1 (this is just vlan) and add it to the bridge to the WAN port (eth0 + vlan1).

On dd-wrt
1. need telnet
2. do the setting via WEB check through telnet:
2.1. With dual-Access PPPoE, you set IP (Advanced settings and Receive IPTV) and check the work of the Internet. The essence of this chip is in the conf file in the upstream line to specify the desired interface on which to use (vlan2 - the network interface of the WAN port with assigned IP, ppp0 - the Internet interface itself from RT)
/ tmp # cat igmpproxy.conf

quickleave
phyint vlan2 upstream ratelimit 0 threshold 1
phyint br0 downstream ratelimit 0 threshold 1
phyint ppp0 disabled
...

2.2. make the Security setting>Filter Multicast daws should not be - start the igmpproxy service that will use the conf which is higher, to determine which interface (upstream) and where to throw (downstream).
3. then according to the settings we have:
/ tmp # ps | grep igmprt
2157 root 912 S igmprt /tmp/igmpproxy.conf
/ tmp # cat /tmp/igmpproxy.conf
quickleave
phyint vlan2 upstream ratelimit 0 threshold 1
phyint ppp0 disabled
phyint br0 downstream ratelimit 0 threshold 1
phyint eth0 disabled
phyint vlan1 disabled
phyint ath0 disabled
phyint lo disabled
/ tmp # ifconfig vlan2
vlan2 Link encap: Ethernet HWaddr
inet addr: 1.1.1.5 Bcast: 1.1.5.255 Mask: 255.255.255.0
...
/ tmp #

4. there is one more important parameter Setup->Networking section Create Bridge parameter IGMP Snooping - ON / OFF start with OFF (for all clients)

Post has been editedbalian007 - 23.11.17, 09:35



Rep: (24)
I apologize in advance for the "lyrical" retreat:
I patched my TL-WR841N router to dd-wrt. Internet connected for one or two.
Web-muzzle from the drain is very different. I began to search through the windows, where to register the ip for access to the locale of RT.
Otherwise, the HD Mini prefix does not stream. The program is loading, but there is no air. When connected to a channel - a black screen on the monitor (I transfer HDMI cables from a PC and a set-top box to the monitor)
Well, go to the site of the RT. Hi Hi. I have a question: on which LAN did I connect the console?
- for the first
- it is necessary on the fourth
- OK, switched to 4
- the console is overloaded?
- not
- overload
- OK, overloaded. No ether
And here's the most interesting thing in the chat: something went wrong, sorry
About 10 years ago, techno did have RT below the baseboard, but now this is a different time.
Our local provider resells the Internet from RT.


On the drain, the master (who messed up the wires on the packet) set up a secondary connection (dual access pppoe) with ip 1.0.0.1 assignment and mask 255.255.255.248
just for the console. But, in dd-wrt there is no such option.
And yet, I changed the LAN (on the stock firmware) in places to all the nests - the prefix itself diagnoses whether or not the Internet works and works independently of any nest.
Bike about 1 and 4 LAN - this is purely "excuse" tech.

Post has been editedKemchuk - 23.11.17, 14:20



Rep: (27)
* Kemchuk
What I write now is beyond the scope of this topic. But, why don't you switch to OpenWrt?
Vlan, igmpproxy and a lot of everything delicious.



Rep: (24)
AndreyP68 @ 11/23/17, 10:06 PM*
But, why don't you switch to OpenWrt?

I switched to the old one - I got a "brick".
Through the web interface it turns out you can not flash it.



Rep: (219)
Kemchuk @ 11/23/17, 2:16 pm*
On the drain, the master (who messed up the wires on the packet) set up a secondary connection (dual access pppoe) with ip 1.0.0.1 assignment and mask 255.255.255.248
just for the console. But, in dd-wrt there is no such option.

Attached Image




Rep: (219)
AndreyP68 @ 11/23/17, 10:06 PM*
What I write now is beyond the scope of this topic. But, why don't you switch to OpenWrt?
Vlan, igmpproxy and a lot of everything delicious.

Raise vlan3
dmesg | grep switch
<6>[4.900000] switch0: Atheros AR8316 rev. 1 switch registered on ag71xx-mdio.0

swconfig dev switch0 vlan 1 set ports "0t 3 4 5"
swconfig dev switch0 vlan 3 set ports "0t 1"
swconfig dev switch0 set apply
vconfig add eth0 3
ifconfig vlan3 up
...

For RT305x chips
#! / bin / sh
switch reg w 70 68ff5067
switch reg w 44 3001
sleep 1
vconfig add eth2 3
ifconfig vlan3 192.168.0.99 netmask 255.255.255.0 up
#iptables -A POSTROUTING -o vlan3 -j SNAT --to-source 192.168.0.99
iptables -I INPUT -i vlan3 -j ACCEPT
iptables -I OUTPUT -o vlan3 -j ACCEPT
iptables -I FORWARD -i vlan3 -o vlan3 -j ACCEPT
#iptables -I INPUT -i vlan3 -m state --state NEW -j logaccept
iptables -I FORWARD -i vlan3 -o ppp0 -j ACCEPT
iptables -I FORWARD -i ppp0 -o vlan3 -j TRIGGER --trigger-type in
iptables -I FORWARD -i vlan3 -j trigger_out
iptables -I FORWARD -i vlan3 -m state --state NEW -j ACCEPT


igmpproxy
ps | grep igmprt
3767 root 912 S igmprt /tmp/igmpproxy.conf

cat /tmp/igmpproxy.conf

quickleave
phyint vlan2 upstream ratelimit 0 threshold 1
phyint ppp0 disabled
phyint br0 downstream ratelimit 0 threshold 1
phyint eth0 disabled
phyint vlan1 disabled
phyint ath0 disabled
phyint lo disabled


Other gadgets
Mounting a remote partition from a device .... 1.18 on a router and launching lighttpd
#! / bin / sh

if test -e "/mnt/Icon/lighttpd.conf";
then
if test -e "/var/run/lighttpd.pid"; then
exit;
fi
fi

Count_ping = `ping -c2 192.168.1.18 | awk '/ packets received / {print $ 4}' `;
if ["$ Count_ping" = 2]; then
if test -e "/var/run/lighttpd.pid"; then
exit;
else
mkdir / tmp / mnt / Icon;
mount.cifs //192.168.1.18/C/lighttpd / tmp / mnt / Icon -o pass = "", sec = ntlm;
lighttpd -f /tmp/mnt/Icon/lighttpd.conf; exit;
fi
else
if test -e "/var/run/lighttpd.pid"; then
killall -9 lighttpd; killall -9 php-cgi; rm -f /var/run/lighttpd.pid; umount / tmp / mnt / Icon;
exit;
fi
fi
exit;



Dnsmasq
Dhcp-option and Adblock support

interface = br0, ath0.1
resolv-file = / tmp / resolv.dnsmasq
all-servers
strict-order
cache-size = 1500
dhcp-leasefile = / tmp / dnsmasq.leases
dhcp-lease-max = 23
dhcp-option = br0,3,192.168.1.99
dhcp-option = ath0.1,3,192.168.2.99
dhcp-authoritative
dhcp-range = br0,192.168.1.120,192.168.1.122,255.255.255.0,600m
dhcp-range = ath0.1,192.168.2.10,192.168.2.21,255.255.255.0,3600m
...
dhcp-option = br0,3,192.168.1.100
dhcp-option = 6, 8.8.8.8

....
addn-hosts = / tmp / hosts0

file created from "wget ​​-O -http://www.mvps.org/winhelp2002/hosts.txt| grep 0.0.0.0 | ...... "and written to / tmp / hosts0
....
echo "addn-hosts = / tmp / hosts0">>/tmp/dnsmasq.conf
logger Restarting dnsmasq
killall dnsmasq
dnsmasq --conf-file = / tmp / dnsmasq.conf


etc.

Post has been editedbalian007 - 24.11.17, 08:59



Rep: (0)
Rebzya help please.
On the router (dir-320) there is a dd-wrt, DHCP connection, the MAC address cloning is enabled.
The Internet router itself receives (Google pings via ssh), and now how to distribute the Internet to lan and wifi?



Rep: (27)
* FrozenArt,
It is strange that you did not write at what stage it was not possible to advance in the setting further ...
Even shy to ask anything, well, what do you think I don’t know, didn’t try to do it, there’s still no result!



Rep: (0)
AndreyP68 @ 11/27/17, 5:30 PM*
It is strange that you did not write at what stage it was not possible to advance in the setting further ...
Even shy to ask anything, well, what do you think I don’t know, didn’t try to do it, there’s still no result!

* AndreyP68, Well, after the cloning of the poppy address, the Internet appeared and everything, I can not do anything further so that the Internet goes to the wifi and the PC. What I just did not try to do, I cannot find anywhere exact instructions on what to do next.

Post has been editedFrozenArt - 27.11.17, 18:48



Rep: (27)
* FrozenArt,
You know exactly what type of connection to the provider? As you used to connect to the provider.



Rep: (0)
* AndreyP68,
DHCP
the Internet on the router itself comes, I go through putty via ssh and ping google, and it responds
Previously, there was a native firmware, and it began to distribute the Internet without problems after I cloned a poppy address, but here xs what is wrong

Post has been editedFrozenArt - 27.11.17, 19:00



Rep: (27)
* FrozenArt,
Screenshots of settings you can put here?



Rep: (5)
Is there a wps function on this firmware and how can it be controlled if it is available



Rep: (516)
UXSET @ 11/28/17, 02:21*
wps function

Not.



Rep: (5)
How to assign static ip addresses on the lan network to mac address in this firmware?



Rep: (516)
* UXSET,
Services tab



Rep: (5)
And for the TPLink Archer c2 router, is this firmware available? Or whatever.



Rep: (516)
Connecting dd-wrt as a “client” wifi or get internet via wifi and distribute as usual.

If we need to get the Internet on the antenna instead of the wan port, with dd-wrt there is nothing easier.
First we need to find the network to which we will connect
Visually
Attached Image
Attached Image

After we found our network and clicked the "Attach" button, we go to the wifi settings, check that the "Client" is standing, there was the required network name, and enter the password from this network.
Visually
Attached Image
Attached Image

If everything is successful, we will see such a line on the System Information tab.
Attached Image


Almost all. Next, go to the "Settings" tab, set "WAN connection type" - DHCP and write down the DNS addresses. It is also recommended to change the address of the router from the standard 192.168.1.1, for example to 192.168.11.1
Visually
Attached Image
Attached Image

Done, now the Internet comes to us by wifi and is distributed as usual. If you also need to distribute the Internet via wifi, then you can add a "Virtual Interface" But you need to remember that the transmitter is one, so do not expect outstanding results in this mode.
Visually
Attached Image
Attached Image


Post has been editedstp101 - 01.12.17, 16:04



Rep: (219)
UXSET @ 11/29/17 00:25*
And for the TPLink Archer c2 router, is this firmware available? Or whatever.

You have on board 7620 + RTL8367RB and if you still look inhttps: //www.dd-wrt.com….php/Supported_Devicesthere is nothing to find, you can look at LEDE and also look//savagemessiahzine.com/ forum / i ... printer & f = 914 & t = 715256maybe something interesting to find.

https://wikidevi.com/wiki/TP-LINK_Archer_C2_v1.x

Post has been editedbalian007 - 29.11.17, 09:01


Full version    

Help     rules

Now: 07.15.19, 23:16