"NEXX WT3020 (A / H / F revisions) | Discussion, firmware, configuration, suggestions
Questionnaire
What firmware are you using?
Stock [ 91 ] ** [12,28%]
Openwrt [ 207 ] ** [27,94%]
Padavan ASUS Port [ 443 ] ** [59,78%]
Are you satisfied with the router? (On a five-point scale)
5 [ 472 ] ** [63,7%]
4 [ 200 ] ** [26,99%]
3 [ 56 ] ** [7,56%]
2 [ 5 ] ** [0,67%]
1 [ 8 ] ** [1,08%]
What bootloader are you using?
Stock [ 190 ] ** [25,64%]
I downloaded from the caps [ 268 ] ** [36,17%]
Put through Prometheus [ 218 ] ** [29,42%]
Other (unsubscribed in the topic) [ 64 ] ** [8,64%]
Total Votes: 741
 



Rep: (1302)
WT3020x - another representative of mini routers for working with modems and other peripherals. Despite its small size (smaller than Tp-link MR3020), it has more productive stuffing and allows you to quickly organize a mini network with Internet access and / or vpn connection to another network (office, home, etc.). The time of writing this text is available in two color compositions: black and white.
Attached Image

Specifications
  • CPU: MediaTek MT7620n (580MHz)
  • RAM: 64MB
  • ROM: 8MB (Flash chip W25Q64BV) (WT3020A - 4MB)
  • USB: 2.0 - 1 port (WT3020A - no)
  • Wired network: 2 RJ45 100Mb ports (vlan support)
  • Wireless network: 2.4 GHz 802.11n MiMo 2x2: 2 (300Mb)
  • Nutrition: 5V microUSB
  • Indication: 1 LED (extension possible by connecting to GPIO)
  • GPIO: 4 pins found on board
A photo
Attached Image
Attached Image

Attached Image

Attached Image

SSH access
It is absent in principle on the stock firmware, but there is Telnet, which does not allow transferring files to the server directly, which leads to problems with automatic firmware ... Telnet login and password:
Login:nexxadmin
Password:y1n2inc.com0755
However, the latest version of Prometheus supports firmware on the drain.

Firmware
from D-Link DIR-620 Rev.F1
Maybe someone will be interested in another absolutely working firmware from D-Link DIR-620 Rev.F1))
As usual, fill in through breed, after the first launch, we reset to factory settings. Who needs it, attaches a screen with settings for Intertelecom.
Read more here -"NEXX WT3020 (A / H / F revisions) (Fast sabian4ik # 76214075)
Padavan
Instructions for firmware router on firmware from ASUS (mod from Padavan)
This manual is intended for those who want to upgrade to the ASUS firmware (mod from Padavan).
To go, you must have the PROMETHEUS script installed and the firmware compiled, you can read about it in detail.Thisforum thread.
Because There is no SSH on the router, the installation of the firmware is complicated, because the creators of the PROMETHEUS script have prepared a solution that will facilitate the installation process reducing it to pressing a few buttons.

1. In order to flash your router using a script, it is advisable (but not necessary, since the script can sew and Telnet) to install an intermediate firmware on it, which will open access to SSH. Why do you need it? The compiled firmware may not fit into the section reserved for it, and then the router can be removed from the state of the brick only via the UART.
For A revision:
Attached filenexx_zero_a.zip(2.92 MB)


For other revisions (H and F)
Attached filenexx_zero_h.zip(2.94 MB)


Before flashing, be sure to unpack the archives !!!

The firmware is installed through the WEB interface of your router.
ATTENTION!!! This is not a full firmware, it will not give you the correct operation of the router, this file serves only to upgrade to another firmware. Almost everything is cut out of the original, you will have WIFI (password 1234567890) and an SSH server, LAN access and DHCP enabled. Everything else is removed.
Admin Screenshot
Attached Image



2. Flash UBOOT through a script, there is no need to assemble it, it is already delivered as a finished product.

3. After that you can flash the router on the assembled firmware in Prometheus, Login / Password: admin / admin, ip: 192.168.1.1.

Instructions and transient firmware provided by the userFreize , for which he thanks a lot!


Prometheus script and firmware distribution terms :
You can not distribute ready-made assembly devices for companies other than ASUS;
• You can not use the script to build the firmware with proprietary modules;
• It is strictly forbidden to distribute mods, patches and parts of the code that interfere with the above conditions.

From zyxel
I want to warn everyone that the firmware, although it starts, is from a different router and causes a number of bugs. It makes sense to use only zyxel fans or people who are too lazy to mess with other firmware.
How to flash firmware from omni
Explanations for facilitating the omni firmware
Get root and install packages
Openwrt
Download firmware from the official site
Memo for the bootloader firmware on LEDE / OpenWRT
WIKI
Modified OpenWRT by racht

Please note that the firmware can be installed via the Web interface, but OpenWRT will not allow you to change UBOOT, and the stock downloader does not support recovery via sftp or usb. It is strongly recommended that you first flash one of the loaders, otherwise you can get to the brick.

Stock firmware
Router firmware via telnet
How to flash Asus portgoldenhandles

1. Throw on the flash firmvare.trx
2. We stick the flash drive into the router
3. We go to the router by telnet, you can through putty , address 192.168.8.1
Login: nexxadmin
Password: y1n2inc.com0755
4. We enter
cd / media / sda / sda1

5. Just in case, we make a backup
for i in 0 1 2 3; do cat / dev / mtdblock $ i>mtdblock $ i.bin; done

6. We sew
mtd_write -r -e mtd3 write firmware.trx mtd3


User instruction providedFreize , for which he thanks a lot!
U-BOOT
Be sure to read (full help for loaders)
Chinese loader
Download:Attached filebreed-mt7620-reset1.rar(74.75 KB)

Please note that with unsuccessful firmware will be a full brick!
1. Throw on the flash drive breed-mt7620-reset1.bin
2. We stick the flash drive into the router
3. Go to the telnet router (see above)
4. We enter
cd / media / sda / sda1

5. Just in case, we make a backup
for i in 0 1 2 3; do cat / dev / mtdblock $ i>mtdblock $ i.bin; done

6. We sew
mtd_write -r -e mtd0 write breed-mt7620-reset1.bin mtd0

U-BOOT for ASUS port
Attached fileuboot.7z(49.95 KB)
MD5: 3226b91d287d3401f1534a220e7396f2
Installation is similar to the neighbor above,just do not forget to unpack !
Instructions for restoring firmware:
1. Copy to the root of the first section of the USB Flash disk (usb 2.0), pre-formatted (ie, empty) in FAT16 / FAT32, the firmware image, while renaming the file to "root_uImage" (without quotes and extensions, BUT case sensitive );
2. Turn off the power of the router (pull out the power cord from the router);
3. Insert the USB flash disk into the USB port of the router;
4. Clamp the RESET button and turn on the router (we plug the power cord into the router) without releasing the RESET;
5. WAITING, the flash drive will start blinking (if there is an indicator on it), after a couple of minutes of holding, release the RESET;
5. After some time, if the indicator of the router does not change color to blue, restart it, the firmware will load. If it does not, check the USB flash drive or pick up another one.

Free GPIO
Other
Information unit in binary numbering system GOST 8.417-2002 GSI
bit2(bit) - amount of information 1 (usually used to denote the connection speed and the amount of information transmitted);
byte2,3 - amount of information 1 equal to8bit (usually used to denote the amount of data on the media).

1) The term “amount of information” is used in devices for digital processing and transmission of information, for example in digital computing (computers), to record the amount of storage devices, the amount of memory used by a computer program.
2) In accordance with the international standard IEC 60027-2, the “bit” and “byte” units are used with SI prefixes.
3) Historically, there is such a situation that the name “byte” is incorrect (instead of 1000 = 103accepted 1024 = 210) used (and use) SI prefixes: 1 Kbyte = 1024 bytes, 1 MB = 1024 Kbytes, 1 Gbytes = 1024 Mbytes, etc. At the same time, the designation Kbytes start with a capital letter unlike the lowercase letter “k” to designate a multiplier ten3.
Version difference
A = 4 MB flash - no USB

AD, H, F are absolutely identical devices, the only difference is in the firmware that comes from the factory with the Chinese and English interface
The base of modems for support is increased in the H version compared to F
AD didn’t feel, but I suspect that they added some dLNA / UPNP thread, and I didn’t see it on sale, and I don’t see any reason to overpay for something that can be implemented with alternative firmware (I still make backups with the stock programmer and sew everything my heart desires)

What does the F model show that at some point in time (during the merging of Lede with OpenWRT, in version 17.01.2-17.01.3) the firmware stopped loading, I suspect that they changed something in the hardware, and specifically something was namut in the core with support for the SPI interface on which the entire firmware sits
But in recent versions of OpenWRT this problem is not noticed.

I checked it very simply, two devices purchased with a difference of 1 year on native Flash-ah, the same firmware was launched on one, and not on the other.
after updating OpenWRT to version 17.01.4, the firmware compiled with the same configuration worked on both devices


Post has been editedAndrewP_1 - 17.08.19, 13:35
Reason for editing: As on a subject with installed padawan, fix ttl



Rep: (1)
* Vech , Yes, I downloaded this putty, tried to connect, there are a lot of things, where to click? I do not do this every day, I asked for help, if you can’t why then write what is easier and what is more difficult.



Rep: (478)
* maxim-851,
run putty
enter ip
press the open button
Login: Password

much easier ?!

and that’s all, you are in the console, then the team

do not be lazy, took up a router with Linux on board, study at least ssh / telnet and the minimum set of commands

Post has been editedVech - 07.10.17, 11:08



Rep: (1)
* Vech , Why after entering the password does Access denied write?



Rep: (478)
* maxim-851,
root login
the password is the one that was set via the web face

(although FIG knows what kind of firmware you have there), the firmware collector may have wound up his firmware, I’m not a telepath and I don’t guess on coffee grounds

it's hard to ask google for: ssh access denied
?

Post has been editedVech - 07.10.17, 11:51



Rep: (1)
* Vech Where can I see the password?



Rep: (478)
* maxim-851,
I don’t guess on the coffee grounds and I’m not a telepath
VecH @ 10.10.17, 17:30*
(although FIG knows what kind of firmware you have there



Rep: (1)
* Vech , the firmware is 3.4.3.9-099_19224e2



Rep: (1)
* Vech , apparently I still went to the server. How to enter commands now?



Rep: (478)
* maxim-851,
fingers on the keyboard

are you kidding?!, have already laid out everything on the shelves, still learn how to press buttons, thereby typing commands ?!


Posted on 10/07/2017, 12:56:

Maxim-851 @ 07.10.17, 18:06*
firmware costs 3.4.3.9-099_19224e2

I do not know such firmware

the question was what kind of firmware, and not what kind of kernel is there



Rep: (1)
* Vech , the fact is that when you enter any command, it says not found

Posted on 10/07/2017, 13:06:

* Vech , Stop getting smart, I say that I’m doing this for the first time and I don’t know what and where, I am interested in the end result and not the process itself. Just help and that’s it.



Rep: (478)
stop cutting, you can’t figure it out for yourself, give all the information so that others can

copy EVERYTHING here
I do not see where you enter
what do you enter
and what command the router sends you to not found

I have to write more to you than you have questions
should be exactly the opposite, write everything that is necessary and not necessary, so that helpers do not have to ask extra questions



Rep: (478)
Maxim-851 @ 10/07/17, 19:05*
Stop getting smart, I say that I’m doing this for the first time and I don’t know what and where, I am interested in the end result and not the process itself. Just help and that’s it.

I'm not smart, but I foresee that an increase in WiFi speed between the router and the client is still a flower (for Megafon 150-2 / Huawei e3372h itself)

I roughly predict that we will be raking for a long time:
- in what mode does your USB whistle work
- then at what frequency / mode does it work
- still touch how to climb from the console of the router to the modem console
- and I really hope that you do not have to reflash the modem

Learn in advance that you would understand what you are doing, I don’t want to work as a remote keyboard here, and even more so with crooked eyes to watch (do not describe in detail what and how you are doing, in extreme cases, screen shots) what is going on there

I think that by raising the speed of WiFi, my dialogue with you will be finished, then you’ll get there yourself somehow

p.s.I just give a fishing rod and learn how to fish, a person will be able to feed themselves
than every time you run to him and for him to catch and carry fish


Post has been editedVech - 07.10.17, 13:15



Rep: (1)
* VecH,
Here is what I see after entering the login and password in putty, should it be?

Attached images
Attached Image



Rep: (478)
1. show the main page of the web muzzle (after entering the login and password), it is not clear with what firmware we are now messing with

2. Also in this black window show the command response: ls -al / etc / config / wireless



Rep: (1)
* Vech , don’t worry, I have already done all of the above, only this remains!



Rep: (1)
VecH @ 10.10.17, 14:27*
1. show the main page of the web muzzle (after entering the login and password), it is not clear with what firmware we are now messing with

2. Also in this black window show the command response: ls -al / etc / config / wireless


Attached images
Attached Image
Attached Image



Rep: (1)
maybe there is some alternative way to enter these commands?



Rep: (478)
This is firmware from ASUS, unfortunately I had no business with it, I have OpenWRT / LEDE (it is easier to carry out all the manipulations there)



Rep: (58)
* maxim-851 , after ls there should be a space (i.e. ls -la, and after a space the path to the folder or file you want to see)



Rep: (1)
The question of increasing the transfer speed via wi-fi channel with ASUS firmware from PADAVAN remains open for me. Who is how to increase the transmission speed - please share your experience?


Full version    

Help     rules

Now: 08/26/19, 10:19