TP-LINK TL-WR842ND - Discussion | [wifirouter] Discussion, firmware, problem solving



Rep: (15)
TP-LINK TL-WR842N / ND- Discussion
Attached Image
The forum decided to post images under the spoiler Attached Image

A photo:
Attached Image
Attached Image

Description:
TL-WR842ND is an N-series multifunctional wireless router with data transfer rates up to 300 Mbps, which guarantees uninterrupted HD video streaming, online games, Skype calls and fast file transfer over a local network. The multifunctional USB port provides convenient work with the printer wirelessly, as well as the ability to configure the FTP server. The guest network provides separate access to your network for guest users, and the VPN tunnel function can provide security when transferring data between multiple local networks.
Specifications:
  • Wi-Fi speed - up to 300 Mbps
  • Wireless Standards - IEEE 802.11n / g / b
  • Frequency range - 2,400 - 2,4835 GHz
  • Interfaces - 4 10/100 Mbps LAN ports, 1 10/100 Mbps WAN port, 1 USB 2.0 port
  • Buttons Button - WPS / Reset (WPS function / reset), Wi-Fi ON / OFF button (on / off wireless broadcast)
  • Antennas - 2 removable omnidirectional antennas with 5 dBi gain
  • USB functions - Data storage / FTP / Media / Print server / 3G / 4G connection
  • Wireless Network Security - WEP, WPA / WPA2, WPA-PSK / WPA2-PSK Encryption, MAC Address Filtering
  • Additional functions - NAT (network address translation), VPN traffic transmission (PPTP / L2TP / IPSec), SPI firewall, access control, 5 IPsec VPN tunnels, guest network
  • Food - 12 V post. current / 1 A
  • Dimensions - 192 x 130 x 33 mm
Firmware
Instructions:
Complete User Guide:
Restore or replace the router software:
  • 1. If there are no problems for users when switching from official to alternative firmware, an attempt to replace one alternative firmware with another may cause difficulties. For example, if you want to replace OpenWRT with DD-WRT (and other combinations), you will need to roll back to the factory software from the web interface and then upgrade to the desired one.
  • 2. This router is practically not killed (in terms of experiments with software), but a situation may arise when it is necessary to recover, but there is no access to the web interface. Then we do this (an example for revision v2, therefore the files are substituted for the revision corresponding to yours):time, two, three. Firmware for recovery via tftpd revision 3.
  • 3. Ways to replace the router software

3G / 4G USB Modem Compatibility Chart(stock software).
3G Backup Channel Setup(OpenWRT).
Examplerestore and configure the router (ver.1) with Gargoyle, NDIS modem (3372) + unlimited bonuses ;-)
Replacing the radiator in the TL-WR842ND v1
Connect OpenWrt / LEDE as a wifi client
DD-Wrt connection as a wifi client
We raise 4G connection on Openwrt
Differences from the team building ofmodemsandmen from openwrt
Collection of tips

The curator of the topic isN.o.F.a.c.e.


Post has been editedN.o.F.a.c.e. - 06.07.19, 13:32
Reason for editing: Firmware for returning to stock



Rep: (831)
* Basyr Does a dump occur when devices are connected via air?
Does the console from the console work through bluetooth?

Post has been editeddjmrmore - 06.10.18, 09:33
Reason for editing: Added



Rep: (1)
Yes, it’s through the air. No, stock IR remote.

There are some considerations, it may still fall off because Himedia is dual-band 2.4 GHz and 5 GHz. Maybe it somehow influences?

Post has been editedBasyr - 06.10.18, 09:42



Rep: (831)
* Basyr I have mybox. The same problem was. Remote with bluetooth. I decided it by installing ddwrt, expanded the channel to 40 MHz and chose the region of Japan. The version of router 2 is the same as yours. The scheme worked stably, then it was necessary to connect the joystick, I ordered a yugrin ethernet adapter from China to check it, I hooked up a prefix to it and stayed on it. By the way, your console supports 5 GHz. Replacing the router is also a solution.

Upd The most important did not write. Bluetooth very much interferes with the work of WiFi at 2.4 if next to the router.
Attached Image
Attached Image



Post has been editeddjmrmore - 06.10.18, 09:52
Reason for editing: Added and added



Rep: (1)
I see. Thanks! Just already thoughts are being visited to replace the animal with 5 GHz Wi-Fi. At one time, when I was doing repairs in the apartment, I had to forward wires to the maximum: at least to the computer and to the player ... Now it's too late.

But I’ll try to change the settings, you see, it will at least work a little.
So I liked the router, it worked very stably before that, no problem for 2.5 years, and here with the change of the media player, dances with tambourines began.

Post has been editedBasyr - 06.10.18, 09:55



Rep: (0)
Good time. There is a TL-WR842ND v1 and huawei e352b (megaphone). I would like to cross and get a wi-fi router with a 3g modem and vpn support at the output. What firmware can I try? Thank you in advance.



Rep: (1)
please tell me, is V5 compatible with awus036nhr v2 on RTL8188RU?

Post has been editedgarbo - 09.10.18, 14:07



Rep: (0)
I walked through WiFi 842v1, openwrt, does not see WiFi and can not enter through the wire at 192.168.0.1, can I do something or is it a brick?



Rep: (16)
* barish,
192.168.1.1 necessary



Rep: (0)
The same does not go



Rep: (127)
Tell me which 64 MB memory chips are suitable for v.1 .. Maybe share a link ...


TP-LINK TL-WR842ND - Discussion (Post by shchelkynchik # 74961212)

Post has been editedkirandy - 09.10.18, 14:32



Rep: (6)
I bought myself a TL-Wr842n v3 (I read on the forum that it is much better). installed firmware from # Vovan26
But I can’t make friends with OpenVPN with Zaborona-help.
Before that I used 841Nd, everything worked out there.
Can someone tell me how to do this, or can anyone have a ready-made firmware with a fence sewn into it, as it was on my last router?

The most interesting thing that I set up by analogy is that “VK” is launched on the phone, but it doesn’t want to on the laptop (both devices are powered via wi-fi)

Post has been editedLinkIF - 10.10.18, 08:38



Rep: (152)
* kirandy , it’s hard to say, you can look at the microcircuit by datasheets, but it is not clear how to find out the model in the opposite direction, each memory manufacturer has microchips marked differently. You just need to find the memory strips ddr1 (sdram) and look at the model of the microcircuit on it, and then look for the datasheet for this model, you need 64 MB (64 × 8 Mbit) volume and a bus frequency of at least 250 MHz (with such a frequency original microcircuit).



Rep: (127)
* v111v111 ,
* shchelkynchik ,
It is enough to just search a bit on the internet. Here:
http://cyber-place.ru/...hread.php?t=384&page=2
just discuss modding TP-Link routers. And on the 2nd page admin writes:
We increase the amount of RAM memory to 64 mb on the TP-LINK MR3020 and WR703N routers

TP-LINK MR3020 and WR703N routers use a Zentel A3S56D40FTP DDR1 16Mbit x 16bit memory chip (16 * 16 = 256 Mbit. 256/8 = 32MByte) 400 MHz.
It can be replaced with any 32Mbit x 16-bit chip. 333 instead of 400 MHz and the router will work fine. The truth is now quite difficult to find such chips. You need to look for a laptop strap memory DDR-SODIMM.

Proven memory chips:
Hynix HY5DU121622DTP-D43 (Mustang DDR-SODIMM 512 MB card)
Hynix HY5DU121622CTP-D43 (Hynix SODIMM DDR-PC2700S-25330 on 512MB DDR 333 CL 2.5, 400 MHz chips are compatible with the "D43" marking).
Infineon HYB25D512160BE (512 MB Infineon DDR-SODIMM bar)

Not tested bars, but theoretically they should work:
PC400 HY5DU121622DTP-D43-C Hynix
PC400 H5DU5162ETR-E3C Hynix
Samsung PC400 K4H511638G-LCCC
Samsung PC400 K4H511638J-LCCC
PC400 A3S12D40ETP-G5 Zentel
PC400 NT5DS32M16BS-5T Nanya
PC400 P3S12D40ETP-GUTT Mira
PC333 MT46V32M16TG-6T: F Micron
PC333 MT46V32M16P-6T: F Micron
PC333 EDD5116ADTA-6B-E Elpida
PC333 HYB25D512160CE-6 Qimonda
PC333 HYB25D512160CEL-6 Qimonda
PC333 HYB25D512160DE-6 Qimonda

The field for replacing the memory chip, the router itself must determine the new amount of RAM 64mGB.

You can, of course, search and compare datasheets, but it's long and dreary!

Post has been editedkirandy - 10.10.18, 17:08



Rep: (6)
LinkIF @ 10.10.18, 07:38*
I bought myself a TL-Wr842n v3 (I read on the forum that it is much better). installed firmware from # Vovan26
But I can’t make friends with OpenVPN with Zaborona-help.
Before that I used 841Nd, everything worked out there.
Can someone tell me how to do this, or can anyone have a ready-made firmware with a fence sewn into it, as it was on my last router?

The most interesting thing that I set up by analogy is that “VK” is launched on the phone, but it doesn’t want to on the laptop (both devices are powered via wi-fi)


It seems that everything was decided successfully, after Mr. Herzz recommended updating with the latest firmware from openWrt.
Perhaps this information is useful to someone.



Rep: (0)
Filled openwrt but something through the web interface I can not turn on / off the router ports, which are yellow, not wan ports. It appears that the cable is not connected to them, although in fact devices are connected in all ports. Is it easier to configure via telnet than via the web interface?



Rep: (127)
Good night all. A question. I bought a v5 router, installed OpenWRT firmware on it from here:
TP-LINK TL-WR842ND - Discussion (Post by gazrh # 74798878)
But unfortunately, I could not configure the Huawei E3372H modem on it, the one that Huawei, without reference to the operator. For some reason, my modem sits on the Eth1 interface, and not on USB.
Well, the question is different. I tried to roll back to the original firmware first from this post:
TP-LINK TL-WR842ND - Discussion (Post by Vladjket # 75187439)
I sewed through TFTP, the firmware is going fine. But after the firmware, the router does not boot, it blinks with all the indicators about once a second, and the Internet indicator changes its color from green to orange immediately. Okay, I think maybe the firmware is not the same. I found here another firmware for the stock (sorry, right now I'm too lazy to look for the link). The same nonsense, indicators also blink. I downloaded all three firmware from the site’s site for this router, using the DD utility, I cut boot from them, the first 512 bytes. But always the same after the firmware - all indicators blink! Why? The bootloader has changed or something, explain to me please! And how to replace boot now? Or what am I doing wrong? I ask for help!



Rep: (411)
Firmware for recovery and rollback 842v5.
Attached filetp_recovery.zip(7.55 MB)

P.S. It is advisable to raise the "cap".
Verified bykirandy
TP-LINK TL-WR842ND - Discussion (Post by kirandy # 77874304)

Post has been editedvovan26_ - 12.10.18, 10:31



Rep: (127)
* vovan26_ ,
Thanks, I'll try now!
Sew via TFTP?

Post has been editedkirandy - 12.10.18, 00:00



Rep: (411)
Kirandy @ 10/12/18, 01:57*
Sew via TFTP?

Yes.



Rep: (127)
Vovan26_ @ 12.10.18, 1:56*
Firmware for recovery and rollback 842v5.tp_recovery.zip (7.55 MB)

Does not flash! Network address should be 192.168.0.225? Only this address should for firmware v5!

P.S. I looked at the firmware file, the addresses seem to be correct
Attached Image

And in the network settings the address is the same
Attached Image

HZ, why does not want to flash, 5 times I tried! Before that, all the firmware was uploaded ... Curved firmware?

Post has been editedkirandy - 12.10.18, 02:01


Full version    

Help     rules

Now: 08/26/19, 10:21