6 pagesV  1 2 3 4 5 6 > »  
 
REPLY
> VOYO A1 MINI - Install Linux | - 8 '' | Intel Bay Trail Z3735D (F) | 2GB | WiFi, BT -
evgen-y2k
Message#1
06.12.14, 11:23
Local
*****
[offline]

Group: Friendssavagemessiahzine.com
Messages 217
Check in: 11.08.09
Lenovo P780

Reputation:-  14  +

Linux on VOYO A1 MINI
In this topic, we discuss the features of running Linux-systems on our device.
Description | Discussion » | Buying and Accessories » | Voyo WinPad A1
Ubuntu linux » | Windows 8-8.1 » | Windows 10 » | Windows RT and software » | Games for tablets on Intel Bay Trail » | Windows 7 » | Change the operating system » | Search programs » | Antivirus » | Ambulance laptop owners » | IT smoker » | Operating systems and software

Specifications
Intel Bay Trail Z3735D (F), 8 inch 1280x800 IPS multitouch, 2Gb RAM, 32Gb eMMC, MicroSD, WiFi, BT, Bat. 5000 mAh
additional information


Post has been editedShoore - 06.12.14, 16:14
evgen-y2k
Message#2
06.12.14, 11:31
Local
*****
[offline]

Group: Friendssavagemessiahzine.com
Messages 217
Check in: 11.08.09
Lenovo P780

Reputation:-  14  +

Good day!
Thanks for the experiment with running linux.
To gwin pin:
Did you start the system with the kernel parameter i915.modeset = 1 or by default? If with a parameter, it turns out that two people (including me) have a problem with initialization, and one (you) does not have a problem.
Now for everyone:Please check your device versions. I have a Z3735D, but the VOYO A1 MINI is also available with the Z3735F. In theory, they are the same and differ only in the type of case of the chip and max. temperature, respectively, but still who knows what really.
Further. Trying to get rid of errors when loading. To do this in the BIOS do this:
BIOS changes and kernel options
Let's go advanced =>LPSS & SCC Configuration and set
LPSS & SCC Device Mode = ACPI Mode (should be the default, but I don’t remember how it was)
SCC eMMC Support = Enable eMMC 4.41 Support
eMMC Secure Erase = Disable
SCC eMMC 4.5 DDR50 Support = Enable
SCC eMMC 4.5 HS200 Support = Disable
LPSS PWM # 1 Support = Disable
LPSS PWM # 2 Support = Disable
everything else = Enable

Changing these parameters does not affect the loading of Windows.

Kernel parameters to insert into grub.cfg:
i2c-designware-platform.force_std_mode = 1 i915.panel_ignore_lid = 0 video.use_native_backlight = 1 i915.modeset = 1 i915. / sd [your swap partition] nosplash quiet showopts

Also, please try changing the parameter i915.modeset = -1 and boot.
At the first boot after changing the BIOS settings, it can also be streamed with I / O errors, but then everything loads fine. My core really swears even on watchdog, but this is not critical.
After downloading, try using xrandr to rotate the screen. If the driver is correct and everything is fine, then the command (in the terminal) xrandr -o left (or indices 0,1,2,3 can be used instead of left | right, etc.) will rotate the screen.
On the results of unsubscribe.
Gwin pin
Message#3
06.12.14, 15:45
Visitor
**
[offline]

Group: Active users
Messages 23
Check in: 27.04.14

Reputation:-  3  +

You said it with all the responsibility? After changing the BIOS, my device turned into a brick. Now I will try to reset the settings blindly.

evgen-y2k @ 06.12.2014, 11:23*
LPSS PWM # 1 Support = Disable

This item causes me great doubts. It is a pity that these doubts came to me when it was too late.

Post has been editedGwin pin - 06.12.14, 15:48
evgen-y2k
Message#4
06.12.14, 17:32
Local
*****
[offline]

Group: Friendssavagemessiahzine.com
Messages 217
Check in: 11.08.09
Lenovo P780

Reputation:-  14  +

I say onlywhat did you do. Possible problems with changing BIOS settings are known to me (stepping on this rake BEFORE reading the information on the forum). That's how I got everything. If the device is worn out by changing these parameters, then your and my BIOS are different. If you doubt my words, I can upload a video with the inclusion of my device and the entrance to the BIOS and further to the section with these parameters. Believe me, I do not pursue the goal of ruining someone's tablet.
You did not answer my question about the first launch of Linux. Did you run with the parameter i915.modeset = 1 or not?

Post has been editedevgen-y2k - 06.12.14, 17:39
Gwin pin
Message#5
06.12.14, 19:08
Visitor
**
[offline]

Group: Active users
Messages 23
Check in: 27.04.14

Reputation:-  3  +

In order.
I have a version of "F"
Launched with the parameter i915.modeset = 1. Without parameters, the screen does not glow at all. When nomodeset is loaded as I described
Gwin Pin @ 12/02/2014 00:45*
Screen 800x600 in the "standing" position. Can not rotate.

The BIOS was as indicated by you, except for:
SCC eMMC Support = Enable eMMC 4.5 Support
SCC eMMC 4.5 HS200 Support = Enable
LPSS PWM # 1 Support = Enable

evgen-y2k @ 06.12.2014, 17:32*
(attacked this rake BEFORE reading the information on the forum).

And how did you get out of the situation? And then everything is somehow worse than I first thought. The tablet is not completely scorched. The power indicator is on and the USB seems to be working. But you can not reset the settings blindly.
manly_m
Message#6
06.12.14, 21:41
Experienced
******
[offline]

Group: Friendssavagemessiahzine.com
Messages 669
Check in: 10.11.09

Reputation:-  40  +

evgen-y2k @ 06.12.2014, 11:31*
Kernel parameters to insert into grub.cfg:
i2c-designware-platform.force_std_mode = 1 i915.panel_ignore_lid = 0 video.use_native_backlight = 1 i915.modeset = 1 i915. / sd [your swap partition] nosplash quiet showopts

Also, please try changing the parameter i915.modeset = -1 and boot.

All the same.
i915.modeset = 1, i915.modeset = -1 bright bands on a dark screen. Sometimes at the same time, after a reboot, artifacts remain in the form of a flickering in the middle of the screen, which disappears with time.

The only thing that ruled out is resume = / dev / sd [your swap partition] because there is no linux swap partition on the flash drive.
I did not change the eMMC parameters in order to avoid, I think the eMMC settings should not affect the download from the Live CD (if wrong, correct it).
As far as I remember, Ubuntu 14.04.1 loaded without such errors.

evgen-y2k @ 06.12.2014, 11:31*
Please check your device versions.

I have a twin brother PIPO W2 Z3735D. Insignificant differences only in the rear camera OV5648, and charging 5V 2A.

Bios
Core version 5.008
Project Version V3.1.5
EC FW Version 201407178A
manly_m
Message#7
06.12.14, 21:58
Experienced
******
[offline]

Group: Friendssavagemessiahzine.com
Messages 669
Check in: 10.11.09

Reputation:-  40  +

Gwin Pin @ 12.6.2014, 15:45*
LPSS PWM # 1 Support = Disable

This item causes me great doubts. It is a pity that these doubts came to me when it was too late.

If our items match, try to include:
Del
в†’ 1 time
↓ 5 times
Enter
↓ 10 times
Enter
PgUp (for reliability)
Enter
F4
Enter

Post has been editedmanly_m - 06.12.14, 22:02
evgen-y2k
Message#8
08.12.14, 07:37
Local
*****
[offline]

Group: Friendssavagemessiahzine.com
Messages 217
Check in: 11.08.09
Lenovo P780

Reputation:-  14  +

to gwin pin
Hello. Did you manage to lift the tablet?
When I had problems with the bios, I could see it by connecting via HDMI to the TV. What is strange, before HDMI started to work only after loading Windows. Try it, maybe it will help you if you have not solved the problem yet.
Now further on the topic. Here are a couple of documents that I dug. Perhaps they will be useful to us.
IntelВ® Atom в„ў E3800 Building
Processor Development Kit Yocto
Project * Board Support Package
(Bsp)

And the second:Bay Trail Yocto project
Actually the information in these documents confirmed the correctness of the vector I chose :)
Look, comment.
evgen-y2k
Message#9
08.12.14, 11:24
Local
*****
[offline]

Group: Friendssavagemessiahzine.com
Messages 217
Check in: 11.08.09
Lenovo P780

Reputation:-  14  +

Guys, have a couple of ideas.
1. Try to build the latest LTSI branch. May shoot. WatchHERE
2. Try running the Angstrom build for MinnowBoard. TakeHERE
What is Angstrom lookHERE
Well, the Yocto project has not been canceled.

I now have no opportunity to actively participate in the process, because I am in Iraq. Communication is problematic and the time is only for work :(
Therefore, I rely more on your experiments in the next 2 weeks.
Gwin pin
Message#10
09.12.14, 01:10
Visitor
**
[offline]

Group: Active users
Messages 23
Check in: 27.04.14

Reputation:-  3  +

evgen-y2k @ 12/08/2014 07:37*
to gwin pin
Hello. Did you manage to lift the tablet?
When I had problems with the bios, I could see it by connecting via HDMI to the TV.

I have very bad time now. Constantly on the road. Before the weekend I can not get to the tablet.

About HDMI, I also thought. And your message confirms that I thought correctly. But in a quick cable could not be found. Actually, I'm not going to do anything else until I get a cable and try this option. Well, if it does not help, you probably have to sew.


About the rest. Tempting of course. But before the New Year holidays just can not connect. Yes, and the baggage of theoretical knowledge on the subject need to replenish.
manly_m
Message#11
10.12.14, 00:17
Experienced
******
[offline]

Group: Friendssavagemessiahzine.com
Messages 669
Check in: 10.11.09

Reputation:-  40  +

evgen-y2k @ 12/08/2014, 11:24*
2. Try running the Angstrom build for MinnowBoard. Take HERE

Unrolled the image of Angstrom-development-GNOME-image-glibc-ipk-v2014.12-minnow.hddimg.xz on a USB flash driveof this instruction.

Bottom line: not loading.
Upon closer examination, it turned out that the flash drive does not have a boot flag, and it cannot be installed.
evgen-y2k
Message#12
10.12.14, 08:46
Local
*****
[offline]

Group: Friendssavagemessiahzine.com
Messages 217
Check in: 11.08.09
Lenovo P780

Reputation:-  14  +

to manly_m:
Tell me please, is there a small FAT32 partition with daddies / EFI / BOOT on the flash drive?
And if there is, is there a bootia32.efi loader or something nice in it?
Most likely the system does not boot due to the lack of a 32-bit loader. Please note that the resource from which you downloaded the image separately contains the gummibootia32.efi file, which is the bootloader.
In general, sometimes in this direction. There will be difficulties - ask. By the way, the boot flag for UEFI is not critical. The obligatory presence of GPT is also not required in case of our device, the presence of a FAT32 partition on the storage medium and having the appropriate folders and files is enough. Today I will try to put the download image at night. Well if you can download ...

Post has been editedevgen-y2k - 10.12.14, 09:00
evgen-y2k
Message#13
10.12.14, 13:15
Local
*****
[offline]

Group: Friendssavagemessiahzine.com
Messages 217
Check in: 11.08.09
Lenovo P780

Reputation:-  14  +

News:
today posted a new buildFedlet: a Fedora Remix for Bay Trail tablets
You can also try. Download link:Tyts
manly_m
Message#14
10.12.14, 21:59
Experienced
******
[offline]

Group: Friendssavagemessiahzine.com
Messages 669
Check in: 10.11.09

Reputation:-  40    +

evgen-y2k @ 12/10/2014, 08:46*
Tell me please, is there a small FAT32 partition with daddies / EFI / BOOT on the flash drive?
And if there is, is there a bootia32.efi loader or something nice in it?

The folder is there, the file is also present.
evgen-y2k @ 12/10/2014, 08:46*
Please note that the resource from which you downloaded the image separately contains the gummibootia32.efi file, which is the bootloader.

This file is the same as the image. At least in size in bytes, they match.
I tried to replace bootia32.efi from asus T100, it loads to minimal bash.

evgen-y2k @ 12/10/2014, 13:15*
today posted a new build of Fedlet: a Fedora Remix for Bay Trail tablets
You can also try.

Ok, I'll try.
evgen-y2k
Message#15
12.12.14, 07:32
Local
*****
[offline]

Group: Friendssavagemessiahzine.com
Messages 217
Check in: 11.08.09
Lenovo P780

Reputation:-  14  +

I tried Fedlet. Pleasant impression. It works sound, touch, sees the status of the battery and the connected charging (applied patches from the LTSI branch). WiFi with bluetooth does not work, you need to collect the driver. The cameras don't work either. The situation with the video is exactly the same as on other distros. The i915 driver correctly starts an average of one out of five. I can not understand what the problem is with our (or my specific) device. If the driver starts but the picture fails, there are no errors in the logs, everything is correct. It seems that all conceivable options and combinations of the BIOS and the parameters of the kernel went through, but to no avail. Ideas and thoughts ran out. I would be glad of any idea or advice.
Reassembled the kernel under Suse. With the video, the problem remained.
evgen-y2k
Message#16
12.12.14, 13:21
Local
*****
[offline]

Group: Friendssavagemessiahzine.com
Messages 217
Check in: 11.08.09
Lenovo P780

Reputation:-  14  +

Guys, it seems something looms.
Below is a list of kernel parameters in which I get the correct load about once every 1.17 and 1.18 kernels.

i2c-designware-platform.force_std_mode = 1 video.use_native_backlight = 1 i915.modeset = 1 i915. enable_fbc = 1 i915.enable_rc6 = 1 acpi_backlight = vendor acpi_osi = Linux acpi = force acpi_enforce_resources = lax drm.vblankoffdelay = 1 reboot = pci, force nosplash quiet showopts

Please write down the results
These 2 parameters are questionable. Included both so far: video.use_native_backlight = 1 and acpi_backlight = vendor

Post has been editedevgen-y2k - 15.12.14, 07:42
Reason for editing: Fixed an error in the parameter string
manly_m
Message#17
12.12.14, 18:09
Experienced
******
[offline]

Group: Friendssavagemessiahzine.com
Messages 669
Check in: 10.11.09

Reputation:-  40  +

Evgen-y2k @ 12.12.2014, 07:32*
I tried Fedlet. Pleasant impression.


I still can not start. When starting by default, stripes appear on a dark background, disappear after a few seconds, a circle appears with slices that are added as they are loaded. At this all stops.

I tried to add the kernel parameters as you wrote above, with them when loading the kernel panic pops up.

I added these options to /EFI/BOOT/grub.cfg

}
menuentry 'Test this media & start 20141209 Fedlet' --class fedora --class gnu-linux --class gnu --class os {
linuxefi / isolinux / vmlinuz0 root = live: LABEL = 20141209-fedlet-i686 ro rd.live.image quiet rhgb rd.live.check
initrdefi /isolinux/initrd0.img i2c-designware-platform.force_std_mode = 1 video.use_native_backlight = 1 i915.modeset = 1 i915.enable_fbc = 1 i915.lvds_downclock = 1 i915.semaphores = 1 video = DSI-1: chi-1 chd = 1, ids151ds_downclock = 1 i915.semaphores = 1 video = DSI-1 i915.lvds_downclock = 1 @ 75e acpi_backlight = vendor acpi_osi = Linux acpi = force acpi_enforce_resources = lax drm.vblankoffdelay = 1 reboot = pci, force nosplash quiet showopts
}


Right?
evgen-y2k
Message#18
12.12.14, 18:17
Local
*****
[offline]

Group: Friendssavagemessiahzine.com
Messages 217
Check in: 11.08.09
Lenovo P780

Reputation:-  14  +

1. You did not insert a string with parameters there. It is necessary to add it to the linuxefi / isolinux line ...
2. I corrected a typo in the previous post and inserted a forgotten parameter. Try again.
Yes, and to see the process of loading the ESC button on the keyboard when a circle appears with slices :) So you can see what the download is shutting down

Post has been editedevgen-y2k - 12.12.14, 18:38
Gwin pin
Message#19
14.12.14, 12:59
Visitor
**
[offline]

Group: Active users
Messages 23
Check in: 27.04.14

Reputation:-  3  +

Evgen-y2k @ 12.12.2014, 07:32*
The situation with the video is exactly the same as on other distros. The i915 driver correctly starts an average of one out of five.

This is, incidentally, not like inthis postlooks like Then it turns out that the reason is not Linux at all.

I have a dead number. connected via HDMI to the TV. Shows the BIOS screen saver, does not respond to the keyboard. :(

Theoretically, there should be a non-soldered COM port. We must try to connect it to Claudia.

Post has been editedGwin pin - 14.12.14, 13:02
evgen-y2k
Message#20
14.12.14, 13:23
Local
*****
[offline]

Group: Friendssavagemessiahzine.com
Messages 217
Check in: 11.08.09
Lenovo P780

Reputation:-  14  +

No not like this. The post is clearly a problem with the DSI is visible. What is this interface you can lookHERE
A watersHEREI posted a video with our problem filmed
vivalenta0
Message#21
14.12.14, 16:05
Visitor
**
[offline]

Group: Active users
Messages 20
Check in: 16.02.09
Xiaomi Redmi Note 3 Pro Standard

Reputation:-  0  +

and so I understand ubuntu we can not see?
Voyo
 

6 pagesV  1 2 3 4 5 6 > » 


 mobile version    Now: 04/29/19 12:06