TP-LINK TL-MR3220 - Discussion | [wifirouter] Discussion, firmware, problem solving

Rep: (17)
Attached Image

A photo:
Attached ImageAttached ImageAttached ImageAttached Image
Device purpose
Share your 3G / 4G connection freedom! The TL-MR3420 N-Series wireless router with 3G / 4G standards allows for sharing of mobile broadband 3G / 4G connectivity via WiFi or an Ethernet cable. By connecting a 3G / 4G USB modem to the router, you can create a Wi-Fi access point in minutes, through which wireless shared Internet access is possible, as well as information and applications on the local network.

Support any modems
Compatibility is the most important point to consider when purchasing a 3G / 4G router. TP-LINK has taken due measures to ensure that the router is 100% compatible with the modems that will be used with it. TP-LINK 3G / 4G routers successfully work with Internet service providers in the regions where they are sold. Worldwide, working groups have been established that constantly test new regions with new modems, so users can be sure that their 3G / 4G router will work flawlessly in the region where they live and work.

Supports 3G / 4G and wired redundancy
A distinctive feature of the TL-MR3220 model is support for the 3G / 4G standard and a wired connection with a channel reservation function, so that the connection to the Internet always remains active. Users can specify in the settings the preferred connection mode, one option out of two: 3G / 4G or WAN, the second option will be a backup connection. At the moment it is the only device that offers the possibility of using two types of connections at the same time. This allows you to get a wider range of settings, reduce downtime and save money on payment for connecting to an Internet service provider.

N standard data transfer rate and solid wireless coverage area
The TL-MR3220 router supports the IEEE 802.11n wireless standard and helps deploy a wireless network with data transfer rates of up to 150 Mbps with lower data loss when transmitting over long distances and over obstacles in a small office or large apartment, even in a reinforced concrete building. Moreover, users can easily catch the signal of their wireless network from a greater distance than was previously possible with devices that support the 802.11g standard.

WPA / WPA2 Encryption Modes - Enhanced Security
WEP encryption is no longer considered reliable enough to protect wireless networks. The TL-MR3220 router uses WPA / WPA2 (Personal / Enterprise) encryption modes developed by the WI-FI Alliance industry group, which deals with the compatibility and security of wireless devices for local area networks. WPA / WPA2 encryption ensures protection against any attacks and unauthorized access.

Share via 3G / 4G connectivity
The TL-MR3220 allows working at 4G standard speeds and supports more than 200 models of 3G modems, allowing users to share 3G / 4G broadband mobile connectivity via a wired or wireless connection.
Interface USB 2.0 port for LTE / HSPA + / HSUPA / HSDPA / UMTS / EVDO USB modem
1 10/100 Mbps WAN port, 4 10/100 Mbps LAN ports, auto-Negotiation and auto-MDI / MDIX support
Buttons WPS / Reset Button
On / Off switch wireless mode
Power on / off button
External power supply 9 VDC current / 0.85 A
Sizes (ShhDhV) 204 * 138 * 44 mm
Antenna type Omnidirectional, removable, Reverse SMA
Antenna gain 5 dBi
Parameters of the wireless module
IEEE 802.11g, IEEE 802.11b Wireless Network Standards, with some characteristics of the IEEE 802.11n standard
The frequency range of 2.4-2.4835 GHz
EIRP (Wireless Power)<20 dBm (EIRP)
Wireless Security Support 64/128-bit WEP, WPA-PSK / WPA2-PSK encryption,
Wireless MAC Filtering
DBPSK, DQPSK, CCK, OFDM, 16-QAM, 64-QAM Modulation Technology
Software features
QoS (traffic prioritization) WMM
Security NAT and SPI firewalls, MAC address / IP address / packet / application / URL filtering, DoS attack protection, SYN Flooding, Ping of Death
Management Management via web interface (HTTP), Firmware update via web configuration interface
CE, FCC, RoHS certification
Package Contents N Series Router with 3G / 4G Standards
1 antenna
Power Supply
Ethernet cable
CD with materials
Quick Setup Guide
System Requirements MicrosoftВ® WindowsВ® 98SE, NT, 2000, XP, Vista в„ў or Windows 7, MACВ® OS, NetWareВ®, UNIXВ® or Linux.
Environmental Parameters Operating Temperature: 0 в„ѓ - 40
Storage temperature: -40 в„ѓ - 70 в„ѓ
Relative air humidity during operation: 10% - 90%, without condensation
Relative humidity during storage: 5% - 90%, without condensation
Before flashing / updating your router's software - Recommendations for updating the software of TP-LINK routers, check its hardware version, you can see it on the back of the device.The router version and the firmware version must match!

OpenWrt based alternative firmware for 3G and 4G modems for TP-LINK TL-MR3220 (GoldenOrb)
Latest factory firmware for v1. * v2. *
New updated custom firmware
Actual Firmware GoldenOrb 2017-12-15 Attention! We look the Version of your Router v1. * v2. * Supported Modems here
DD-Wrt firmware themethe forum
FullFlash firmware for programmer Download Ver 1. * Download ver 2.
Updated Firmware GoldenOrb 2018-09-18 Attention! We look the Version of your Router v1 (not yet). * v2. *

Wishes to design themes
Suggestions and suggestions are accepted in QMS.

There is no curator in the subject. For questions about filling the caps, please contact the section moderators via the "Complaint" button under the messages to which you want to add links, or through QMS.

Post has been editedATV59 - 30.11.18, 11:12

Rep: (11)
* ivan2280 ,

Post has been editedgarry2007 - 19.03.19, 14:53

Rep: (0)
All DD.

There was a problem after resetting to factory settings. Maybe someone came across.

I stopped seeing usb modem. The diode does not light up. In the web - unplugged
ver 2.3
fw 140929

Before that, I normally worked with this modem (ZTE MF827) on this firmware.
Now tried another ZTE MF827 and Huawei E3272 the same story
All modems are working properly in the computer.

Rep: (18)
KazKL @ 03.26.19, 12:48*
In the web - unplugged

Somewhere on the Internet, when a person has a similar situation, he was helped by transferring the mode of the network in the modem to "only 3G".

Rep: (0)
Snaider444 @ 03.26.19, 12:25*
"only 3G" try may helps.

Did not help

Although judging by the modem's LED, it also raises 4G (blinking blue) and 3G (blinking green) session

Post has been editedKazKL - 26.03.19, 09:35

Rep: (18)
KazKL @ 03.26.19, 13:29*
Did not help

here I read in one forum - “With the MR3220 v2 and MR3420 v2 routers there is a problem of unclear etiology.
The essence of the problem is that the 4G modem ZTE MF823 connected directly may not be detected or behave incorrectly.
It is solved using a USB extension 0.7-1.5 m long and better if with a ferrite ring.
Anyone does not fit - you need to pick up.
At the moment, we are cutting off the hardware incompatibility (we are trying to solve it programmatically). If it does not work out, then a new version of iron will be launched, and on the old one we will decide through crutches "
when people connected to modems, they also had unplugged status, some actually helped using our extension cable.

Rep: (0)
SAT & 4 @ 03.26.19, 21:39*
instead of the standard stabilizer 5v on USB simple roll

If only this was the problem.

In the cap there is an instruction.
Even if it starts through an extension cord, I will redo it.

Post has been editedKazKL - 26.03.19, 20:33
Reason for editing: Spelling is lame

Rep: (3)
Hello to all! Maybe someone will come in handy, bypassing the greed of the cellular operator for analyzing ttl packets.
Instructions for solving this problem:
Description in paragraphPreparing the router Attached fileTo bypass operator blocking via ttl on TP.pdf router (460.83 KB)

The same instruction, but here:
To circumvent the operator’s greed by ttl on TP-Link TL-MR3220 v2 router and e3272 modem
Modem preparation:
Initially, the modem was stitched to work in Hilink as described inPost # 7328and was used in a laptop, but to work with the TP-LINK MR3220 v2 router, this option did not fit and had to be changed to Stick. (what makes Hilink different from stick)
1. Install the firmware: (full version Post # 7328)
1.1. Unlock the modem before the firmware. Everythingutilities to unlockprocess descriptionunlocking
1.2. Change imeithroughDc-Unlocker_Client, the at ^ datalock = "Your Unlock Code" command is entered even though your modem is unlocked, otherwise there will be an at ^ command error.
1.3. Install the driver again if previously installed for firmware:
1.3.1. HUAWEI_DataCard_Driver_5.05.01.00_Setup
1.3.2. FC_Serial_Driver_Setup
1.3.3. HUAWEI_HiLink_Switch_Driver_Setup
1.4. Install the firmwareThe safe version of the firmware is 21.491.05.00.00.
1.5. InstallDashboardor at will herethese
1.6. Perform modem settings as desired, prepare it for the router.
1.7. Switched to modem mode via Dc-Unlocker_Client -Download
using the command AT ^ SETPORT = "FF; 10,12" - Modem Only mode is enabled. In this mode, according to the forum, the maximum speed is 20-30 Mbit, but my provider does not receive this speed, so this option came up to me.
All teams

Preparing the router:

1. Download and install the firmwareALTERNATIVE SPECIAL FIRMWARE based on OpenWrt for 3G and 4G modems for TP-LINK TL-MR3220 and not onlylink directly to the firmware forTP-Link TL-MR3220 v2.
Pre-install the mostlatest firmwarefor the router and proceed to install the firmware, which is installed similarly to the official firmware via the web interface.
Attached Image
(screen from another router, but the principle is the same)

2. Install the modem in the router, it should pick up automatically.
3. Go to the configuration of the router in the System ->Software
3.1. Click update packages
3.2. In the filter, enter Russian or luci-i18n-base-ru click search
3.3. Find the interface translation (luci-i18n-base-ru) and install
3.4. Configure the router at will.
4. Go to the ttl control bypass.
4.1. OriginalPost # 14762
Attached Image

Roll back from the openWRT firmware via the web interface by downloading the file mr3220v2_en_3_14_2_up (120822) .bin and then install the latest firmware for the router, and you are again on the stock firmware.

Firmware file for rollback with openWRT via web interface

Post has been editeddenisok695 - 15.04.19, 18:45
Reason for editing: link correction

Rep: (2)
Good afternoon. Appeared: thank_you:GoldenOrb 2019-03-10 firmware on v1
A photo
Attached Image

Post has been editedal05bi - 18.04.19, 19:33

Rep: (32)
All good. I want to understand why this happens (if there is an explanation). A month and a half ago (plus or minus) wrote that the router was reset to factory settings. I then dropped it myself. Reconfigured everything. But saved after this setting. So usually turned off in the evening, after work turned on. Everything is working. Today here I was just recently going to the store to go. Turned off as usual (I have all the equipment, except the refrigerator turns off, as I leave). I come, no Internet. Rebot router - poh. Well, there with your password - does not accept. From the factory accepted. I restored the settings from the backup - it works. Is there a dead battery somewhere? Or how does it store the settings? Given its age, then if there is a battery there (as in the computers on the BIOS), then I will soon become a constant problem
Any ideas?

Rep: (18)
Deys @ 04/19/19, 10:13 PM*
then if there is a battery (as in the BIOS computers), then I will soon have a constant problem
Any ideas?

What hardware defect can? crashes flash memory as a type. I have 3220v2 since 2012, by itself I have never been dumped either on the firmware or on openwrt, despite the fact that I experienced a sudden power outage hundreds of times. If there had been a battery in seven years, I think she would have died.

Rep: (25)
There are no batteries in the TL-MR3220 v2 router. At least I did not find in his. Works in the mode of almost 24/7 five years. It seems that the problem with resetting the hardware settings (as it was correctly written above, the memory dies), but to clear the conscienceAT ONE'S OWN RISK You can try to update the firmware. To begin to reflash the current and MANUALLY restore settings (and not restore the backup). Or you can flash a new one from 06/14/20 (you can find it on the Ukrainian TP-Link page ). Either welcome to the OpenWRT fans club (I can recommend the version of OpenWrt Chaos Calmer on my own on 05/15/1. The newer ones either slow me down or turn me down). If all this does not help - either in the repair or in the store.

Rep: (18)
Randomhard @ 04/23/19, 01:04*
From myself I can advise the version of OpenWrt Chaos Calmer 15.05.1.

since the year before last, Chaos Calmer has been worth 15.05, everything works stably 24/7.

Rep: (0)
Has anyone been able to make friends with this device with hilink modem E8372 or the like?

Rep: (0)
tell me how to Russify GoldenOrb 2019-03-10
no file luci-i18n-base-ru,
after the update list also does not appear

Rep: (25)
msSASH @ 04/30/19, 01:34*
how to Russify GoldenOrb 2019-03-10

The first thing that comes to mind is to take the necessary file of a suitable architecture from the base openwrt (in the case of GoldenOrb 2019-03-10 for routers with four megabytes of memory, the base Openwrt 15.05) and install via the console. But perhaps this file will pull the dependencies. You need to try, and be ready for a flashing from scratch. File can be taken herehttp: //archive.openwrt...generic/packages/luci/. There are two versions.

Rep: (0)
msSASH @ 04/30/19, 01:34*
tell me how to Russify GoldenOrb 2019-03-10
Try to repeat the operation. I also did not appear on the list from the first time.

Rep: (3)
I assembled for my own needs the firmware for MR3220v2 based on LEDE January 17, 2006.
Details in the description.
My second day is stable and fast enough.
Maybe someone else will come in handy.

Description of firmware mod v2.4 for TL-MR3220 v2
Firmware mod v2.4 - 2019.05.09

TP-Link TL-MR3220 v2
LEDE Reboot 01.01.6 r3979-2252731af4 / LuCI lede-17.01 branch (git-18.201.27126-7bf0367)
Kernel Version 4.4.153

Changes regarding the base version:

(-) Cut out everything related to IPv6, including support in busybox and packages
(-) Cut help messages in busybox utilities
(-) Everything related to debug: printk, debugfs is cut from the kernel, symbols - the kernel does not display any information, dmesg output is empty

Due to these events, a space has been released in the firmware, in which a plus to the basic functionality has been added:
(+) support for an external USB flash drive / disk (the ability to organize extroot);
(+) support for 3G modems ;.
(+) VPN PPTP protocol;
(+) VPN protocol L2TP (without IPSEC);
(+) LUCI application watchcat

Installation for existing firmware and lede / openwrt clones via web interface - file with sysupgrade name,
for the rest - a file with a factory in the name ..

The / usr / sbin has a script for automatically preparing a usb flash drive for extroot.
After installing the firmware, you can access the router via SSH, and start it with the command:

/ usr / sbin / usb-drive-init

Two partitions will be created on the previously inserted flash drive: the first (/ dev / sda1) 256Mb - Linux Swap,
the second (/ dev / sda2) - ext2 is the rest of the space for extroot.
The script will also copy the / overlay folder from the firmware to the USB flash drive so that the sda2 partition can be mounted as overlay.
After rebooting the router, you need to complete the rest of the configuration through the web interface in the "Mount Points" section.

There are some compiled packages in the packages.tar.gz file, for example openvpn, for offline installations from the same flash drive.
To do this, the archive must be deployed to the root of the sda2 partition.

Link to download

Post has been editedtoyan - 10.05.19, 10:52

Rep: (1)
toyan @ 05/10/19 09:45*
Firmware mod v2.4 - 2019.05.09

TP-Link TL-MR3220 v2
LEDE Reboot 01.01.6 r3979-2252731af4 / LuCI lede-17.01 branch (git-18.201.27126-7bf0367)
Kernel Version 4.4.153

Great job! And could you compile the version for v1 too. I would be very grateful, I think that not only I am alone ;-)

Rep: (0)
In attempts to connect the Sierra U598 modem with Intertelkom (flashing OpenWRT, DD-WRT) somehow rolled the firmware back to my native and instead of TP-LINK TL-MR3220 v.2 became my old brother TL-WR741N.

To return everything as I tried and upgrade in the usual way via webmord (they write the error saying the wrong version of the hardware), through Tftp everything seems to be fine with the MR3220 (you go to the router the same version of WR741N, tried different firmware), through WinSCP does not allow to go ( may not set up so settings).

Pliz advise how to pour native under MR3220, because WR741 does not support USB modems

Attached images
Attached Image

Post has been editedmsSASH - 11.05.19, 01:03

Rep: (18)
msSASH @ 05/11/19 05:01*
through WinSCP does not allow to go

is access to web interface ruined?

Full version    

Help     rules

Now: 06/26/19 21:52