Multiboot for Nokia N9 | multiboot kernel

Rep: (256)
Multiboot for Nokia N9

I spread my working config, allowing to load several OS. I also upload the files that I use. More information about the kernel can be readhere.

All manipulations in paragraphs 1-5 are done without rebooting the device!
Prepare the device:
1) We execute (if we did it before, then it is not necessary) in the terminal a command from user:
disclaimer-cal remove View-openmode

2) Define your product-code, download the necessary firmware corresponding to the code and these two archives (timeandtwo). Archives throws in MyDocs.
3) Download and installany of the Nitroid releases(if you need one), wait for the installation to complete.
4) Execute the following commands in the terminal
tar xvzf /home/user/MyDocs/modules.tar.gz -C /
/ sbin / depmod -a
tar xvf /home/user/MyDocs/kernels.tar -C /

5) Downloadingthis archive, unpack 2 files in / home / user / MyDocs / boot

This completes the preparation of the device, then you need to flash the Ubiboot kernel.

1) Download itcore
2) We sew the core of thisinstructions

Next, disconnect the phone from the cable and try to turn it on. If everything is done correctly, then the boot menu will display the boot OS selection. SailfishOS is put on thisinstructionswith the exception of the paragraph about Ubiboot.

PS: transfer where necessary.

Post has been editedAncelad - 28.01.14, 08:50

Rep: (471)
I decided to highlight the post in a separate topic.
A multiboot can be applied to any of the instructions for both Nitdroid and sailfisn or nemomobile.
Difficulties and their solutions in this vein, I propose to discuss here!

Rep: (0)
If I follow these instructions, I can install it, and the debit nitroid can be installed

Rep: (471)
Well, in general, yes ...

Rep: (256)
Without any "well, in general" :)

Rep: (2)
Ancelad I put everything according to the instructions, as it should, the OS selection appears, the boot is loaded, but the nitroid does not want ... but I didn’t put it on my debit, but just unpacked it into the home / nitdroid folder ...

Post has been editeddenismad - 30.03.14, 03:37

Rep: (2)
Ancelad I apologize, the question is removed. everything is loaded! THANKS!) Tried to configure the config, as a result did not work, was sewn, did everything according to the instructions, it works)

Rep: (0)
Hello! Help guys. I did everything according to the instructions, even twice, meego and nitdroid is launched and sailfish does not want. I click on the sailfish displays the item back in the multiboot. I stitched without deleting nitdroid on multibut from this topicSailfish for Nokia N9sailfish starts, but no nitdroid. I wanted and meego and andr and the salfish on the phone. N9 16 gb. I would be very grateful

Rep: (0)
I put ubiboot with original (files unconfigured by someone), it was the same.
Saylfish is loaded when you click on it and select the first kernel (you need to edit ubiboot.conf for correctness)
The theme for the silyfish file is configured to load only the harmattan core and the sailfish core)
Take two ubiboot.conf - from this topic and from that, and you will understand everything, where to add.

Post has been editedgoose976 - 04.12.14, 17:16

Rep: (0)
From this topic I took ubiboot. And what is there to rule in ubiboot.conf? That is, where it is necessary somewhere to register that would be launched saylfish?

Rep: (0)
G_OS6_NUM = 1
G_OS6_NAME = "Saifish"
G_OS6_1_LABEL = "vmlinuz-"
G_OS6_1_FILE = "/ boot / sailfish / boot / bzImage"

Rep: (0)
It turned out to configure a multiboot. But now such a problem. Meego and Nitdroid all work well, and in sailfish such trabla. Photos in the application

Posted 12/04/2014, 20:31:

I tried to put ubiboot cSailfish for Nokia N9All is well with the salesman, that's only in this case I remain without an android: (What should I do? Have you encountered this?

Attached images
Attached Image

Post has been - 04.12.14, 21:25

Rep: (0)
goose976 thank you very much for your help

Rep: (0)
Before editing ubiboot.conf on the link to the profile topic, you started and watched the "sailboat"?
I set myself r5.1, it works fine (not shaman with mount -o bind, nano, etc.) it started up after rebooting into sailfish.
Let me remind you that to launch sailfish you MUST have - wi-fi WITHOUT a password.
Further, all the prompts menu. (search and connection in the above assembly only in landscape mode is clearly visible)
The easiest option, I used it.
we are loading in harmatan, in xterm (in my own words, because I live on the phone):
mount / dev / mmcblk0p4 / sailfish
rm -rf / sailfish / *
tar --numeric-owner -xvjf /home/user/MyDocsvgrade-sailfish_r5.1.tar.bz2 -C / sailfish /
/ sbn / reboot
in the boot poke "sailboat" and the core
wait s
on the new drive everything you need (if the account is created, we prescribe)
pour tea and indulge.
ZY At the first start, I hung on "Wait"
I waited 5 minutes, then I pressed the on / off button, turned off, loaded into the sailboat again and the system started working.
ZZY zypper in nano from under the moment does not plow, from under the moment I use "meetxtedit", there is in the store)
Good night with a working sailboat.

Post has been editedgoose976 - 05.12.14, 00:33

Rep: (0)
And everything, thank you, yesterday it happened after dancing with a tambourine, in ubiboot instead of nemo recorded sailfish was launched for some reason :)). I do not know why, the main thing was launched. Everything is working. Thank you very much!!!

Post has been - 05.12.14, 16:46

Rep: (4)
How to get BackupMenu with Ubiboot?

Full version    

Help     rules

Now: 07/26/19, 02:52