TP-Link TL-WR841 - Discussion | [wifirouter] Discussion, firmware, problem solving

Rep: (1774)
TP-Link TL-WR841N / ND- Discussion

Attached Image

The forum decided to post images under the spoiler Attached Image

A photo:
Attached ImageAttached Image
The TL-WR841N wireless router is a combined wired / wireless network device designed for use in small and home offices. Using the 2T2R MIMO technology, the TL-WR841N allows you to create a network with ultra-high data transfer rates, making it possible to view HD video online, use IP telephony and play online without delays or disconnections. The device is made in a stylish case and is equipped with a WPS button for quick installation of WPA2 protection.
Offsite specifications

Interface 4 10/100 Mbit / s LAN port
1 10/100 Mbps WAN port
Buttons Quick Protection Setting Button (QSS)
Reset button
External power supply 9V DC. current / 0,6A
Standards of wireless data transmission IEEE 802.11n, IEEE 802.11g, IEEE 802.11b
Antenna 5dbi * 2 fixed omnidirectional antennas
Dimensions (WxLxH) 192 x 130 x 33 mm
Parameters of the wireless module
The frequency range of 2.4-2.4835 GHz
11n signaling speed: up to 300 Mbps (dynamic)
11g: up to 54 Mbps (dynamic)
11b: up to 11 Mbps (dynamic)
EIRP (Wireless Power)<20dBm (EIRP)
Sensitivity (reception) 270M: -68 dBm with 10% PER
130M: -68 dBm with 10% PER
108M: -68 dBm with 10% PER
54M: -68 dBm with 10% PER
11M: -85 dBm at 8% PER
6M: -88 dBm with 10% PER
1M: -90 dBm at 8% PER
Wireless functions Enable / Disable broadcast, WDS bridge, WMM, Statistics
Wireless network protection 64/128/152-bit WEP / WPA / WPA2, WPA-PSK / WPA2-PSK
Wireless network 64/128/152-bit WEP / WPA / WPA2, WPA-PSK / WPA2-PSK
Software features
WAN connection type Dynamic IP / Static IP / PPPoE / PPTP / L2TP / BigPond
DHCP Server, Client, List of DHCP clients,
Address Reservation
QoS (traffic prioritization) WMM, Bandwidth Control
Port Forwarding Virtual Server, Port Launch, UPnP, DMZ
Dynamic DNS DynDns, Comexe, NO-IP
VPN traffic pass PPTP, L2TP, IPSec (ESP Head)
Access control Parental control, local control, list of nodes, access schedule, rule management
Network security (firewall) DoS, SPI firewall
Filtering by IP Addresses / Filtering by MAC Addresses / Domain Filter
Binding IP and MAC addresses
Management Access Control
Office in place
Remote control
CE, FCC, RoHS certification
Scope of Delivery Wireless Router TL-WR841N
External power supply
CD with materials
Quick Installation Guide
System Requirements MicrosoftВ® WindowsВ® 98SE, NT, 2000, XP, Vista в„ў or Windows 7, MACВ® OS, NetWareВ®, UNIXВ® or Linux
Environmental Parameters Operating Temperature: 0 в„ѓ ~ 40
Storage temperature: -40 в„ѓ ~ 70 в„ѓ
Humidity (operating mode): 10% ~ 90% non-condensing
Humidity (during storage): 5% ~ 90% non-condensing
Useful links:

The curator of the topic isN.o.F.a.c.e.

Post has been editedN.o.F.a.c.e. - 06.07.19, 13:31
Reason for editing: dump v14

Rep: (17)
Firmware Version:
3.16.9 Build 151126 Rel.54989n
Equipment Version:
WR841N / WR841ND v11 00000000

Is there an alternative firmware? Poke nose pliz =)

Rep: (179)
* maskibot
OpenVrt is in the cap, Dvvrt last betahere.

Rep: (17)
ddwrt flashed. But how to remove the isolation ports LAN? Do not go ping mezhu ports, I think something with VLAN. Write how to remove it through telnan.

Rep: (0)
Please tell me which firmware is better to flash in order to make a repeater out of the router? Openwrt or dd wrt? And which is easier to set up?

Rep: (360)
And which is easier to set up?

Openwrt (on LEDEinstalled for the first timeAfter the drain, the client does not go out! ).
You scan a network - you are connected by the client.
IP assign different from the main router.
That is, the primary client is
Without doing so there will be no distribution.
Create an access point.
It is advisable to put 14.07 or 15.05 version. In 05/15/1 wifi falls off sometimes.
Attached Image

Attached Image

Attached Image

Attached Image

Attached Image

Result - main 841v8 client 841v8
Attached Image

Post has been editedHerzz - 02.07.19, 21:33

Rep: (0)
Herzz @ 07/07/2016, 12:04*
OpenWrt. You scan a network - you are connected by the client.
You create a point of access.
It is advisable to put 14.07 or 15.05 version. In 05/15/1 wifi falls off sometimes.
[attachment = "8351203: sshot-4.jpg"]
[attachment = "8351205: sshot-5.jpg"]
[attachment = "8351206: sshot-6.jpg"]
[attachment = "8351208: sshot-7.jpg"]
[attachment = "8351210: sshot-8.jpg"]

Thank you very much! I will try.

Rep: (360)
I got 841 v8 at the start of the light of all the indicators and only the Power is on
The recovery mode is not included (depending on the firmware in the early ones there is no this function)
On UART falls outKernel panic - not syncing: No init found .
Treatment - watching the power-on / off log until it starts.
We sew the latest firmware from the boot loader.
WDS mode on standard issued (rate 50Mb) 25/18
The same WDS (setting explained above) on OpenWrt - 50/50
On the default firmware, you can get an Internet connection with WDS over cable, you can only manually register the IP in the network computer
WiFi is okay

Post has been editedHerzz - 29.04.18, 18:21

Rep: (4)
Help is needed. I have this device now, before it was wr740n. Sobssno changed the router due to the fact that there were large packet losses (70-90%). In the new wr841 v11.1 the same problem. Firmware last dd-wrt. Is it a marriage or is there some other reason?
PS directly without a router no losses.
PPS if you ping 32 bytes, then there are practically no losses, and if 1000 each appear. BUT it's not the number of bytes, I really noticeably cut speed.

Post has been editedMr.Fodex - 15.07.16, 19:53

Rep: (360)
* Mr.Fodex,
Logically speaking, 2 routers are the same problem.
Treatment - change provider.

Rep: (4)
Herzz @ 07/15/2016, 20:52*
Treatment - change provider.

Without a router, everything is ok. even 10,000 bytes

Rep: (93)
also logically - firmware (and the V11 itself is questionable)
p.s. return to 740 with a different firmware and (or) change the provider (already advised)

Post has been editedA123l - 16.07.16, 12:38

Rep: (9)
Hello everyone, there is a tp link w841n ver. 8.4, stopped opening many sites. Who can tell me how to cure?

Rep: (360)
stopped opening many sites

And how does the router to the problem?

Rep: (1)
Tell my friends, I killed the router, when I decided to return from dd wrt to tp link firmware, now I can’t get to the web of the router, what can I do?

Rep: (655)
OpenWrt. You scan a network - you are connected by the client.
You create a point of access.
It is advisable to put 14.07 or 15.05 version. In 05/15/1 wifi falls off sometimes.
[attachment = "8351203: sshot-4.jpg"]
[attachment = "8351205: sshot-5.jpg"]
[attachment = "8351206: sshot-6.jpg"]
[attachment = "8351208: sshot-7.jpg"]
[attachment = "8351210: sshot-8.jpg"]

Something does not work so the client connects to any point of the wifi. The password must be entered somewhere (well, to the selected point, the client)?
I wired up yesterday at open-vrt and tried everything, it does not go in any way (and I look at the screenshots in your Russian locale, in my latest version, "language selection" is only a car, and English remains listed)
On dd-vrt also tried to connect to the client, and also fails
This is what they advised me to do on dd-vrtDD-WRT - alternative firmware (Post stp101 # 50724978)

Post has been editedrostikzh - 17.07.16, 11:37

Rep: (360)
The password must be entered somewhere (well, to the selected point, the client)?

So enter - automatically offer to do it.
Attached Image

Rep: (655)
* Herzz,
With DHCP, no action is needed (in the sense that my point gives out or takes it from the main point?)
Well, the IP also does not change, at my point?

Rep: (360)
* Rostikzh,
The only thing that changed the IP on OpenWrt is different from the base.
That it would be possible to enter both the database and the client.
base - openWrt of the type so

Posted on 07/17/2016, 16:34:

With DHCP, no action is required

Except shown nothing changed. If the database is configured with a static IP on OpenWrt, the mode for static has changed.

Post has been editedHerzz - 17.07.16, 17:07

Rep: (655)
* Herzz,
By the way, on my v8 router also after a while, after turning on the router turns off, and all the lights start flashing at the same time, except for the network (it is constantly shining), the common TP-Link power supply unit from the other router is being treated. I put more powerful blocks. It is necessary to acquire either a worker TP-Linkovsky, well, or who will share the scheme from this router? (exactly the part where the interchange on the power supply is drawn is of interest.)
This happened after the lightning discharge, the entrance van port was cut down and the block was burnt, so I wonder what other units are not satisfied with it, what it lacks, voltage, amperage, or what level of pulsations ?!
Share who, with me a huge thank you

The second router (740n) from where it took the block, works equally well on both blocks! (I can't change them)

Post has been editedrostikzh - 17.07.16, 18:10

Rep: (5)
Good day!
I updated the firmware, did not change the settings, periodically turned off wi-fi on the android.
TL-WR841N, it was TL-WR841N_V9_140625, it became TL-WR841N_V9_150331.
Can you somehow overcome it?
Thank you in advance.

Full version    

Help     rules

Now: 07/17/19 21:23