APKENV (harmattan) | running Android applications on n9 without nitrodide

Rep: (472)

Version: 42.7.0

Last update of the program in the header:22.03.2014

By allowing you to run multiple games with android in native code.
You can run as from the terminal. so with qml interface
more details:http://meegos.ru/forum/viewtopic.php?pid=120647#p120647

Before installation, you must enable the developer mode
New builds will be here:
Work applications:http://wiki.maemo.org/Apkenv/Game_Compatibility

Pak games moved and Dropbox to Poison ... My DB generates too much traffic and it is periodically disconnected from the distribution .. I will move to POH and GD

Pak gamesIndeks disk

At the moment, work well:
-World of GOO
-Cute The rope
-AngryBierds rio
-AngryBierds spase
-AngryBierds season
-Amazing Alex

Also in the subject there are workers:
-Plansts vs Zombies
-Super Hexagon

Download:Version 42.7.0
Version 42.3.15
Version 42.3.15+ instructions for launching. +Pak of the going games

Old apkenv version+ graphic interface
Icons: Attached fileIco.zip (137.96 KB)

Post has been editedAlexxxl - 08.08.14, 09:34

Rep: (472)
Nokia N9,
Delve into the topic!

The trick is that apkenv can ONLY run some games written in binary without using dalwick! Apparently there simply are no applications suitable for these criteria ... Otherwise, they would have already been launched ...

Rep: (472)
Apnu theme so to speak ...

Today I downloaded the latest APKENV -https://www.dropbox.com/s/r2qg464svu1ggq3/a....3.15_armel.deb
And a pack of games going to him -https://www.dropbox.com/s/gbprbzscmg1kios/Apkenv%20Games.zip

This apkenv does not have an interface graph, install via the terminal.

1) Install deb
2) put in the folder / home / user / MyDocs / Apkenv / downloaded apk files
3) Run the terminal ..
- If we just want to run the game, then we code (without any devel-su):
apkenv /home/user/MyDocs/Apkenv/game_file_name.apk

- If we want to make a shortcut to the desktop and no longer go to the terminal to run the code (without any devel-su):
apkenv --install /home/user/MyDocs/Apkenv/game_file_name.apk

ps In the attached selection there are games:

  1. -World of GOO
  2. -FruinNinja
  3. -Cute The rope
  4. -AngryBierds rio
  5. -AngryBierds spase
  6. -AngryBierds season
  7. -AngryBierds
  8. -Amazing Alex

The only thing for the game FruinNinja does not automatically want to create an icon ... Either blind it with your hands, or start the game through the terminal as described above.

it seems that they also launched Plants vs Zombiez ... but have not yet found a working APK .. I dig TMT ...

Post has been editedAlexxxl - 12.07.13, 15:53

Rep: (256)
Through the tweaker, put, there will be an icon for you. Proof -https://twitter.com/iAncelad/status/331863327452061696

Rep: (472)
Yes, as an option through a tweaker ...

Rep: (13)
For some reason, for me, games in the half-screen are launched ... I did everything according to the instructions. I went around the forums - I could not find a solution :-(

Rep: (472)
I have not seen such a thing, but how about the floor of the screen? As if we decide landscape instead of portrait?

Rep: (13)
On the contrary, as if portraiture.

I solved the problem with the help of Tweaker. Through the terminal, it was launched into a split-screen, and after creating the icon through the Tweaker and starting from the menu, everything became fine. It turns out quickly, conveniently and no dancing with a tambourine.

I will describe step by step, maybe someone will come in handy:
1. Install APKENV from the attached file.
2. We drop a pack with games along the path / home / user / MyDocs / Apkenv /.
3. Go to Tweaker and execute sequentially:
- Tweak "E";
- "7" (APKENV);
- "1" (installation);
At this point, the tweaker will suggest which of the games should be installed. You can choose one or several. To do this, enter numbers sequentially through a space (example: 1 2 4 5 7).
4. Exit Tweaker, go to the menu and enjoy the game icon that appears

Post has been editedpolotyh - 15.07.13, 01:11

Rep: (256)
3. We go into the Tweaker and execute sequentially: - Tweak "E"; - "7" (APKENV); - "1" (installation);

: D somewhere I already saw it ...

Rep: (1923)
What do you mean?

Rep: (256)
What do you mean?

yes toto thisat least

Super Hexagon with a tambourine starts, by the way :)

Rep: (256)
And besides the roving toys, is there anything else that can really be blown up?

http://wiki.maemo.org/Apkenv/Game_Compatibility- Let it be for now

Rep: (0)
I have a problem. I downloaded Apkenv, installed it, put it in the game folder and enter the command to launch the game through the terminal. I entered it and nothing happens. The same problem with creating shortcuts to the desktop

Rep: (1923)
try throughN9 QuickTweak app (script)create shortcuts to games, tweak E
This apkenv does not have an interface graph, install via terminal- so installed ???

Post has been editedalexummc - 18.07.13, 18:21

Rep: (0)
everything, it was necessary to reboot the device, but the second problem arose. When the game starts, it does not open to full screen, but to half and the sensor does not respond.

Rep: (1923)
I had this when the first time I stupidly installed apkenv as a regular program,
but when reinstalling through the terminal as it is written in the header, everything was installed and works as it should.

Rep: (0)
one more question. How to remove a game icon? I tried through the terminal, but it says the package was not found. Game angry space

Rep: (1923)
You put any file manager, open the applications folder in it along this path /home/user/.local/share, look for the files with the name of the game in it and delete them.
Or, again, through the N9 QuickTweak app (script) your E - 7

Post has been editedalexummc - 18.07.13, 19:27

Rep: (0)
And by the way, the apkenv is not installed through the terminal

Rep: (1923)
if it wasn’t installed then it wasn’t installed at all
and since no one has problems with it then ...
on a neighboring site (and probably also on this one) it says how to install programs
through the terminal. read it again and do everything carefully.

do you get superuser rights before installing the program in the terminal?

Post has been editedalexummc - 18.07.13, 19:38

Rep: (0)

cd / home / user / MyDocs / Downloads
/ home / user / MyDocs / Downloads # dpkg -i apkenv_42
warning, the file “/ var / lib / dpkg / status” is near line 112 of the “speedtest” package:
missing description
warning, file “/ var / lib / dpkg / available” near line 38 of the “speedtest” package:
missing description
(Reading the database ... 56897 files and directories are currently installed.)
Preparing to replace the apkenv 42.3.15 package (using the apkenv_42.3.15_armel.deb file) ...
Unpacking replacement for apkenv package ...
aegis-installing apkenv (from '')
dpkg: package dependencies do not allow you to configure apkenv package:
apkenv depends on libsdl-mixer1.2 (>= 1.2.6), however:
The libsdl-mixer1.2 package is not installed.
apkenv is dependent on libsdl1.2, however:
The libsdl1.2 package is not installed.
dpkg: failed to process apkenv (--install) parameter:
dependency problems - leave not configured
Errors occurred while processing the following packages:

I’m through the phone. I can not send a picture

Full version    

Help     rules

Now: 08/07/19, 07:03