Rep: (189)
* quqdron
The technology for manually installing EPO.DAT and EPO.MD5 navigation forecast files is as follows:
0. A smartphone must be rutted for these purposes. Sure!
1. From the official resources of mediatek download both files:
Links are case sensitive !!! It is necessary to type them in the address bar of the browser or add to bookmarks.
By default, files are copied to the Downloads folder (it is also download).

2. Rename the file EPO.DAT to EPOHAL.DAT (also case sensitive!).
3. Copy both EPOHAL.DAT and EPO.MD5 files to the folder:
/ data / misc
(Actually, in particular, you need root for this).

4. We give RW permission to both files for all users (Owner, Group, Guest). It's 0666.
The owner and group of files must be root (this is always the case after copying files, but it won’t hurt to check).
5. Reboot Basic.
After the reboot, the EPO.MD5 file should disappear - it, in fact, is needed only to check the checksum of the main EPOHAL.DAT file

6. We launch any navigation program (for example, I launch Navitel) and try to catch satellites.
(It is not necessary to catch them to the end).
After starting the navigation program, the EPOHAL.DAT file is automatically renamed to EPO.DAT, and the old EPO.DAT is deleted.

EVERYTHING! You can use the navigation with the forecast of satellites!
Just do not forget to enable this forecast in Settings:
Positioning ->GPS EPO (check)
By the way, here in EPO Parameters you can see by dates - a new forecast file has been installed or not.

Quqdron @ 08.26.19, 07:19*
can automate

This can be done by editing some kind of system file (there is either here or in Basic firmware).
But it is quite difficult and I didn’t even try to do it.
But, if edited, the update comes from Settings ->Positioning

The roots of the problem.
Fools from Mediatek 3-4 years ago changed the locations of EPO.DAT and EPO.MD5 files on their servers
Result: all owners of old devices on MTK processors were thrown together in terms of updating the navigation forecast.
Since the vendors, of course, did not update the firmware for this purpose.

Rep: (189)
* The ONE1,
It has already been written repeatedly!
one). Latest Versions:
boorloader v.03.84
radio v.03.88
(By the way, here is the latest in the header: bootloader-angler-angler-03.77.img, radio-angler-angler-03.84.img - the versions are not the latest).

2). How to install the latest versions of bootloader, radio and vendor at the same time?
It was also said already - pre-install the native firmware Android 8.1, the latest in release time.
Where to get it?
Here, in the header, but in the section on OFFICIAL firmware:
Google Nexus 6P - Official firmware (Post Displax # 75787637)
I would go through fastboot

3). Immediately after installing the official firmware - look at the bootloader and radio versions (if the latter, then never touch them again!) And further:
- install third-party recovery via fastboot (depending on which custom firmware you are going to install; for AICP 14.0 - install recovery from the header of this forum thread or from the header about official firmware);
- download and install firmware from recovery.

P.S. Of course, you need to read the instructions: how to sew native firmware via fastboot, how to sew recovery also through fastboot.

Post has been editedmkudritsky - 26.08.19, 05:50

Rep: (189)
need to upgrade to the latest versionvendor and radio

I would still additionally andbootloader updated to the latest version.
Unfortunately, the header contains links to these modules of far from the latest versions ...

The ONE1 @ 08.24.19, 9:57 p.m.*
No, I don’t sew a vendor and a radio at all .. doesn’t it seem like it is necessary to sew ??

Sewing the latest versions is mandatory.
I did this through the full vendor (from Google-Huawei) native Android 8.1 firmware.

But you can sew separately modules via fastboot from the desktop via the wire.
I refused to do so, because You can easily get a brick if you do something wrong.
It is especially dangerous to sew the "wrong" in the bootloader.

Well, of course, before all experiments, you need to unlock the bootloader ...

Post has been editedmkudritsky - 25.08.19, 12:39

Rep: (189)
* 3w3w3,
No, not from Nokia.

The following batteries are in my two BASICs:
Lenovo BL171
ZTE V970

The best one is the ZTE battery, as it has a bit more capacity (1650mAh) than Lenovo (1450mAh).
By the way, it is better suited to the contact area of ​​BASIC - almost no files have to work.
Unfortunately, both batteries IMHO can not be found right now. I at the end of 2014 barely found them, not like now.
Both batteries still work pretty well!
Only it is necessary to load at least a little and daily BASIC. And without load, from 100% to 5% are discharged in exactly 7 days in the on state, but, of course, in sleep mode with the screen off.

P.S. In general, guys, I'm amazed!
When I created my top post, I thought that I would talk here with myself!
But, as we see, I’m not the only one who does not dare to throw Basic. They are like first love! : D

Post has been editedmkudritsky - 25.08.19, 12:06

Rep: (189)
Pabushabi @ 08.24.19, 11:40*
try this google camera modification

I tried it. Does not work.
I have the feeling that on Lineage OS and on its subsidiary OSs like AICP, Google cameras do not work at all. This is also indirectly confirmed by the direct branch.savagemessiahzine.comby Google Camera.

However, maybe this is because on my AICP 14.0 Android 9 there are no GAPPS. From the word no.
I do not exclude that the Google camera needs some Google services.
Although this is not in the FAQ.

I think that all those comrades who want to try Goolge Camera on Nexus 6P need to bypass the Lineage OS firmware and its clones.

P.S. I repeat - the Snapdragon camera built into the AICP is enough for me.
But the question about Google Camera on AICP interested me! I'll try to study it in a sluggish mode.

The only negative is the slowdown of the animation of opening folders (groups) in the launcher

I don’t even have one. Nothing slows down at all!
It didn’t slow down even when I rolled GAPPS Nano on top of AICP 14.0.
(Then, again, from scratch, I rolled up a clean AICP 14.0 without GAPPS when I found the YouTube client Vanced.)

Post has been editedmkudritsky - 24.08.19, 15:13

Rep: (189)
The ONE1 @ 08.23.19, 10:30*
How do you not drizzle aisp ???? My phone reboots by itself 20 times a day, check another access point ... when you disconnect it with the Internet turned on, the phone reboots every time .. I don’t know what kind of programmers are sitting there that they cannot fix this bug .. ..

Everything is fine with AICP 14.0.
Nothing reboots, especially 20 times.
As for the access point, I tested everything a month ago - I was on vacation and connected all laptops through the access point.
I checked all the pieces of hardware: bluetooth (only with a button / stick for photos - photos were on vacation; I haven’t transferred files yet), fingerprint scanner, access point, barometric pressure sensors (there are no differences with SGS7), digital compass (comparison with the Asus A500KL, with the "needle" compass - all the same). About 4G, calls - I'm already silent (daily check).
Navigation - sees all the satellites (GPS, GLONASS, Beidou), but takes only GPS into operation (the accuracy and speed of satellite searches are the best of all my devices).

In short, the firmware is perfect.
Well, besides Google Camera v6. *. It is installed on my subject AICP 14.0 and even takes a picture, but after the picture it saves a 3-4 second photo, which is wildly annoying.

It is somehow strange that you have such problems with AICP 14.0 - I have this firmware installed perfectly smoothly.
The question is: what version of bootloader and radio are installed on your Nexus 6P?
I have everything - from the latest native firmware Android 8.1.
boorloader v.03.84
radio v.03.88
I put it this way: first I installed the native Android 8.1 firmware according to all the rules of aka “recovery” (bootloader / radio of the latest version was installed), and then I rolled third-party recovery v3.3.1.0 and then AICP 14.0.

The ONE1 @ 08.24.19, 00:10*
here he threw off on page 284 look .. P3v12.6_GoogleCamera_6.2.030.apk this version works for me

You should try it too.
P.S. I tried it - Google Camera P3 on AICP 14.0 does not work for me. Simply crashes when you try to start. We need to look for other versions of this camera.
At the same time I tried bluetooth file transfer to AICP 14.0 - it works, but only in one direction (from smartphone to laptop) and at a low speed. Always did not like the bluetooth interface.

Post has been editedmkudritsky - 24.08.19, 09:24

Rep: (189)
So, my teXet X-Basic celebrated another birthday!
(It was purchased in August 2013).

What has changed over the past year?
1. Of the browsers, Google Chrome has long ceased to be updated, a bit later Opera stopped updating.
Now I'm sitting on Dolphin browser v12.1.2 - updates are very rare, but they arrive.

2. What software from the most popular is regularly updated?
2GIS (version for Android up to 4.2.2 inclusive) - the databases are always fresh, and the main program is very rare, but updated.
Navitel - software and maps are always fresh.
Telegram, Viber - regularly updated.
SpeedTest - regularly updated.
Total Commander, OpenCamera, AllReader. ColorNote, VKontakte, SuperSU - very rare, but still updated. Not more than 1 time in 2 years.

Files for predicting satellites in navigation are also regularly updated:
True, they must be manually downloaded and installed on BASIC.

3. There is software that I do not intentionally update:
ADW Launcher EX v1.3.3.9 - with this launcher I replaced the native launcher.
BSPlayer v1.27.190 - audio and video player instead of the native.
CalenGoo v1.0.75 - instead of the native and Google calendar. Works with a standalone database!
Contact Editor Pro v0.6.6 - an addition to the native Contacts. May add a birthday to a contact.
QuickPic (no cloud) v4.2 - view pictures and drawings instead of the native Gallery.
SD Maid Pro v3.1.4.6 - a system cleaner from garbage.
FlashLight v1.0.7 - Flashlight.

I do not update for reasons: either the software has changed its owner and has lost its former quality, or the new versions of the software do not receive new functionality for Android 4.2.2, or the software acquires weight and advertising without new functionality. Well, or a combination of these items! : D

4. What configuration of system software do I use?
Firmware - from September 2013. Of course, Android 4.2.2. Strong, maximally cleaned of software debris.
Partitioning the internal flash - a la "41 Megabytes". This is when the entire internal 4GB flash is available for software, and the data section is a MicroSD flash drive (I have 8GB and 2GB on two BASICs).
Philz CWMR Toch recovery v6.0.5.0 - excellent recovery, works great with the layout of the flash drive "41 megabytes."

5. On both of my BASIC ALL ALL Google applications - the so-called. GAPPS.
My opinion is this: GAPPS are the main poison for all budget smartphones, as they very quickly and unreasonably grow in size and cease to fit in limited Flash and RAM state employees.
After the demolition of GAPPS, both of my BASICs are working as fast as when buying.
Strange, but even heavy applications like 2GIS, Navitel, Viber, Telegram, Dolphin Browser do not slow down ...

How did I replace the GAPPS?
Yalp Store v0.46 - replacement for PlayMarket. They are now updating all the software.
CalenGoo v1.0.75 - stand-alone, without synchronization, replacement for the Calendar.
OpenCamera, QuickPic (no cloud) v4.2 - replacement with Google's photo gallery.
BSPlayer v1.27.190 - replacement for the standard video player (I liked the fact that you can set the boundaries for the section of the video being watched and adjust the speed of the video display).

The most difficult thing was to replace the native client of Youtube.
SkyTube v2.95 - a great third-party client YouTube! But there are also disadvantages: you can not register and leave comments. Does not remember request history ...
Z.Y. 1. Alas, the good NewPipe program has ceased to be supported for Android 4.2.2. Therefore, demolished her.
2. The most popular clone of the native Vanced client no longer supports Android 4.2.2. But there is not the latest version suitable for BASIC. I downloaded it, but have not tried it yet, because my BASIC - for a long time already my 3rd spare smartphone and SkyTube capabilities are enough for me.

6. Navigation on BASIC - fire, especially with fresh EPO.DAT, EPO.MD5! Despite the legendary MTK65 chipset **
BASIC navigation is worse than Snaps only one - IMHO a little worse positioning accuracy.
But in general, Basic all these 6 years remains a very good navigator for a penny!

7. Battery (both of them, of course, are third-party. Since my relatives swelled and died a year later, already in 2014).
So, due to the very rare use of BASIC, they lose the calibration of the controller.
With a 100% charge, the smartphone can still lie for a whole week without use, but the charge readings drop in jump, say, from 30% to 5%.
To prevent this from happening, you need to use Basic at least a little every day - for example, watch at least one 5-minute YouTube video on it.
Well, or you need to recharge the batteries to 100%, pull them out and "put BASIC on eternal parking near the pier!" : D

Post has been editedmkudritsky - 23.08.19, 08:24

Rep: (189)
The bottom line is the endless boot into the system, when trying to flash via fastboot it produced a bunch of various errors like "security device flash function is disabled", "unknown reason", "remote authenticate image failed". In recovery when entering, it gives errors

The forecast is very bad - something hardware has failed (most likely Flash or RAM).
This can not be treated even by hardware from qualified repairmen, as there is no FullFlash for our device (you can replace Flash memory with a working one, but what can I sew there?).

Recommendation: throw this smartphone and buy something more modern.
Moreover, for A500KL there is firmware only with Android 5.0, which will soon become morally obsolete and they will stop writing fresh versions of software for it.
("Discontinued" Android 4.0-4.2.2. So far, 4.4.2 is relevant and up to 5.0.0 just a stone's throw.)

P.S. To make a decision, flip through the last pages 10-15 of this thread. There are many messages with symptoms such as those on your smartphone. And no one has yet managed to reanimate the A500KL.
P.P.S. Due to poor hardware reliability, I do not change the battery on my Asus A500KL, but for a long time my hands itched to replace it with the brand new Craftmann. I'm afraid that you will replace the battery, and the smartphone will fail in a month or two. Of course, something about 2,000 rubles (battery + work to replace it) is a little money, but I also don’t want to throw it away.

Post has been editedmkudritsky - 23.08.19, 06:58

Rep: (189)
Hukii-kun @ 08.21.19, 9:26 p.m.*
I can throw off stock recovery with the system

I also have stock recovery - somewhere around the house, like WW- firmware, but decorated as custom (in my opinion, no * .md5 is needed for it).
Moreover, somewhere there was a native firmware, designed as a custom, but with cut out GAPPS and cut out garbage.
It's just that I'm on vacation right now and it's hard to reach my file archive. (But you can!)

But I'm glad that everything ended normally with you! Congratulations!
P.S. And although custom firmware does not creep into bootloader, radio, recovery, you still need to be careful not to sew the device firmware from another device iron. As they say, God saves a careful! Our device is not the worst. It is still very fast even with GAPPS. And stuffed with sensors quite well - almost like a flagship. Even a digital compass is! It's a shame with your own hands to brick a smartphone. Moreover, there is no FullFlash for the A500KL, alas ...

Post has been editedmkudritsky - 22.08.19, 07:02

Rep: (189)
The ONE1 @ 08/22/19, 04:19*
Then what turns out, in order to install one of those firmwares, do you need to install another recovery or something ??? Or sew through fastboot?

Somewhere here was a list of firmware that needs recovery with FBE encryption.
Alas, pixel experience is among them.

And you need to sew like this:
1. Through fastboot install recovery 3.2.1 with FBE encryption.
2. From this recovery, format the flash drive.
By the way, after formatting, I recommend rebooting the device (back to recovery, of course). And only after rebooting - roll pixel experience.
And even after formatting and rebooting, I would dissolve the flash and separate the cache separately - so, for every fireman.
(That is, the firmware does not need to be installed from fastboot (only recovery)! Moreover, it is not provided by the fastboot commands. IMHO - maybe I looked?)

The matter is complicated by the fact that there are no links to these actions and to recovery with FBE in the header!
You will have to look for them here - in the forum.

P.S. And why AICP 14.0 did not work, if not secret?
For example, I tried for a long time to install the pixel experience, but after installing and testing the AICP I decided - they are not looking for good from good.
This AICP, despite the fact that it is custom, works for me better than the firmware from Vendors on my other devices. Generally without glitches (though NFC hasn’t tested yet)!
Even older cores almost always work with cold Snap-810! Only on very heavy applications are disconnected, and even then not immediately. And how many updates have already been! Glukov did not see.

Post has been editedmkudritsky - 22.08.19, 04:42

Rep: (189)
* hukii-kun,

All clear!
Have you tried to install third-party firmware from the device on Intel to our device?
If YES, then nothing bad happened - third-party firmware does NOT update the key: bootloader, radio, recovery.

How would I act in your place now?
It depends on the following factor.
1. If you started your experiments with Android 5.0 Lollipop WW_12.4.5.58 firmware, then this means: the bootloader, radio modules on the subject are the latest.
Then everything is simple: you need to download the firmware from here:

Z.Y. I looked - from the header the link seems to be like (?) Going to the full official firmware with all modules, including bootloader, radio. If it’s relevant, then I’ll take a look - somewhere I was lying around v.WW_12.4.5.58, designed as a third-party firmware

and restore the device by loading into recovery. The firmware can be fed either from MicroSD, or from an external flash drive connected via OTG.

2. If it all started not with the latest firmware (maybe even with Android 4.4.2). Then the bootloader, radio modules are not the latest version.
I would do this: restore the device to working on point 1.
And then - I would download the full firmware Lollipop WW_12.4.5.58, but from the official Asus website, and would reflash. In this case, the bootloader, radio modules would become the latest.
Well and further - third-party recovery, rutting, cleaning of the official firmware from garbage ...
(I don’t remember already whether the unlocked bootloader blocks the official firmware. If it does, it needs to be unlocked again! All the same utility from the Asus site.)

Post has been editedmkudritsky - 21.08.19, 08:29

Rep: (189)
Ms. Highscreen Spark @ 08/19/19, 16:08*
I bought a new battery for my Highscreen Spark. Which of the shovels can boast of this?

I can boast!
Fixed Nexus 6P. I bought a new battery for 1700 rubles and installed it in a regular SC for 500 rubles!
(It was possible to install it yourself - there are rollers on YouTube - but it’s difficult to do this carefully without special equipment.)

Post has been editedmkudritsky - 21.08.19, 05:31

Rep: (189)
* Axelez1987, as IMHO.
I think that a working motherboard can be taken from this device:
Asus Zenfone 5 A500CG - Discussion
Reason: these smartphones at one time differed only in chipset.

But why do this?
ZenFone 5 on Intel had disadvantages: no 4G, no GLONASS, it worked very little on a single battery charge.
But there are pluses: performance, custom firmware up to Android 8.0 inclusive, two SIM cards.

P.S. I repeat - I am not completely convinced of the full compatibility of the Asus A500KL and Asus A500CG motherboards.

Rep: (189)
The ONE1 @ 08/18/19, 20:34*
please tell me when I install the crDroid firmware, Resurrection Remix writes encrypting data, and then in the recovery does not see the internal storage .. because of what this is happening and how to fix it ... ?????

I venture to suggest the following.

We have two types of recovery: ordinary (in links from the v3.3.1.0 header) and with FBE encryption (the latter, if I remember correctly, v3.2.1.0).
So, there are a number of firmware on Android 9 that work only with recovery with FBE encryption.
Information: AICP 14.0 works with recovery with conventional encryption.

So, most likely you are trying to install FBE encryption firmware on a regular recovery. Or vice versa.
What prevents all this from being verified by exhaustive search? Well, since we started preparing the device with the demolition of all user information.
I also read that when installing firmware with FBE encryption, you must format the internal flash! Wipes alone are not enough!

Good luck!

P.S. 1. By the way, I subtracted all this somewhere in the links from the header. And he himself applied all this when he tried to roll pixel experience on the device.
2. Forgot to give one more information on AICP 14.0. The Pixel mod of the Google camera worked very poorly on this firmware for me (that is, what you need). He worked, did not crash, but everything was somehow slow ... Very slow. I think that the Google camera requires high processor power for HDR mode, and the AICP 14.0 core is energy-efficient and does not allow our hot Snapdragon-810 to work at full capacity.
So I left the default supplied Snapdragon camera on AICP 14.0. Personally enough for me.

Post has been editedmkudritsky - 19.08.19, 06:09

Rep: (189)
GlebAX @ 08/18/19, 16:26*
Pixel Experience

The first one has not been established for me.
It seems that everything is flashing normally, but when rebooting from recovery it freezes at the first start. Waited 20 minutes and more patience was not enough.

Now I use AICP 14.0 Android 9 without GAPPS.
Everything works and works great! Almost better than the official Android 8.1. There was not a single glitch.
I checked all the hardware, except for NFC (it was not possible) - there are no comments. True, so far I've tried bluetooth only on a stick with a button for a selfie photo.
Z.Y. I even checked atmospheric pressure sensors and a digital compass - the flight is excellent!

A small remark only on the speed of WiFi (I only have a 2.4GHz router): it is the smallest of all my gadgets - something around 25Mbps. For comparison, on the antediluvian teXet X-Basic from 2013 on the MTK6572, the WiFi speed reaches 45-60 Mbit / s.
On devices with Dragon-400, the WiFi speed is 40-50Mbps.

Bonus is a very energy-efficient core AICP 14.0.
The smartphone practically does not heat up, only slightly tepid in some energy-intensive applications such as 2GIS. In this case, all 8 cores work, although the older cores are cut off even with a small load.
In general, I even installed TWRP (4 cores) + native firmware with a patch that disables 4 older kernels, but AICP 14.0 works on my device much better in terms of energy efficiency.

The firmware from the end of May, when I installed it, is updated once a week.
Not a single glitch, neither during the update, nor after it. Security patches are regularly encapsulated in the firmware - now the patch is from August 2019.
After flashing, unless I edit once a week /system/build.prop to mute the noise canceling microphone.

There is, however, one big complaint about firmware without GAPPS — the firmware calendar cannot work without a Google account, that is, autonomously from Google services.
For this reason, in the standard AICP Calendar 14.0, I can’t, for example, configure the notification of birthdays according to entries from the address book.

Rep: (189)
* The ONE1, and what firmware?
And why does recovery ask for a password? Before flashing the graphic key, fingerprint, etc.?

Rep: (189)
For me, a smartphone is primarily a small computer, and only then a telephone.
And, since I can’t live without a handheld computer since 1996 (when I got the Psion 3c PDA), the concept of "cell phone" for me existed only for a short time. At this time, PDAs and cell phones were separated.
But since 2002, I have been using "all in one" - communicators Rover S2 and a little later Qtek S100. (Well, then it went, went!: D)

P.S. By the way, why does the author of the branch look so narrowly at things ?!
Personally, I have not only not used push-button cell phones since 1996, but also watches, alarms, notebooks, etc. Since (in my opinion) 2003 I have not used topographic maps - they were then replaced by a bunch of Qtek S100 + Bluetooth GlobalSAT BT-338 + navigation software ...

Post has been editedmkudritsky - 17.08.19, 18:39

Rep: (189)
I noticed that recently an abnormally large number of articles about space, galaxies, stars have appeared on the main page of the site.
I myself like to read space fiction, but here somehow the space is in sharp contrast with the theme of the site. Especially in such large doses!

Although how to say?
Radio astronomy experts say that all smartphones in the world can be combined into one large radio telescope the size of the Earth! : D

Post has been editedmkudritsky - 12.08.19, 21:53

Rep: (189)
Again, something version 2.962 crashes.
So far I only checked on the Asus Zenfone 5 A500KL device on Android 5.0.0 32bit.
Rolled back to the good old 2.95.

Z.Y. Guys, how on v2.95 to make the device disconnect itself, say, 2 minutes after the video has ended?
And then it happens to me like this: I turn on the video, while watching I fall asleep: D, after three hours I wake up - the video has long been over, the screen of the device is on, charging 2%. Fortunately, on all my devices where the subject is installed, IPS screens. So only the battery suffers.

Post has been editedmkudritsky - 10.08.19, 14:10

Rep: (189)
I want to express my gratitude to the developers of the firmware - the screensaver in the form of a blank page has again returned to the device on the latest firmware arriving through the air!

I read here about the problems with the flash drive.
Yes, unpleasant.
I took my book PocketBook 626 Plus around the end of 2016. I think that in one of the last production batches.
(I always do this with all gadgets - I try to take devices from the last installments, as manufacturers usually eliminate identified hardware mistakes at this point).

And the question, in fact, is this: in PocketBook 626 Plus of the last installments, a mistake with a flash drive was eliminated or not?
What does statistics say about this?

Post has been editedmkudritsky - 10.08.19, 09:26

Full version

Help     rules

Now: 08/30/19, 10:35 a.m.