Rep: (326)
Invalid sparse file format at header magi

Your fastboot.exe simply does not understand a large thinned image (sparse) with a system partition. It is necessary to select the appropriate, different versions are walking in the open spaces of the network. Therefore, I propose to flash the firmware from the SD card as written in the instructions. It uses the "flasher" built into the smartphone, and the firmware settings (and some libraries) are taken from the stock archive. Therefore, it is stitched correctly at 100%. Or flashing it separately through TWRP.
I threw the files boot and system on the USB flash drive, while the computer gave an error that the file is too large for this system partition (fat32). Formatted, made ntfs, uploaded files, no files

Boot can no longer flash, you have already flashed it higher through fastboot. Only system.img through TWRP firmware. To copy a file larger than 4 GB to a flash drive, you need to format it in exFAT, your smartphone does not understand NTFS. You can also copy, being in TWRP, system.img directly from the computer to the internal memory (which is 8 GB) of the smartphone, it is in ext4, there are no restrictions on the file size.

Post has been editedAmigaser - Today, 13:51



Rep: (326)
Olegl @ 07.17.19, 08:08*
Or is there only 3g?

For HTC Desire 820G, it's like as soon as 3G. For Qualcomm models, there is support for 4G.



Rep: (326)
* Drummicchecka, This is a console utility. Copy your stock firmware to its folder. Open the console in the folder with it and type RUU_Decrypt_Tool.exe<firmware name>.zip (rename short). Answer all questions Y. After unpacking, the OUT _.... folder will appear, and in it the system folder with boot.img and system.img.



Rep: (326)
* Drummicchecka, Are you reading between the lines? I wrote what you need to unpack the stock firmware. Ordinary archiver does not open it.



Rep: (326)
Olegl @ 07.16.19, 18:14*
350m free

So what's so surprising? The OS uses RAM for its system processes and parameters, you know ... Yes, and the programs that you have running are also loaded into RAM and even use their data there. So everything is fine. Physical RAM you have 2 GB.



Rep: (326)
Olegl @ 07.16.19, 18:07*
cpu-z

Can it free memory?



Rep: (326)
* Olegl, where is it shown?



Rep: (326)
Drapmicchecka @ 07.16.19, 17:38*
When installing the OPJXIMG firmware via TWRP, it gives an error Invalid argument

I kinda wrote clearly above - DO NOT INSTALL the firmware through TWRP, do not even try. The stock is installed either from the SD card, or via fastboot from the computer.
Drapmicchecka @ 07.16.19, 17:38*
Fastboot is also sewn with errors

Write at least what specific errors you write, error is different ... If you cannot flash from the card or computer via fastboot, you can try UNPACKING the stock firmware on your computer with the help of specials. utilitiesHTC RUU / ROM Decryption Tool, throw the boot.img and system.img pulled out of it into the memory of the smartphone and flash them sequentially through TWRP. This is usually enough to start the system.
Drapmicchecka @ 07.16.19, 17:38*
also OTA firmware.

OTA update is stitched only through stock recovery or from the system through the air. But I would not risk until you restore the basic stock firmware, otherwise you can get a completely non-recoverable "brick".

Post has been editedAmigaser - Yesterday, 18:03



Rep: (326)
Drapmicchecka @ 07.16.19, 16:27*
I threw the firmware on the flash drive, but the computer does not see it, like the phone itself.

And what have the computer? For firmware drain from the SD card, the computer is not needed. In general, in order for the computer to see the smartphone in the device manager, you needHTC driverto install. Have you installed it? And the smartphone needs to be loaded into the download mode (turn on with the holding of the book. "Power" and "c. Minus").
Drapmicchecka @ 07.16.19, 16:27*
I tried to flash through TWRP, but I always get the same error: Digest file was not found.

Yeah, does TWRP mean you already have it? Disable the hashing check (digest) in the settings. And, by the way, do not flash the stock firmware via TWRP if you are trying to flash it. It is not intended for this. Or sew something else? System and boot?
Drapmicchecka @ 07.16.19, 16:27*
I tried to install native recovery via fastboot, I write a command: fastboot flash recovery name.img, no response from the console

So if the computer does not see the smartphone, then there will be no clear reaction. Do you have a smartphone in firmware mode (download)? After you install the driver and the smart appears in the device manager as My HTC, you can check the console response of the smartphone by ADB in the console by typing in it the command fastboot devices. In response, the serial number of the smartphone should come. And why do you need a "native" recovery? TWRP is much better, can do the same thing and much more ...
Drapmicchecka @ 07.16.19, 16:27*
And now I can not get into the recovery. What to do?

And how did you get into it at all?

Post has been editedAmigaser - Yesterday, 17:20



Rep: (326)
* BAMBUK6677, Well, it means exactly the problems with the eMMC chip.



Rep: (326)
* BAMBUK6677,
Well, if it is not stitched from the SD card, then what else can you do? And why not flash? What's happening?



Rep: (326)
* BAMBUK6677,
you most likely flew flash memory. Take it to the SC to replace the mat. fees.



Rep: (326)
* shtorma,
Try to download the firmware. Also, you may need to replace the SD card, preferably with a new one.

Post has been editedAmigaser - Yesterday, 00:54



Rep: (326)
TWRP recovery version TWRP 3.2.1 for HTC Desire 820u (it seems there wasn’t yet)
For odnosimochnogo:
Attached filetwrp-3.2.1-0-a51tuhl_unofficial.img(31.3 MB)

For dvuhsimochnogo:
Attached filetwrp-3.2.1-0-a51dtul_unofficial.img(31.3 MB)

Attached Image

Fastboot commands for downloading and flashing via ADB:
fastboot boot twrp-3.2.1-0-a51tuhl_unofficial.img
fastboot flash recovery twrp-3.2.1-0-a51tuhl_unofficial.img

fastboot boot twrp-3.2.1-0-a51dtul_unofficial.img
fastboot flash recovery twrp-3.2.1-0-a51dtul_unofficial.img


Post has been editedAmigaser - 15.07.19, 22:41



Rep: (326)
* ss1vv,
I still have these TWRP -HTC Desire 820 - Discussion (Post Amigaser # 77019388), though they are for other models, but what the hell is not joking ...



Rep: (326)
On the first screen, a red inscription began to appear with the text “This build is for development purposes only. Do not distribute outside of HTC’s written permission. Failure to comply with legal action

And what version of TWRP were you stitching? Try another from that post of mine. There were similar problems with a person with a smartphone - one to one that you have. All this is very similar to the problematic flash memory, because there was a message that this TWRP normally works for another person with the same model and firmware.

Post has been editedAmigaser - 15.07.19, 22:36



Rep: (326)
Now only began to appear red inscription.

This is understandable, so for everyone who asked for a custom recovery instead of a stock one.
I have A51_UL PVT, but a phone with 2 SIM cards. Maybe this is the problem?

This is very strange because the PID for the duplicate is A51_DTUL.HTC Desire 820 - Discussion (Post Amigaser # 80050042)
TWRP may not work because of non-compliance of iron with the core. Well, try to flash the original Chinese, although it hardly helps ...
Attached fileHTC_A51_TWRP_Recovery_3.0.2-0_htcui.com.img(30.24 MB)

How is it all over?

And nothing, apparently on the TWRP firmware, everything is over, read the thread.

Post has been editedAmigaser - 15.07.19, 22:28



Rep: (326)
* serbus, How do you know that? While these "news" in the status of fakes, when there will be these 10 models at the office. HTC, then we will translate them into reality status: yes2:



Rep: (326)
* serbus, What was it? Today it seems not April 1 ... :) All these insider fakes should not be posted here. When will something at the office. site, then discuss it. Well, in general there is for this special. section on the forum.
https://mobihobby.ru/p...ldfire_s/specification:) I still have a cooler model in the closet - HTC Desire S - at one time the best was on the mobile market ...

Post has been editedAmigaser - 15.07.19, 21:35



Rep: (326)
NIghtKnight26 @ 07.15.19, 14:00*
But how to enter fastboot on it if it does not turn on?

So that's all. I wrote above that you first need to figure out with power, why it does not turn on, and only then look for the firmware (it may not be necessary). The voltage, let's say, is normal for a discharged battery, although a fully charged battery should be around 4.3 V. The charging current is also acceptable. Wait a few hours if ex. does not change, then the battery. you just do not charge. Most likely problems with the charge controller in the smartphone. But first, as an option, you can try to replace the battery with a known normal and charged one.

Full version

Help     rules

Now: 07/17/19 6:47 PM